LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 07-16-2007, 10:15 AM   #31
Tomermory
Member
 
Registered: Mar 2007
Location: Amiens, France
Distribution: Debian Etch,
Posts: 181

Original Poster
Rep: Reputation: 30

Ah! Could we be homing in on the problem?
There is no line in the interfaces file dealing with a default gateway. Would that be 10.0.0.138 in my case (the address to my modem?). I've already posted it, but here is my current interfaces file (copied from Knoppix):

Quote:
# /etc/network/interfaces -- configuration file for ifup(8), ifdown(8)

# The loopback interface
# automatically added when upgrading
auto lo
iface lo inet loopback

allow-hotplug eth0
iface eth0 inet dhcp
pre-up ifconfig eth0 up

allow-hotplug eth1
auto eth0

iface eth1 inet dhcp

iface eth2 inet dhcp

auto eth2

auto eth1
 
Old 07-16-2007, 10:42 AM   #32
farslayer
Guru
 
Registered: Oct 2005
Location: Willoughby, Ohio
Distribution: linuxdebian
Posts: 7,231
Blog Entries: 5

Rep: Reputation: 189Reputation: 189
Your displayed interfaces file is for DHCP addressing not Static IP addresses...

It's difficult to help you if you are going to switch back and forth between static and dynamic addressing every other post.. Your displayed configuration is for Dynamic addressing on Both Ethernet interfaces.

With Dynamic addressing your router or DHCP server would assign the Default gateway and DNS servers. your config should work fine for either interface you are using, and BOTH should not be plugged in at the same time.

With Static addressing you need to specify every piece of address info yourself, from the IP address, to the Gateway and DNS Servers, etc..


Exactly HOW do you want this setup and working, Static addressing or DHCP ?
Which interface do you plan to use ?

There is no need to have an interface you are not using try to come up automatically it just slows down the boot process and doesn't get used anyway.
 
Old 07-16-2007, 11:35 AM   #33
Tomermory
Member
 
Registered: Mar 2007
Location: Amiens, France
Distribution: Debian Etch,
Posts: 181

Original Poster
Rep: Reputation: 30
Quote:
It's difficult to help you if you are going to switch back and forth between static and dynamic addressing every other post..
Sorry about that!The way I want to set this up is to have a static address on this (Debian) computer so that it can communicate with another (Ubuntu machine) I'm not sure about which interface I need to use. The way I saw it, there was one Ethernet card, which I had put in so that I can set up this network, and one external ADSL modem. I imagined that the external modem was eth0 and the card was eth1. I had no idea what eth2 was. Now I realise that this was all wrong, absolutely wrong! Now I understand (hopefully this is nearer the picture?!) that eth0 is firewire, and so redundant, and that eth2 is the Ethernet card. Eth1, then, needs to come down as it doesn't correspond to anything in the computer. Trouble is, the computer behaves as though it does correspond to something! I hope this is coherent! I'm just one hell of a newhie when it comes to networking, and I've only been using Debian for around a month.
 
Old 07-16-2007, 02:58 PM   #34
farslayer
Guru
 
Registered: Oct 2005
Location: Willoughby, Ohio
Distribution: linuxdebian
Posts: 7,231
Blog Entries: 5

Rep: Reputation: 189Reputation: 189
lets jump back to Page 1 of this thread then and look at the sample config i posted for you.. .


Code:
it-etch:/usr/src/linux# cat /etc/network/interfaces
# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
allow-hotplug eth0
iface eth0 inet dhcp
# auto eth0

# The Secondary network interface
allow-hotplug eth1
iface eth1 inet dhcp
# auto eth1

# The Tertiary network interface
# allow-hotplug eth2
# iface eth2 inet dhcp
auto eth2
iface eth2 inet static
address 192.168.0.1
netmask 255.255.255.0
gateway 192.168.0.138
network 192.168.0.0
broadcast 192.168.0.255
The only 2 sections you should need active are lo which is your loopback interface and eth2 since that is the physical network interface you have decided to use.

According to your earlier post (output of lspci) there are actually 2 physical network interfaces on your motherboard, so there should be 2 physical network jacks on the back of the PC. one of them will be eth1 and the other is eth2.

so with this information in your /etc/network/interfaces file and the cable plugged into the appropriate physical network interface jack in the PC, your machine should have a Static IP address of 192.160.0.1 and the Other interfaces should be down (because the auto ethX lines are commented out for those interfaces.)

It really shouldn't be any more complicated than that...



It is really odd that your router is 192.168.0.138 and your PC is 192.168.0.1 those settings are backwards from the default configuration of most routers.

Most routers are either 192.168.0.1 or 192.168.0.254.
Most routers start handing out DHCP addresses in the range of 192.168.0.100 - 192.168.0.200

but if the information you provided is correct the configuration in this post should work.




Another item that is odd is that every time you have DHCP enabled you are showing IP addresses in the 10.0.0.0 network, not 192.168.0.0 .

Are you sure your network is configured for 192 address range ?

You mentioned you had another PC on the network and it is working fine..
Just for sanity's sake could you post the IP setting of that workstation ?

Last edited by farslayer; 07-16-2007 at 03:02 PM.
 
Old 07-16-2007, 03:36 PM   #35
Tomermory
Member
 
Registered: Mar 2007
Location: Amiens, France
Distribution: Debian Etch,
Posts: 181

Original Poster
Rep: Reputation: 30
Thanks for all your help with this, farslayer. I'm a teacher, and I know how exasperating it can be when a student fails to understand, despite all your efforts! Actually, I've read through all the posts again and I can see that I've learned a lot since the beginning - so thanks once again. Now I need to go away and find some more information to clear this up:

Quote:
Most routers are either 192.168.0.1 or 192.168.0.254.
Most routers start handing out DHCP addresses in the range of 192.168.0.100 - 192.168.0.200
And this too:

Quote:
Another item that is odd is that every time you have DHCP enabled you are showing IP addresses in the 10.0.0.0 network, not 192.168.0.0
But I want to clear this up now:

Quote:
You mentioned you had another PC on the network and it is working fine..
This isn't quite true. I had connected these two computers up before, in the bad old days when I only had Windows on both machines. Then I was able to connect them together using the Windows tools and quite a bit of help from a colleague.

Last edited by Tomermory; 07-16-2007 at 04:28 PM.
 
Old 07-16-2007, 04:22 PM   #36
Tomermory
Member
 
Registered: Mar 2007
Location: Amiens, France
Distribution: Debian Etch,
Posts: 181

Original Poster
Rep: Reputation: 30
Following what I said in the post above, I've just found the following information on the web page of my Internet provider. I don't know if it helps, but here it is:

Primary DNS: 194.117.200.10
Secondary DNS: 194.117.200.15
SubnetMask: 255.255.255.0
Domain name: club-internet.fr

On another page, they explain how they attribute the modem IP addresses. Here is my translation:

Quote:
The default range of local IPs is set for the Speed Touch 530 modem as 10.0.0.X (where X is a number between 1 and 255.)
By default, the Speed Touch 530 modem is assigned the address 10.0.0.138. Therefore the other possible IP addresses range from 10.0.0.1 to 10.0.0.255 (excepting 10.0.0.138, which is reserved for the Speed Touch 530 modem.)
As for the IP 192.168.0.1 - it was me personally who gave this computer that address, and the client computer 192.168.0.2. Do I take it that I should have chosen something like 10.0.0.1 and 10.0.0.2? If so, I can't understand why my old Windows network worked as these were the exact IPs I used.

Last edited by Tomermory; 07-16-2007 at 04:27 PM.
 
Old 07-16-2007, 08:15 PM   #37
farslayer
Guru
 
Registered: Oct 2005
Location: Willoughby, Ohio
Distribution: linuxdebian
Posts: 7,231
Blog Entries: 5

Rep: Reputation: 189Reputation: 189
Do you have a broadband router hooked up between your Broadband modem and the computers ? if you do have a router it would typically assign addresses in the 192.168.0.0 Range.. from what I can see that functionality may be built into your modem...

I'm asking you a lot of questions so I can try and get a clear picture of what is going on and figure out exactly where our disconnect is so we can get you running.. Yes it can be frustrating and at time I wish I had a white board so I could draw a picture it would make explanations so much easier

it looks like part of the problem is we have been trying to assign an address in the wrong IP range to get you online..

Code:
it-etch:/usr/src/linux# cat /etc/network/interfaces
# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
allow-hotplug eth0
iface eth0 inet dhcp
# auto eth0

# The Secondary network interface
allow-hotplug eth1
iface eth1 inet dhcp
# auto eth1

# The Tertiary network interface
# allow-hotplug eth2
# iface eth2 inet dhcp
auto eth2
iface eth2 inet static
address 10.0.0.1
netmask 255.255.255.0
gateway 10.0.0.138
network 10.0.0.0
broadcast 10.0.0.255
Try these addresses for your Static IP address..

the second computer can then be 10.0.0.2 and so on..

If that works and the PC's are online... we can look at what it will take to make them talk to each other on you local network.
 
Old 07-17-2007, 01:10 AM   #38
Tomermory
Member
 
Registered: Mar 2007
Location: Amiens, France
Distribution: Debian Etch,
Posts: 181

Original Poster
Rep: Reputation: 30
Sorry, farlayer, that doesn't work!!! I've tried editing your file to disable eth2 and enable eth1, and I've also edited it to enable both. But as soon as we assign a static IP, the Internet comes down. I'm going to write to my Internet provider to see if there is anything funny about the modem. It'd surprise me, though, as it's very common - and as I said, the network did work under Windows.

Quote:
Do you have a broadband router hooked up between your Broadband modem and the computers ?
No, there is no router. It is a simple ( ) crossover connection between two computers.
 
Old 07-17-2007, 11:33 AM   #39
Tomermory
Member
 
Registered: Mar 2007
Location: Amiens, France
Distribution: Debian Etch,
Posts: 181

Original Poster
Rep: Reputation: 30
Great news, farslayer I've got the Internet working with a static IP! And I've managed to switch off eth1 and eth0! Simple solution - I knew it would be something dumb! The netmask was wrong! 255.0.0.0 and not 255.255.255.0! Next step, configuring the other computer.
 
Old 07-17-2007, 12:12 PM   #40
Tomermory
Member
 
Registered: Mar 2007
Location: Amiens, France
Distribution: Debian Etch,
Posts: 181

Original Poster
Rep: Reputation: 30
OK, I've just tried configuring the second computer but the two computers don't see each other. I guess this problem will be much more straightforward than the last, though!
Here are the parametres I put in the second computer:
Configuration: static IP address
IP address: 10.0.0.2
Subnet mask: 255.0.0.0
Gateway address: 10.0.0.1

Host: james1

DNS servers: 10.0.0.1

Search domain: debian.

I'm not at all sure about the last two. For this computer they were: DNS servers: debian; Search domain: Ian. Do I need to change these settings on the second computer to read the same as the first?
 
Old 07-19-2007, 02:30 AM   #41
Tomermory
Member
 
Registered: Mar 2007
Location: Amiens, France
Distribution: Debian Etch,
Posts: 181

Original Poster
Rep: Reputation: 30
I'm going away for a month, and I won't be able to look into this problem until I get back. I'll post a new thread then, as I still can't get these two computers to see each other.
Once again, thanks a lot for your help - I'd never have got this far without it.

Cheers

James
 
  


Reply

Tags
debian, local, network, ubuntu


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Please help setting local network leonidg Linux - Networking 3 01-20-2005 06:35 AM
Setting up Mail server for Local Network Deep13 Linux - Software 2 10-30-2003 08:05 AM
Setting up a local network guyd Linux - Networking 12 08-10-2003 02:00 PM
setting up ftp to run on a local network dewyw74 Linux - Newbie 2 01-02-2003 02:33 AM
Problems gettting to local network after setting firewall vendemmian Linux - Networking 0 05-21-2001 11:34 AM


All times are GMT -5. The time now is 04:40 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration