LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 07-12-2007, 04:59 AM   #1
Tomermory
Member
 
Registered: Mar 2007
Location: Amiens, France
Distribution: Debian Etch,
Posts: 181

Rep: Reputation: 30
Setting up local network


Hi,

I'm trying to set up a local network between one computer running on Debian Etch and another on Ubuntu Dapper. This should be easy enough to do, but neither computer sees the other. Here is the procedure I followed, did I miss something?

In the Debian machine I did system --> networking and changed the properties on eth0 to the following:

Configuration: static
IP address: 192.168.0.1
Subnet mask: 255.255.255.0

I validated this and then set up the Ubuntu machine as follows:

Configuration: static
IP address: 192.168.0.2
Subnet mask: 255.255.255.0
Gateway address: 192.168.0.1

When I do a ping on the Debian machine towards the Ubuntu machine, this is what I get:

Code:
james@debian:~$ ping -c5 192.168.0.2

PING 192.168.0.2 (192.168.0.2) 56(84) bytes of data.
From 192.168.0.1 icmp_seq=1 Destination Host Unreachable
From 192.168.0.1 icmp_seq=2 Destination Host Unreachable
From 192.168.0.1 icmp_seq=3 Destination Host Unreachable
From 192.168.0.1 icmp_seq=4 Destination Host Unreachable
From 192.168.0.1 icmp_seq=5 Destination Host Unreachable

--- 192.168.0.2 ping statistics ---
5 packets transmitted, 0 received, +5 errors, 100% packet loss, time 4009ms
, pipe 3
Here is the result of ifconfig:

Code:
debian:/home/james# ifconfig
eth0      Link encap:UNSPEC  HWaddr 00-00-20-ED-00-8B-B3-B6-00-00-00-00-00-00-00-00
          inet addr:192.168.0.1  Bcast:192.168.0.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:290 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 b)  TX bytes:12135 (11.8 KiB)

eth1      Link encap:Ethernet  HWaddr 00:30:BD:BB:43:19
          inet6 addr: fe80::230:bdff:febb:4319/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:191 errors:0 dropped:0 overruns:0 frame:0
          TX packets:73 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:20301 (19.8 KiB)  TX bytes:18588 (18.1 KiB)
          Interrupt:169 Base address:0xdc00

eth2      Link encap:Ethernet  HWaddr 00:20:ED:8F:21:36
          inet addr:10.0.0.1  Bcast:10.0.0.255  Mask:255.255.255.0
          inet6 addr: fe80::220:edff:fe8f:2136/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:7665 errors:0 dropped:0 overruns:0 frame:0
          TX packets:8257 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:6868880 (6.5 MiB)  TX bytes:1280628 (1.2 MiB)
          Interrupt:177 Base address:0xd800

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:200 errors:0 dropped:0 overruns:0 frame:0
          TX packets:200 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:9860 (9.6 KiB)  TX bytes:9860 (9.6 KiB)

I don't know if this is of importance, but when the Debian computer boots in verbose mode, I get a message that DHPDISCOVER is looking at eth1 on 255.255.255.255 on various ports, and fails to find anything. Shouldn't it look on 255.255.255.0? Incidentally, I don't know if this is of importance but before I attempted to set up the network, I got the same message, but rather than looking at eth1 it looked at eth0.
Perhaps I should add that I had managed to establish this connection when both computers were Windows, and I also managed it between Windows and Linux, but since I got rid of Windows I have never been able to connect these two computers.
This problem seems very simple to me, but I haven't found a solution to it by Googling around or by looking at the previous threads on this forum.
Thanks in advance for your help

James
 
Old 07-12-2007, 08:48 AM   #2
farslayer
Guru
 
Registered: Oct 2005
Location: Willoughby, Ohio
Distribution: linuxdebian
Posts: 7,231
Blog Entries: 5

Rep: Reputation: 189Reputation: 189
might I suggest running iptables -L on both machines to see if a firewall is enabled ?

The following shows output on a system with no firewall rules configured..
Code:
it-etch:/usr/src/linux# iptables -L
Chain INPUT (policy ACCEPT)
target     prot opt source               destination

Chain FORWARD (policy ACCEPT)
target     prot opt source               destination

Chain OUTPUT (policy ACCEPT)
target     prot opt source               destination
It's interesting is that most of your traffic is over eth2 (10.0.0.1) RX bytes: (6.5 MiB) TX bytes: (1.2 MiB).

While there is practically ZERO traffic over eth0 (192.168.0.1) RX bytes: (0.0 b) TX bytes: (11.8 KiB)

It's hard for me to guess how you have everything connected.. how are the PC's in the 192.168.0.0 subnet connected together ? Via a switch, crossover cable, other ?
 
Old 07-12-2007, 08:48 AM   #3
tjyorkshire
Member
 
Registered: Jun 2007
Location: UK
Distribution: openSUSE 10.2
Posts: 138

Rep: Reputation: 15
hey,
Firstly the DHPDISCOVER problem shouldn't matter, as you have no DHCP server and you are using static ip addresses.
What happens when you ping the Ubuntu machine towards the Debian machine?
Do you have a firewall that is blocking the packets?
 
Old 07-12-2007, 09:18 AM   #4
Tomermory
Member
 
Registered: Mar 2007
Location: Amiens, France
Distribution: Debian Etch,
Posts: 181

Original Poster
Rep: Reputation: 30
OK, here's what I get when I do iptables -L on the Debian machine:

Code:
Chain INPUT (policy ACCEPT)
target     prot opt source               destination

Chain FORWARD (policy ACCEPT)
target     prot opt source               destination

Chain OUTPUT (policy ACCEPT)
target     prot opt source               destination
When I do the command on the Ubuntu machine, I get the same result.

As for the ping command on the Ubuntu machine, this is what I get:

Code:
james@james1:~$ ping -c5 192.168.0.1
PING 192.168.0.1 (192.168.0.1) 56(84) bytes of data.

--- 192.168.0.1 ping statistics ---
5 packets transmitted, 0 received, 100% packet loss, time 4013ms
It's very strange this business about eth2. I have never (as far as I know) tried to configure eth2, unless by mistake, and in any case when I do system --> networking, eth2 is listed as being unconfigured.
The two computers are simply connected via a crossover lead.

As for DHCPDISCOVER, if it's not needed, is there a way of stopping Debian from looking for it on boot up? It at least doubles the start up time.
 
Old 07-12-2007, 09:27 AM   #5
farslayer
Guru
 
Registered: Oct 2005
Location: Willoughby, Ohio
Distribution: linuxdebian
Posts: 7,231
Blog Entries: 5

Rep: Reputation: 189Reputation: 189
Just spotted something else that is interesting...

Quote:
eth0 Link encap:UNSPEC
Are you sure you configured and are using the right interface ? encapsulation should be ethernet, not unspecified..

do you truly have 3 ethernet cards in that machine ?

lspci to verify the number of NIC's

cat /var/log/dmesg | grep eth - see what eth device is assigned to what hardware

Last edited by farslayer; 07-12-2007 at 09:48 AM.
 
Old 07-12-2007, 09:40 AM   #6
Tomermory
Member
 
Registered: Mar 2007
Location: Amiens, France
Distribution: Debian Etch,
Posts: 181

Original Poster
Rep: Reputation: 30
I'll tell you the whole story! I had a few problems when I was installing Debian, as it asked me questions I found difficult to answer about the network. I'm not sure I got them all right as I'm very weak in this area. Also, I had a funny business with the Internet connection not coming on automatically on start up. I played around with it for a while until I got it working. Perhaps I made a mess of everything - it wouldn't be the first time!
As for the Ethernet card business, this has always struck me as odd. As far as I know, there are only two Ethernet cards in this machine. Well, there were last time I looked! But where on earth does eth2 come from? And Debian isn't alone in flagging up eth2 - I also had it on Mandriva and, I think the other distros I've tried on this machine.
 
Old 07-12-2007, 09:48 AM   #7
farslayer
Guru
 
Registered: Oct 2005
Location: Willoughby, Ohio
Distribution: linuxdebian
Posts: 7,231
Blog Entries: 5

Rep: Reputation: 189Reputation: 189
So did you run the commands I posted ? the results may contain the answers you seek....
 
Old 07-12-2007, 11:02 AM   #8
Tomermory
Member
 
Registered: Mar 2007
Location: Amiens, France
Distribution: Debian Etch,
Posts: 181

Original Poster
Rep: Reputation: 30
My apologies, farslayer, I didn't see your commands at the bottom of your post. Guess that's what comes of my doing too many things at once. Well, here's the Ispci command. I don't know what it all means!

Quote:
debian:/home/james# lspci
00:00.0 Host bridge: Silicon Integrated Systems [SiS] SiS645DX Host & Memory & AGP Controller (rev 01)
00:01.0 PCI bridge: Silicon Integrated Systems [SiS] Virtual PCI-to-PCI bridge (AGP)
00:02.0 ISA bridge: Silicon Integrated Systems [SiS] SiS962 [MuTIOL Media IO] (rev 14)
00:02.1 SMBus: Silicon Integrated Systems [SiS] SiS961/2 SMBus Controller
00:02.3 FireWire (IEEE 1394): Silicon Integrated Systems [SiS] FireWire Controller
00:02.5 IDE interface: Silicon Integrated Systems [SiS] 5513 [IDE]
00:02.6 Modem: Silicon Integrated Systems [SiS] AC'97 Modem Controller (rev a0)
00:02.7 Multimedia audio controller: Silicon Integrated Systems [SiS] AC'97 Sound Controller (rev a0)
00:03.0 USB Controller: Silicon Integrated Systems [SiS] USB 1.0 Controller (rev 0f)
00:03.1 USB Controller: Silicon Integrated Systems [SiS] USB 1.0 Controller (rev 0f)
00:03.2 USB Controller: Silicon Integrated Systems [SiS] USB 1.0 Controller (rev 0f)
00:03.3 USB Controller: Silicon Integrated Systems [SiS] USB 2.0 Controller
00:0b.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)
00:10.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)
01:00.0 VGA compatible controller: nVidia Corporation NV17 [GeForce4 MX 440-SE] (rev a3)
And here is the result of cat /var/log/dmesg | grep eth:

Code:
debian:/home/james# cat /var/log/dmesg | grep eth
eth0: RealTek RTL8139 at 0xdc00, 00:30:bd:bb:43:19, IRQ 169
eth0:  Identified 8139 chip type 'RTL-8100B/8139D'
eth1: RealTek RTL8139 at 0xd800, 00:20:ed:8f:21:36, IRQ 177
eth1:  Identified 8139 chip type 'RTL-8100B/8139D'
eth1394: eth0: IEEE-1394 IPv4 over 1394 Ethernet (fw-host0)
eth1: link down
ADDRCONF(NETDEV_UP): eth1: link is not ready
Hm, it would appear that eth1 is down. I wasn't expecting that!
 
Old 07-12-2007, 11:35 AM   #9
nx5000
Senior Member
 
Registered: Sep 2005
Location: Out
Posts: 3,307

Rep: Reputation: 52
Quote:
00-00-20-ED-00-8B-B3-B6-00-00-00-00-00-00-00-00
Wow that's a looong HW adress
Looks like mine when I put my Wireless in monitor mode.

Could it be firewire, bluetooth, usb?
 
Old 07-12-2007, 11:58 AM   #10
Tomermory
Member
 
Registered: Mar 2007
Location: Amiens, France
Distribution: Debian Etch,
Posts: 181

Original Poster
Rep: Reputation: 30
Quote:
Could it be firewire, bluetooth, usb?
I don't have bluetooth so it couldn't be that.
 
Old 07-12-2007, 12:59 PM   #11
farslayer
Guru
 
Registered: Oct 2005
Location: Willoughby, Ohio
Distribution: linuxdebian
Posts: 7,231
Blog Entries: 5

Rep: Reputation: 189Reputation: 189
From the LSPCI command these are your two onboar Ethernet controllers..
Quote:
00:0b.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)
00:10.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)
This entry from teh dmesg log is a bit confusing though..
Quote:
eth1394: eth0: IEEE-1394 IPv4 over 1394 Ethernet (fw-host0)
IEEE 1394 is Firewire..
I'm not sure why it's listing eth0 next to a Realtec chip AND the firewire entry..

It looks like your REAL Network interfaces are eth1 and eth2 and the Firewire has taken over the eth0 Position.

You may want to edit your /etc/network/interfaces file and see how that goes.. maybe something like this..

Code:
it-etch:/usr/src/linux# cat /etc/network/interfaces
# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
# allow-hotplug eth0
# iface eth0 inet dhcp

# The Secondary network interface
# allow-hotplug eth1
# iface eth1 inet dhcp
auto eth1
iface eth1 inet static
address 192.168.0.1
netmask 255.255.255.0
gateway 192.168.0.254
network 192.168.0.0
broadcast 192.168.0.255



# The Tertiary network interface
# allow-hotplug eth2
# iface eth2 inet dhcp
# auto eth2
# iface eth2 inet static
# address 192.168.0.3
# netmask 255.255.255.0
# gateway 192.168.0.254
# network 192.168.0.0
# broadcast 192.168.0.255
 
Old 07-12-2007, 01:37 PM   #12
Tomermory
Member
 
Registered: Mar 2007
Location: Amiens, France
Distribution: Debian Etch,
Posts: 181

Original Poster
Rep: Reputation: 30
Right, now I've got another problem. I cannot run the text editor:

debian:/home/james# cp /etc/network/interfaces /etc/network/interfaces.backup
debian:/home/james# kedit /etc/network/interfaces
Xlib: connection to ":0.0" refused by server
Xlib: No protocol specified

kedit: cannot connect to X server :0.0
debian:/home/james# kate /etc/network/interfaces
Xlib: connection to ":0.0" refused by server
Xlib: No protocol specified

kate: cannot connect to X server :0.0

What's going on here?
 
Old 07-12-2007, 01:44 PM   #13
nx5000
Senior Member
 
Registered: Sep 2005
Location: Out
Posts: 3,307

Rep: Reputation: 52
Install package: "sux" and then sux kate blah.txt
Or use "sudo" and then sudo kate blah.txt
 
Old 07-12-2007, 01:50 PM   #14
Tomermory
Member
 
Registered: Mar 2007
Location: Amiens, France
Distribution: Debian Etch,
Posts: 181

Original Poster
Rep: Reputation: 30
OK, panic over. I downloaded sux and then ran xhost local:root. Now to work...

Before I change anything, I'd like you to see what's in /etc/network/interfaces. Does it look right?

Quote:
# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

iface eth1 inet dhcp



iface eth0 inet static
address 192.168.0.1
netmask 255.255.255.0

Last edited by Tomermory; 07-12-2007 at 01:52 PM.
 
Old 07-12-2007, 02:12 PM   #15
nx5000
Senior Member
 
Registered: Sep 2005
Location: Out
Posts: 3,307

Rep: Reputation: 52
Nein, not good. Eth0 is your firewire!
eth1 and eth2 are your ethernet wire interfaces
(you don't need the xhost for sux, otherwise sux becomes useless)
 
  


Reply

Tags
debian, local, network, ubuntu


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Please help setting local network leonidg Linux - Networking 3 01-20-2005 06:35 AM
Setting up Mail server for Local Network Deep13 Linux - Software 2 10-30-2003 08:05 AM
Setting up a local network guyd Linux - Networking 12 08-10-2003 02:00 PM
setting up ftp to run on a local network dewyw74 Linux - Newbie 2 01-02-2003 02:33 AM
Problems gettting to local network after setting firewall vendemmian Linux - Networking 0 05-21-2001 11:34 AM


All times are GMT -5. The time now is 01:35 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration