LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 05-12-2011, 03:49 PM   #1
rwl0323
LQ Newbie
 
Registered: May 2011
Location: on the grid
Distribution: WinXP, Win7, Debian, Xbuntu
Posts: 3

Rep: Reputation: 0
setting default sound-card in alsamixer


Hi to All!
This is my first posting here. I have a little experience playing with Linux but I am new to Debian and am very impressed with it outside of my current sound card difficulties.
I have been messing with this sound card issue since I first installed several weeks ago with no solution in sight, I have searched hi and low and tried different things and still no permanent solution. I won't even attempt to list all of the things I have tried.

Very brief details as follows:

According to alsamixer (run in terminal) I have 2 sound-cards, The default being "0 HDA ATI HDMI" and the second one listed as "1 Intel ICH5". The default ati card is actually a sound module(?) on my video card. It does not work....no sound...nada. If I hit F6 "Select sound card" in alsamixer and change the default card to the Intel ICH5 (my actual onboard soundcard!!!) and then exit and reboot, it may work...or not. When Debian is back up and running and I go to a terminal and run alsamixer, if the Intel card is now set as default, I have sound....if not i try again. I have to play this game every time I boot into Debian!!!!!!! As per a posting I read in regards to a similar prob in ubuntu, I included the following line in my alsa-base.conf file "options snd_hda_ati_hdmi index=1"
Problem still persists.
How can I permanently set the intel card to default? Would just as soon remove the ati option all together.

Any help, leads, suggestions would be greatly appreciated!!!!!!

Thank You,
Wayne
 
Old 05-12-2011, 06:05 PM   #2
widget
Senior Member
 
Registered: Oct 2008
Location: S.E. Montana
Distribution: Debian Testing, Stable, Sid and Manjaro, Mageia 3, LMDE
Posts: 2,235

Rep: Reputation: 371Reputation: 371Reputation: 371Reputation: 371
Have you gone into your bios and had a look there? You can usually disable one of them there and enable the other. You seem to have both enabled and that could cause problems like you are having.

I like to have the package "gnome-alsamixer installed. It is a very nice gui app that does pretty much what you are doing with the cli alsamixer. Seems to work a little better and it is easier to do on the fly mixing on.
 
Old 05-12-2011, 07:13 PM   #3
rwl0323
LQ Newbie
 
Registered: May 2011
Location: on the grid
Distribution: WinXP, Win7, Debian, Xbuntu
Posts: 3

Original Poster
Rep: Reputation: 0
Thanks for the reply widget. I actually do have gnome-alsa installed. As far as bios settings...the ati is my video card. I don't recall seeing any options in bios for ati sound.
I'm actually trying this atm:

https://help.ubuntu.com/community/SoundTroubleshooting

There is a section close to the end of the page:

"Configuring default soundcards / stopping soundcards from switching"

Note: This section assumes that you have installed each soundcard properly.

*In a shell, type cat /proc/asound/modules

* This will give the the name and index of each soundcard you have currently. Make a note of the names, and decide which one you want to be the default card.
*Now type sudo nano /etc/modprobe.d/alsa-base.conf
* At the very end of the file, add the following (assuming you have 3 cards with module names A, B and C and you want to have them in the order CAB)

options snd-C index=0
options snd-A index=1
options snd-B index=2

*******************************************

My results :

wayne@ibmbox:~$ cat /proc/asound/modules
0 snd_hda_intel
1 snd_intel8x0

which confuses me somewhat considering the snd_hda_intel is apparently the "driver" for the HDA_ATI_HDMI *whatever* on my vid card. Anyhow I edited my alsa-base.conf as follows:

# autoloader aliases
install sound-slot-0 /sbin/modprobe snd-card-0
install sound-slot-1 /sbin/modprobe snd-card-1
install sound-slot-2 /sbin/modprobe snd-card-2
install sound-slot-3 /sbin/modprobe snd-card-3
install sound-slot-4 /sbin/modprobe snd-card-4
install sound-slot-5 /sbin/modprobe snd-card-5
install sound-slot-6 /sbin/modprobe snd-card-6
install sound-slot-7 /sbin/modprobe snd-card-7
# Cause optional modules to be loaded above generic modules
install snd /sbin/modprobe --ignore-install snd && { /sbin/modprobe --quiet snd-ioctl32 ; /sbin/modprobe --quiet snd-seq ; }
install snd-rawmidi /sbin/modprobe --ignore-install snd-rawmidi && { /sbin/modprobe --quiet snd-seq-midi ; : ; }
install snd-emu10k1 /sbin/modprobe --ignore-install snd-emu10k1 && { /sbin/modprobe --quiet snd-emu10k1-synth ; : ; }

# Prevent abnormal drivers from grabbing index 0
options bt87x index=-2
options cx88_alsa index=-2
options snd-atiixp-modem index=-2
options snd-intel8x0m index=-2
options snd-via82xx-modem index=-2
# Keep snd-pcsp from beeing loaded as first soundcard
options snd-pcsp index=-2
# Keep snd-usb-audio from beeing loaded as first soundcard
options snd-usb-audio index=-2
options snd-intel8x0 index=0
options snd-hda-intel index=1

The last 2 lines are the ones i added.

So far after the last reboot it works. I did get a kernal panic on shutdown after making the changes. I'll post if the changes stick as my previous attempts at editing this file seemed to not work.

Wayne

PS: about the kernel panic: prior to some updates this past week, every-time I went into alsamixer and selected soundcard i would get a kernal panic during the reboot....as it was shutting down. After i did this .conf file mod it did it again....idk?
 
Old 05-12-2011, 08:45 PM   #4
widget
Senior Member
 
Registered: Oct 2008
Location: S.E. Montana
Distribution: Debian Testing, Stable, Sid and Manjaro, Mageia 3, LMDE
Posts: 2,235

Rep: Reputation: 371Reputation: 371Reputation: 371Reputation: 371
Wow, my Dell bios just let you enable one and disable the rest (I just have a SB Audigy2 and the integrated one that sounds like a 60s pocket transistor radio).

You might want to back up that file and run as root;
Code:
dpkg-reconfigure -a
Using alsa instead of -a may work too but I think I would just go with -a (shotgun approach).
 
Old 05-12-2011, 09:36 PM   #5
rwl0323
LQ Newbie
 
Registered: May 2011
Location: on the grid
Distribution: WinXP, Win7, Debian, Xbuntu
Posts: 3

Original Poster
Rep: Reputation: 0
Thanks widgit! I think i will have to poke around in the bios a bit more. So far though...after several reboots, my settings seem to be sticking.

and about the kernal panic: This may be a totally unrelated issue as it only seems to happen when i choose "reboot" instead of shutdown....again, only time will tell

Thanks Again!
Wayne
 
Old 06-04-2011, 02:27 AM   #6
dreadmeat
LQ Newbie
 
Registered: Jul 2008
Location: Auckland Gnu Zealand
Distribution: debian testing
Posts: 4

Rep: Reputation: 1
Question default soundcard

i'm sure i tripped over a "default soundcard" gui tool/drop down menu tool a while ago.
from memory it just sat in the panel and you had a wee menu that you could easily change default soundcards.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
HD ATI HDMI interfering with default sound card setting CA0106 RichardT Ubuntu 2 01-06-2010 07:21 AM
Setting the Default Notebook Sound Card? raid517 Linux - Hardware 1 12-17-2006 08:32 AM
Setting default Sound card. Mr.Ampersand() Linux - Software 7 11-08-2005 01:32 PM
Sound problem: alsamixer: function snd_ctl_open failed for default: No such device bootlizard Linux - Software 0 08-22-2004 03:45 PM
Sound - crackling and setting default card VoidHawk Linux - Newbie 0 08-03-2001 10:44 AM


All times are GMT -5. The time now is 01:05 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration