LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 01-16-2013, 04:24 PM   #1
theAdmiral
Member
 
Registered: Oct 2008
Posts: 131

Rep: Reputation: 0
Setting Chrome as default web browser


I am using Gnome 2, with Debian 6.0.6.

I have been thumbing around different alternatives for web browsing utilities, i.e.--Iceweasel vs. Firefox vs. Chrome. I had been using Chrome for a long time, but for some reason thought Iceweasel or Firefox would be better. My reason had to do with Java. Also, I think my reason is that when I clicked on an hyperlink in my Thunderbird client, the client wouldn't open up that page in my browser. I still have that problem, but the Java problem is solved.

Now that I have a retrograde problem such that an hyperlink in Thunderbird will not open up a page in Chrome, I'd like to get that fixed. Chrome keeps telling me whenever I open up a new instance that I can select it as the default browser or to "Not ask again".

I have selected Chrome as the default in Preferences -> Preferred Applications. I have also tried selecting Chrome as the default in Chrome -> Settings -> Default Browser -> <button> "Set Chrome as default web browser". When I do that, though, the button acts like it is dead. It can be pressed, but no change takes effect. I have also tried the Chrome support forum and there is nothing on it there for Linux to speak of.

Has anybody out there had this problem for Chrome in Debian 6.0.6?

Please help.
Thanks in advance.
 
Old 01-16-2013, 06:45 PM   #2
Peacedog
Guru
 
Registered: Sep 2003
Location: Danville, VA
Distribution: Slackware, Windows, FreeBSD, OpenBSD, Mac OS X
Posts: 5,292

Rep: Reputation: 167Reputation: 167
Hi theAdmiral, Have you tried this?

http://productforums.google.com/foru...me/zXH00hCliDE

Quote:
gbroonLevel 2
More message actions
3/23/11
Had this problem myself, not sure if you managed to fix iit but I found it was because /usr/share/applications/google-chrome.desktop didn't exist.

I fixed it by creating a link to the file in /opt where chrome is installed.

# ln -s /opt/google/chrome/google-chrome.desktop /usr/share/applications/google-chrome.desktop
Good luck. ;-)
 
1 members found this post helpful.
Old 01-17-2013, 01:26 AM   #3
jim_p
Member
 
Registered: Aug 2009
Distribution: Debian testing
Posts: 483

Rep: Reputation: 109Reputation: 109
You can run (as root)
Code:
update-alternatives --config x-www-browser
and, assuming chrome is listed as a choise there, set it as the default web browser for your system.
 
Old 01-17-2013, 10:35 AM   #4
theAdmiral
Member
 
Registered: Oct 2008
Posts: 131

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by jim_p View Post
You can run (as root)
Code:
update-alternatives --config x-www-browser
and, assuming chrome is listed as a choise there, set it as the default web browser for your system.
Thank you for your contribution, but I just tried this as you suggested and there was no effect.
 
Old 01-17-2013, 11:33 PM   #5
jim_p
Member
 
Registered: Aug 2009
Distribution: Debian testing
Posts: 483

Rep: Reputation: 109Reputation: 109
If you run
Code:
x-www-browser
in a terminal, which browser shows up? Please don't be epiphany :P

Plus, I think gnome has some option gnome-control-center that allows you to change what gnome uses as default web browser, mail client, terminal etc.
 
Old 01-19-2013, 06:51 PM   #6
theAdmiral
Member
 
Registered: Oct 2008
Posts: 131

Original Poster
Rep: Reputation: 0
If I run

Code:
$ x-www-browser
a fresh instance of Chrome pops open.

I have tried the Gnome Control Center approach, selecting Chrome as the default browser. In my Preferred Applications, the radio button for Open Link in New Tab is selected. The Command field lists

Quote:
/opt/google/chrome/google-chrome
I think. The tail of it is concealed. And it is shaded out. I cannot seem to get to it, if need be.

I also tried to run Gnome Control Center from the command line as superuser. And I got an error message. The error message was:

Quote:
root@debian:/home/john# gnome-control-center

(gnome-control-center:22208): Unique-DBus-WARNING **: Unable to open a connection to the session bus: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.

(gnome-control-center:22208): Unique-DBus-WARNING **: Unable to connect to the running instance, aborting.
 
Old 01-19-2013, 08:15 PM   #7
odiseo77
Member
 
Registered: Dec 2004
Location: London, UK
Distribution: Debian Sid, OpenSUSE 13.1
Posts: 992

Rep: Reputation: 294Reputation: 294Reputation: 294
Quote:
root@debian:/home/john# gnome-control-center
You're launching gnome-control-center as root; try launching it as your regular user. There should be a "Default applications" option somewhere where you can configure your default browser. BTW, I don't remember if, on Gnome2, it is in the control center, or under "System > Administration".
 
Old 01-19-2013, 11:12 PM   #8
theAdmiral
Member
 
Registered: Oct 2008
Posts: 131

Original Poster
Rep: Reputation: 0
Are you understanding my problem here?

My problem is that I try to click on an hyperlink in Thunderbird that would normally open up a new tab to that hyperlink's URL page, but the hyperlink acts like it is dead. I seem to think that we are going about this incorrectly. Wouldn't you agree?

Thanks.
 
Old 01-20-2013, 12:06 AM   #9
jim_p
Member
 
Registered: Aug 2009
Distribution: Debian testing
Posts: 483

Rep: Reputation: 109Reputation: 109
If you click on a url that is not inside a browser nor inside thunderbird, e.g in some instant messenger, does it open in chrome?
If yes, then you have to change the browser (or browser string) thunderbird uses to open up urls, because it may say "firefox %u" for instance. I have no idea where such setting may be located in thunderbird
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Google-Chrome as default browser markush Slackware 9 02-15-2012 02:46 PM
Google Chrome cannot determine or set the default browser. ibbill Linux Mint 2 12-02-2011 07:17 PM
Google's Chrome Web Browser popowich General 69 10-15-2008 02:09 PM
Details about default web Browser & default Email client sudhasmyle Linux - Software 4 06-15-2006 11:45 AM
Setting The Default Web Browser FrostBot Linux - Software 5 11-04-2004 07:55 PM


All times are GMT -5. The time now is 11:04 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration