LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 10-30-2005, 03:45 PM   #1
Lokathor
Member
 
Registered: Oct 2005
Location: Boise, ID
Distribution: Debian testing
Posts: 99

Rep: Reputation: 15
"set bell-style none" won't stop my internal speaker from beeping


In my /etc/inputrc file i uncommented the line 'set bell-style none' like the comment said, but it doesn't keep my computer from beeping every time i use TAB to complete part of a command or filename.

What did I do wrong?
 
Old 10-30-2005, 03:54 PM   #2
slackhack
Senior Member
 
Registered: Jun 2004
Distribution: Arch, Debian, Slack
Posts: 1,016

Rep: Reputation: 46
it takes effect the next time you log in (or su).
 
Old 10-30-2005, 04:04 PM   #3
Lokathor
Member
 
Registered: Oct 2005
Location: Boise, ID
Distribution: Debian testing
Posts: 99

Original Poster
Rep: Reputation: 15
I did it over a week ago, and I have rebooted several tims since.

I just never got around to asking about it util now.
 
Old 10-30-2005, 04:15 PM   #4
slackhack
Senior Member
 
Registered: Jun 2004
Distribution: Arch, Debian, Slack
Posts: 1,016

Rep: Reputation: 46
oh then i don't know, sorry. it's always worked for me on slackware-like distros. must be some debian weirdness.
 
Old 10-30-2005, 05:36 PM   #5
Lokathor
Member
 
Registered: Oct 2005
Location: Boise, ID
Distribution: Debian testing
Posts: 99

Original Poster
Rep: Reputation: 15
Yes, infact it did work on my Slackware computer, which is why i'm left so confused.
 
Old 10-31-2005, 07:40 AM   #6
makuyl
Senior Member
 
Registered: Dec 2004
Location: Helsinki
Distribution: Debian Sid
Posts: 1,107

Rep: Reputation: 53
Did you try setting it per user:
echo "set bell-style none" >> ~/.inputrc
My other idea would include opening the case cover, but you can also try these: http://www.debian-administration.org/articles/110
 
Old 11-12-2005, 09:46 AM   #7
marko80
LQ Newbie
 
Registered: Nov 2005
Posts: 1

Rep: Reputation: 0
The problem is in /etc/inputrc.
If you uncomment the "set bell-style none", it won't work.
That's because there's a space character at the end of that line, and the parser doesn't recognize it.
So you have to delete such character and redo login.
 
Old 11-26-2005, 01:52 PM   #8
Lokathor
Member
 
Registered: Oct 2005
Location: Boise, ID
Distribution: Debian testing
Posts: 99

Original Poster
Rep: Reputation: 15
why oh why would the file have an extra space like that?

anyways, it fixed it, thanks.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
"set bell-style none" doesn't silence my bell. JordanH Ubuntu 7 04-22-2014 10:19 AM
Error: "cannot set groups" by using "su -", pls help nelsonyuen Linux - General 14 07-31-2010 12:24 PM
How to set the size of icons for "Starterbar" in "Gdekslets" Blue Jacket Linux - Software 4 11-23-2005 02:42 AM
how do i get to a "Windows style" desktop screen in SuSE 9.1 xxvm1 Linux - Newbie 18 07-23-2004 11:17 PM
"Fast User Switching" (XP Style) in Linux... cedillo Linux - Newbie 3 12-18-2002 12:42 AM


All times are GMT -5. The time now is 11:26 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration