LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Debian (http://www.linuxquestions.org/questions/debian-26/)
-   -   Screen resolution of Debian 505-i386-kde-CD-1 (http://www.linuxquestions.org/questions/debian-26/screen-resolution-of-debian-505-i386-kde-cd-1-a-827673/)

zanesto 08-21-2010 02:19 PM

Screen resolution of Debian 505-i386-kde-CD-1
 
I just installed debian lenny KDE 5.5, when installing the screen was busy at 100% but when I first loggin in, at least I Had 75% of screen resolution. less than 102x768. What can I do? this new serie résoletion screen but the system allows me to be in graphical mode. To be clear, the system gives me at least 800x400.
i'm using Toshiba Tecra M1 with a standard vga graphic adapter

evo2 08-22-2010 11:11 PM

We need to know what hardware you have and what driver you are using.

The hardware can be found with the following command:
Code:

lspci | grep -i vga

The driver being used can probably be found with:
Code:

grep LoadModule /var/log/Xorg.0.log
Evo2.

zanesto 08-23-2010 04:47 AM

Motherboard :
- Processor Type: Mobile Intel Pentium M, 1400 MHz (14 x 100)
- Name of the motherboard:TOSHIBA Portable PC
- Chipset motherboard :Intel Odem i855PM
- System Memory: 512 Mo (PC2100 DDR SDRAM)


Video Card
: Trident Video Accelerator Cyber-XP4 v6.4823-123.22_1 (32 Mo)

evo2 08-23-2010 07:17 AM

Any chance you could post the output I requested? Not going to be able to help you without it.

Evo2.

zanesto 08-23-2010 08:27 AM

Excuse me Evo2 i'm a english learner.i'm a french man. I want you help me.
For the first command lspci | grep -i vga i get this:
01:00.0 VGA compatible controller: Trident Microsystems CyberBlade XP4m32 (rev 91)

For the 2nd command grep LoadModule /var/log/Xorg.0.log i get this :
(II) LoadModule: "pcidata"
(II) LoadModule: "extmod"
(II) LoadModule: "dbe"
(II) LoadModule: "glx"
(II) LoadModule: "freetype"
(II) LoadModule: "record"
(II) LoadModule: "dri"
(II) LoadModule: "trident"
(II) LoadModule: "mouse"
(II) LoadModule: "kbd"
(II) LoadModule: "vgahw"
(II) LoadModule: "ramdac"(II) Module "ramdac" already built-in
(II) LoadModule: "vbe"
(II) LoadModule: "int10"
(II) LoadModule: "ddc"(II) Module "ddc" already built-in
(II) LoadModule: "fb"
(II) LoadModule: "i2c"(II) Module "i2c" already built-in
(II) LoadModule: "xaa"
(II) LoadModule: "ddc"(II) Module "ddc" already built-in
(II) LoadModule: "int10"
(II) LoadModule: "GLcore"
(II) LoadModule: "synaptics"

these are the output i get. Thank you at all

zanesto 08-26-2010 03:55 AM

Please,ho want to help me. I'm still waiting for your solution. Mr Evo2 i'm waiting for u please. Thanks u one's more again

evo2 08-26-2010 06:20 AM

Opps, sorry I meant to reply, but forgot. I don't have time to help right now, but I'll try to give a proper answer within the next 24 hours.

Cheers,

Nick.

evo2 08-26-2010 06:29 AM

Ok, I had a quick look. Hopefully the following might help.

I looks like the correct driver is in the xserver-xorg-video-trident package. To make sure it is installed please run the following command as root.
Code:

aptitude install xserver-xorg-video-trident
(However, from the grep above, I think it is already installed)

Also can you now please post your /var/log/Xorg.0.log file and your
/etc/X11/xorg.conf file if you have one.


Cheers,

Evo2.

zanesto 08-27-2010 01:34 PM

Thanx you Mr Evo2,i'll try the to do what u told me and i'll give the result within 2 hours because i'm right now in the class,i'm reply from my phone in this time.

zanesto 08-30-2010 05:57 AM

1 Attachment(s)
hi, here is my /etc/X11/xorg.conf:
Quote:

# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "fr"
Option "XkbVariant" "latin9"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
EndSection

Section "Device"
Identifier "Configured Video Device"
EndSection

Section "Monitor"
Identifier "Configured Monitor"
EndSection

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
EndSection

For my /var/log/Xorg.0.log file, i copied and plasted the text, LQ told me that the entered text was too long (37837 characters) only 30000 characters recommaned. so i attached it to this post. Thanx

evo2 08-30-2010 07:54 AM

Seems to be a know problem with this device and driver. Please read the following and try editing your Xorg.conf as shown.

http://ubuntuforums.org/showthread.php?t=1059522

Cheers,

Evo2.

zanesto 08-30-2010 12:59 PM

Thanx i'm gonna try an i'll give you tha result

zanesto 08-30-2010 01:58 PM

Thanx you so much Mr Evo2 for that link, it's help me totally works.thanks for your help

zanesto 08-30-2010 02:06 PM

But i have i other problem with my Wireless adater. The system tells me that no wireless adapter found. on windows my wireless adapter name is
Quote:

Intel(R) PRO/Wireless 2100 LAN 3B PCI Adpater
. what can i do? i have only wireless network at mine the reason why i boot from windows to acces internet but on my Debian, not yet. But befor installing debian i 'd ubuntu in dual boot with windows and the wireless was enabled.
Thanx u so much senio member

evo2 08-30-2010 11:30 PM

I think you need to install the firmware for this card. See:

http://wiki.debian.org/ipw2200

Basically you just need to make sure you have "non-free" in your /etc/apt/sources.list and then install the pacakge as root:

Code:

apt-get install firmware-ipw2x00
If you don't have a wired connection on this machine, download the file on another machine (or os)
http://ftp.us.debian.org/debian/pool...lenny2_all.deb

Then transfer the file to your debian machine. Now install the package as root:
Code:

dpkg -i /path/to/file/firmware-ipw2x00_0.14+lenny2_all.deb
In the above "/path/to/file/" is the location of the file on your machine.

Cheers,

Evo2.


All times are GMT -5. The time now is 10:02 PM.