LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 08-22-2007, 06:49 PM   #1
Tillus
Member
 
Registered: Dec 2004
Posts: 55

Rep: Reputation: 15
Screen res too low on Etch


My screen (Viewsonic E655) uses a resolution far too low. It is set to 800*600 and there seems to be no way to change that to 1024*768 in either GNOME or KDE. It seems like nothing, perhaps, but some programs don't resize to fit the lower resolution, one example being Gimps's printscreen, meaning you can't actually print from Gimp. I hope there is a way to get round this in the installation files, but what do I know? I have read the post-install thread, but didn't find much there.

I'm on a Compaq with

an S3 Virge DX/GX graphics card
Windows XP (where 1024*768 works perfectly. I'm looking at it now)
Etch (It's half through the night, but I think it is - Debian 4.0r0)
Intel PIII 996MHz
256 MB

Thanks in advance
Let me know if I've left something out

Tillus
 
Old 08-22-2007, 07:03 PM   #2
Dutch Master
Senior Member
 
Registered: Dec 2005
Posts: 1,675

Rep: Reputation: 122Reputation: 122
Well, you'll have to manually edit the xorg.conf file. Don't worry, it's not as hard as you might think. Open a root terminal (applications -> accessories) and enter in the root password. Now open gedit with this command:
Code:
gedit /etc/X11/xorg.conf
Right on the bottom (it may also be elsewhere) is a section "screen" and it has a subsection "display" with some values. Next to the "mode" entry you add
Code:
"1024x768"
Make sure you have some whitespace between the value just entered and the next value already there (it's "800x600"), a single tap on the spacebar will do Save the file and reboot. Now you should have the 1024*768 resolution as standard.
 
Old 08-22-2007, 08:34 PM   #3
eco2geek
Member
 
Registered: Feb 2003
Location: Portland, OR
Distribution: openSUSE 10.3, among others
Posts: 141
Blog Entries: 1

Rep: Reputation: 15
(No need to actually reboot your computer; just log out of GNOME, and when gdm comes up, hit Ctrl+Alt+Backspace to kill X. It'll automatically restart, using your new resolution.)
 
Old 08-23-2007, 06:16 AM   #4
Tillus
Member
 
Registered: Dec 2004
Posts: 55

Original Poster
Rep: Reputation: 15
My xorg.conf, by the screen-section, looks something like this:

Quote:
Section "Device"
Identifier "S3 Inc. ViRGE/DX or /GX"
Driver "s3virge"
BusID "PCI:2:9:0"
EndSection

Section "Monitor"
Identifier "Allmän skärm"
Option "DPMS"
HorizSync 28-64
VertRefresh 43-60
EndSection

Section "Screen"
Identifier "Default Screen"
Device "S3 Inc. ViRGE/DX or /GX"
Monitor "Allmän skärm"
DefaultDepth 24
Then comes a section of color depths and resolutions - among them 1024*768 - like this:
Quote:
SubSection "Display
Depth 1
Modes "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480" "640x400" "640x350"
EndSubSection
So, I'm baffelled. Maybe the solution could be renaming the screen from "Allmän skärm" (Generic screen) to something else?

I'll see if the man page gives something, but don't let that stop you from answering. So the conclusion is the screen resolution is present in /etc/X11/xorg.conf already, but isn't selectable in KDE (or Gnome for that matter). Also, in the settings dialog in KDE there is an area called (loosely) Screen settings above resolution, that's greyed out. I hope this gives you an idea.

Thanks
Tillus
 
Old 08-23-2007, 06:42 AM   #5
rickh
Senior Member
 
Registered: May 2004
Location: Albuquerque, NM USA
Distribution: Debian-Lenny/Sid 32/64 Desktop: Generic AMD64-EVGA 680i Laptop: Generic Intel SIS-AC97
Posts: 4,250

Rep: Reputation: 60
Try # dpkg-reconfigure xserver-xorg

I always run it from Single-user mode, but I think it works from a GUI terminal window, as well.
 
Old 08-23-2007, 06:57 AM   #6
Tillus
Member
 
Registered: Dec 2004
Posts: 55

Original Poster
Rep: Reputation: 15
Nope, doesn't do a thing
 
Old 08-23-2007, 07:32 AM   #7
nx5000
Senior Member
 
Registered: Sep 2005
Location: Out
Posts: 3,307

Rep: Reputation: 52
And what about hitting several times ctrl alt +
Never saw a depth of 1 but it looks like its possible from the manpage.
 
Old 08-23-2007, 07:46 AM   #8
Tillus
Member
 
Registered: Dec 2004
Posts: 55

Original Poster
Rep: Reputation: 15
No, the screen just gets strange. More like a deprovement if anything and it's only possible to see part of the screen.
 
Old 08-23-2007, 08:18 AM   #9
nx5000
Senior Member
 
Registered: Sep 2005
Location: Out
Posts: 3,307

Rep: Reputation: 52
Your default depth is 24 and you showed us the line of the display for depth 1.
You also have 1024*768 for depth 24?

You can also try to reconfigure Xorg with X internal reconfiguration:

As root:
X -configure
Then you have a new configuration file with compatible modes and the previous command will tell you how to use it.
 
Old 08-23-2007, 08:38 AM   #10
farslayer
Guru
 
Registered: Oct 2005
Location: Willoughby, Ohio
Distribution: linuxdebian
Posts: 7,228
Blog Entries: 5

Rep: Reputation: 189Reputation: 189
Your config is currently showing this:

Quote:
Section "Monitor"
Identifier "Allmän skärm"
Option "DPMS"
HorizSync 28-64
VertRefresh 43-60
EndSection
According to the manual the specs for your monitor say..
http://www.viewsonic.com/pdf/usergui...user_guide.pdf
Fh :30-65kHz,
Fv :50-100Hz


so your "Monitor" section should look like this..

Quote:
Section "Monitor"
Identifier "Allmän skärm"
Option "DPMS"
HorizSync 30-65
VertRefresh 50-100
EndSection

http://www.viewsonic.com/support/use...ber=e655&go=GO

Last edited by farslayer; 08-23-2007 at 08:40 AM.
 
Old 08-23-2007, 09:55 AM   #11
Tillus
Member
 
Registered: Dec 2004
Posts: 55

Original Poster
Rep: Reputation: 15
I don't know (having looked through the manual at your link) how you arrived at that, but it got me one new resolution: 832*624 at 75 Hz. A step in the right direction?

Last edited by Tillus; 08-23-2007 at 09:56 AM.
 
Old 08-23-2007, 10:18 AM   #12
farslayer
Guru
 
Registered: Oct 2005
Location: Willoughby, Ohio
Distribution: linuxdebian
Posts: 7,228
Blog Entries: 5

Rep: Reputation: 189Reputation: 189
The confusing part is they have 5 manuals for your monitor there.. the Vertical and horizontal refresh rates are different in each one. So being cautious I selected one of the lower ranges. a different manual had the following values listed.

30-70
50-120

I'm sure there is a number on your monitor that would link it to a specific manual so you could verify which values are correct for your specific monitor. If the values are too low then you will not get the higher resolutions you are trying to view.. if the values are too high for what your monitor can support there is a possibility the monitor could be damaged trying to display them.


IS there a label in the back with model name / number of your monitor ? is the model name followed by another number ?
E655
E655-1
E655-2
E655-3
E655-4

Last edited by farslayer; 08-23-2007 at 10:48 AM.
 
Old 08-23-2007, 10:28 AM   #13
makuyl
Senior Member
 
Registered: Dec 2004
Location: Helsinki
Distribution: Debian Sid
Posts: 1,107

Rep: Reputation: 53
Change Default depth from 24 to 16 and restart X.
You can use "xrandr" from a console in X to see available resolutions.

You could also change this:
SubSection "Display
Depth 16
Modes "1280x1024" "1152x864" "1024x768" "832x624" "800x600" "720x400" "640x480" "640x400" "640x350"
EndSubSection

into this:
SubSection "Display
Depth 16
Modes "1280x1024" "1152x864" "1024x768" ##### "832x624" "800x600" "720x400" "640x480"
EndSubSection
 
Old 08-23-2007, 11:22 AM   #14
Tillus
Member
 
Registered: Dec 2004
Posts: 55

Original Poster
Rep: Reputation: 15
Thanks guys!

That really helped! I followed makuyl's advice and it did it. And the rest of you have been wonderful. I have another question, but I take it in another thread. To farslayer: the model no. is E655 no extra dashes or digits. Once again, thanks to all of you. I'll even subscribe to this one, so I don't lose it.

Tillus

Last edited by Tillus; 08-23-2007 at 11:26 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Screen Res. with Etch Installation n1gnichol Debian 6 07-03-2007 10:17 AM
Screen res too low on Thinkpad i1400 bob7 Linux - Laptop and Netbook 1 08-24-2006 06:17 AM
X Window Low Res MarkoSan Debian 1 06-11-2006 09:54 PM
Presentation failor - black screen, low res projector, no input etc etc linuxfond Linux - General 4 02-02-2005 06:39 AM
Low Screen Res KB1JIJ Linux - Newbie 5 09-13-2003 03:01 PM


All times are GMT -5. The time now is 05:31 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration