LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Debian (http://www.linuxquestions.org/questions/debian-26/)
-   -   SCIM doesn't work (http://www.linuxquestions.org/questions/debian-26/scim-doesnt-work-331241/)

Mathsniper 06-07-2005 10:39 AM

SCIM doesn't work
 
I have installed scim using command, apt-get install scim scim-tables-zh. and then i create and modify /etc/X11/Xsession.d/95input
Code:

/usr/bin/scim -d
export XMODIFIERS="@im=SCIM"
export GTK_IM_MODULE="scim"
export XIM_PROGRAM="scim -d"
export QT_IM_MODULE="scim"

The SCIM was loaded each starting KDE. But I can't press Ctrl+Space to type chinese. What's matter?(I didn't modify SCIM setting)

damienduff 06-08-2005 02:23 AM

i am sure u can find a lot of information if u search for "SCIM"

Mathsniper 06-08-2005 06:23 AM

okay, but i can't see chinese on debian system. do i need to install package? (i wanna use english system, not chinese system)

damienduff 06-08-2005 12:46 PM

yup, mine is english system too.

i try to make my explanation simple.

apt-get install ttf-arphic-* kde-i18n-zhcn kde-i18n-zhtw
u can oso install the firefly fonts from taiwan if u wish.

apt-get install scim scim-chinese scim-gtk2-immodule

now we need to install locales, so run command "dpkg-reconfigure locales"

select the chinese locales u want but at the next screen, choose en_US.utf8 as default.

(i did not modify /etc/X11/Xsession.d/95input as u did.)

put this in .bashrc
export LC_CTYPE="zh_CN.gb2312"

if possible, please install the simsun and simhei fonts too.
i believe simsun is 简体 and simhei is 繁体。You haf to use defoma for this, but tats a long and different story. scim should now work in some programs but not all.

hkl8324 06-08-2005 01:13 PM

Re: SCIM doesn't work
 
Quote:

Originally posted by Mathsniper
I have installed scim using command, apt-get install scim scim-tables-zh. and then i create and modify /etc/X11/Xsession.d/95input
Code:

/usr/bin/scim -d
export XMODIFIERS="@im=SCIM"
export GTK_IM_MODULE="scim"
export XIM_PROGRAM="scim -d"
export QT_IM_MODULE="scim"

The SCIM was loaded each starting KDE. But I can't press Ctrl+Space to type chinese. What's matter?(I didn't modify SCIM setting)

i can use scim even i didnt add the above lines.....

i just take "one the spot" and "always show XXX(cant remember what exactly is XXX)

using the Scim gconf utilities....

liucougar 06-09-2005 11:40 AM

simhei is 简体 as well ;)

realwhz 03-02-2006 06:43 AM

Hi,

Setting QT_IM_MODULE=scim has no help in fact, since scim does not provide a qt_im_module at all. Another related project, skim, may be responsible for this target.

Anyway, the problem that scim cannot be actived in KDE may be solved as follow:

Run qtconfig, to verify the Input Method of QT application is not On The Spot. Instead, Over the spot may be the correct choice.

Setting XIM_PROGRAM=scim in your 95input configuration file if needed.

Hope these are useful :-)

liucougar 03-02-2006 07:25 AM

install scim-qtimm

daihard 03-02-2006 09:50 PM

I am using Fedora, not Debian, but SCIM works fine with KDE. What I did was add the following lines to my own X script which starts up with X Window.
Code:

export LC_CTYPE=ja_JP.UTF-8
export XMODIFIERS="@im=SCIM"
/usr/bin/scim -d

(I know, it's Japanese, but I'd imagine the basics are the same.)

I also use the English system. I believe you need to set the two environment variables BEFORE you execute "scim -d".

I also installed scim-qtimm following liucougar's advice, but it does not have any effect for me. What is it supposed to do?


All times are GMT -5. The time now is 07:30 AM.