LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 08-30-2004, 09:36 AM   #1
tfotherby
LQ Newbie
 
Registered: Aug 2004
Posts: 3

Rep: Reputation: 0
Unhappy sarge suddenly rebooting (30ish seconds after booting)


I've just downloaded the Debian (Sarge) network installer (RC1) and although the install worked, when the system boots to the "Debain base system configuration" it suddenly reboots. This happens randomly, approximatly 30 seconds into the process of setting the system time, giving the root password, etc.

Any ideas what could be causing this?

I installed Debs by resizing a fat32 partition, using grub to boot into win or linux.

I don't think my problem is the same as thread 223595 but it could be the same as thread 212221.

I don't have time to boot to a terminal so I can't enter any commands to try to solve the problem.
 
Old 08-30-2004, 11:12 AM   #2
R00ts
Member
 
Registered: Mar 2004
Location: Austin TX, USA
Distribution: Ubuntu 11.10, Fedora 16
Posts: 545

Rep: Reputation: 30
I had this same problem when I updated my kernel from 2.4.25 to 2.6.7. The way I got around it was to disable the acpi module (advanced power management). For grub, write something like this:

title Debian GNU/Linux, kernel 2.6.7-1-686
root (hd0,0)
kernel /boot/vmlinuz-2.6.7-1-686 root=/dev/hda1 acpi=off ro hdc=scsi
initrd /boot/initrd.img-2.6.7-1-686
savedefault
boot

And then try it again. Hopefully it will work for you then. Although I'm a little disappointed that I have to disable power management. If anyone has an idea of how to fix the problem without disableing acpi please share.
 
Old 09-08-2004, 02:31 PM   #3
tfotherby
LQ Newbie
 
Registered: Aug 2004
Posts: 3

Original Poster
Rep: Reputation: 0
Angry Doesn't seem to fix it

If I quickly press "e" in the grub bootloader screen it allows me to edit the boot commands and I inserted "acpi=off" in the kernel line. I then pressed "b" to boot.
Unfortunatly this didn't change a thing - the computer still reboots without warning 30 seconds into the process of setting the system time, giving the root password, etc.
any other ideas?
 
Old 09-08-2004, 04:40 PM   #4
HappyTux
Senior Member
 
Registered: Mar 2003
Location: Nova Scotia, Canada
Distribution: Debian AMD64
Posts: 3,513

Rep: Reputation: 63
Re: Doesn't seem to fix it

Quote:
Originally posted by tfotherby
If I quickly press "e" in the grub bootloader screen it allows me to edit the boot commands and I inserted "acpi=off" in the kernel line. I then pressed "b" to boot.
Unfortunatly this didn't change a thing - the computer still reboots without warning 30 seconds into the process of setting the system time, giving the root password, etc.
any other ideas?
I seem to remember reading something about a module being loaded that causes this on the debian-user@lists.debian.org mailing list you may want to search the archives for the last month or so at http://lists.debian.org or search the BTS at http://bugs.debian.org.
 
Old 09-10-2004, 03:17 AM   #5
vavoem
Member
 
Registered: Oct 2003
Location: Rotterdam, the Netherlands
Distribution: Debian Sarge
Posts: 102

Rep: Reputation: 15
I had the same problem and then i used the netinstall from the debian bussinesscard iso (only a 40 MB download or so)
with no problems whatshowever

However this tip is only usefull if you have a broadband connection to the internet

Last edited by vavoem; 09-10-2004 at 03:21 AM.
 
Old 09-10-2004, 09:47 AM   #6
tfotherby
LQ Newbie
 
Registered: Aug 2004
Posts: 3

Original Poster
Rep: Reputation: 0
this problem is in the errata now.

This problem is in the Debian Errata at http://www.debian.org/devel/debian-installer/errata:

Hotplug bugs lead to reboot loops, no display. The version of hotplug installed by rc1 may try to load hardware watchdog modules that cause the system to reboot about 1 minute after they're loaded. Or it might load a frame buffer driver that makes the console unusable. To work around these problems, boot into emergency mode, and either add the unsafe modules (such as "i810-tco") to /etc/hotplug/blacklist, or disable/remove hotplug (warning: disabling hotplug may make USB keyboards unusable). These bugs will be fixed in newer versions of hotplug, but please do let us know if you experience such a bug.

Their advice about going into "emergency mode" doesn't help me because reboot loops still occur.
 
Old 09-10-2004, 09:56 AM   #7
HappyTux
Senior Member
 
Registered: Mar 2003
Location: Nova Scotia, Canada
Distribution: Debian AMD64
Posts: 3,513

Rep: Reputation: 63
Re: this problem is in the errata now.

Quote:
Originally posted by tfotherby
This problem is in the Debian Errata at http://www.debian.org/devel/debian-installer/errata:

Hotplug bugs lead to reboot loops, no display. The version of hotplug installed by rc1 may try to load hardware watchdog modules that cause the system to reboot about 1 minute after they're loaded. Or it might load a frame buffer driver that makes the console unusable. To work around these problems, boot into emergency mode, and either add the unsafe modules (such as "i810-tco") to /etc/hotplug/blacklist, or disable/remove hotplug (warning: disabling hotplug may make USB keyboards unusable). These bugs will be fixed in newer versions of hotplug, but please do let us know if you experience such a bug.

Their advice about going into "emergency mode" doesn't help me because reboot loops still occur.
Thats the one, do you have a knoppix disk handy? If so then boot with it and mount your / partition and edit the file put the module name in there and save the file then reboot to Debian.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
convert total no of seconds in the format hour minutes and seconds suchi_s Programming 15 03-15-2011 11:34 AM
grub suddenly stops booting XP mab_123 Linux - Software 3 03-26-2005 10:08 AM
sarge install problem, keeps rebooting ragamuffin Debian 2 08-29-2004 09:28 AM
SuSE 9.1 / Windows XP suddenly dual booting fails ticker Linux - General 8 06-17-2004 04:44 AM
Suddenly kernels won't finish booting chort Mandriva 5 10-26-2003 03:55 AM


All times are GMT -5. The time now is 04:54 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration