LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Debian (http://www.linuxquestions.org/questions/debian-26/)
-   -   sarge debian alsa sound problem (http://www.linuxquestions.org/questions/debian-26/sarge-debian-alsa-sound-problem-330202/)

lvgandhi 06-04-2005 04:12 AM

sarge debian alsa sound problem
 
I have installed sarge debian in my home pc and dell inspiron with
i810 module. I wanted to use alsa. Hence I added skip i810_audio in
/etc/discover. Though now I don't get i810_audio and all alsa
modules are loaded, I get error notice when I login to kde.
Sound server informational message:
Error while initializing the sound driver:
device /dev/dsp can't be opened (Permission denied)
The sound server will continue, using the null output device.
I have in dmesg as
intel8x0_measure_ac97_clock: measured 49544 usecs
intel8x0: clocking to 47404
. I have done alsaconf and alsactl store also. I have muted external
amplifier also. Still I get error. What to do to make alsa work

kostian 06-04-2005 07:39 AM

but does xmms for example work with alsa plugin selected? or just a simple aplay somefile.wav
AFAIK /dev/dsp is an OSS device so the KDE soundsystem is trying to use OSS but this would only affect the KDE system sounds. You can change it to ALSA in kcontrol.
For the permissions problem check if you are a member of audio group and the permissions of /dev/dsp device.

rickh 06-04-2005 11:02 AM

This thread has proved helpful to several people with similar problems.

Here's another one that I think includes an excellent troubleshooting sequence.

izo 06-11-2005 12:35 PM

hi

You mast be set your user to the sound group

login as root and going to /etc/

Open the group file with your favorite editor and write in sound String your user name

bye !!!!!!!!


All times are GMT -5. The time now is 11:14 PM.