LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 07-15-2005, 02:43 PM   #1
deepclutch
Member
 
Registered: Nov 2004
Distribution: Debian Testing+Sid
Posts: 707
Blog Entries: 1

Rep: Reputation: 32
Post Sarge 3.1 and esd,oss & ALSA problems!


Hi,
I am using sarge 3.1 r0a on custom kernel compiled and a alsamodules .deb packages for support for my intel 915GAV.also i got graphics support from XF86 4.5 .debs from ftp.fifi.org .debs.
My problem is every time i boot into debian ,i need to run:
gconftool-2 --type boolean --set /desktop/gnome/sound/enable_esd false
to disable esd for gstreaamer to work properly for games like ppracer,tuxkart or xmms!.
How to solve this ?as i heard ESD got bugs ! and to make alsa as defaults,will i need to make a script for"gconftool-2 --type boolean --set /desktop/gnome/sound/enable_esd false"
in /etc/init.d to run in startup Question Please Help?

Last edited by deepclutch; 07-15-2005 at 02:45 PM.
 
Old 07-15-2005, 04:29 PM   #2
andywebsdale
Member
 
Registered: Jan 2005
Location: Lewisham,London,UK
Distribution: Debian Wheezy AMD64
Posts: 87
Blog Entries: 2

Rep: Reputation: 23
esound problem

Can't you just UNcheck the box in the gnome control panel that says "enable sound server on startup" if you actually don't want esd to run - I think you may have to do some other stuff to compensate for the lack of esd but I don't know enough - sorry
 
Old 07-16-2005, 11:31 AM   #3
darkleaf
Senior Member
 
Registered: Jun 2004
Location: the Netherlands
Distribution: debian SID
Posts: 2,170

Rep: Reputation: 45
Just disable it. If your card doesn't support hardware mixing you'll need software mixing. The alsasharing wiki page has a file to do that.

You can also try setting all programs to output to alsa.
 
Old 07-16-2005, 04:35 PM   #4
deepclutch
Member
 
Registered: Nov 2004
Distribution: Debian Testing+Sid
Posts: 707
Blog Entries: 1

Original Poster
Rep: Reputation: 32
What is Hardware mixing?any way in windows OS i am getting multiple instances of sound players running.but in sarge ,only alsaplayer will play even when running xmms or rhythmbox.
also 'am not able to play MIDI.WHY?!
plese help?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
ALSA, OSS, ARTS, ESD, GStreamer all sound different. russofris Linux - Software 1 09-02-2005 10:32 PM
suse 9.1 sound problems, alsa & oss EldinTux Linux - Hardware 0 08-23-2004 04:04 AM
Can't use ESD with both OSS and ALSA rpat Linux - Newbie 2 03-24-2004 01:26 PM
ALSA ESD --> no sound, but OSS sound works intense Slackware 1 03-23-2004 03:34 PM
Problems in RH 9 with alsa and esd oss works fine (VIA VT8233) husfeldt Linux - Hardware 1 08-28-2003 07:59 AM


All times are GMT -5. The time now is 09:51 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration