LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 04-21-2011, 02:00 PM   #1
bruceam
Member
 
Registered: Nov 2008
Location: Atlanta, Georiga
Distribution: Debian, Ubuntu
Posts: 63

Rep: Reputation: 15
Running KDE 4.x from Squeeze, Manual Install


I have recently installed Debian Squeeze on my main machine at home. I used the default installation options, which meant gnome was installed as the display manager/GUI. Once I got the system up and running, I have attempted to install the latest KDE display manager/GUI. I executed the following commands:

$sudo apt-get install kde4

and then responded as required when asked if I really wanted to get and install the huge list of programs this involved.

When booting up in runlevel 3, I would log in, and then execute the following command:

$ sudo kdm

the screen would go blank and I would eventually get a KDE error message saying:

"Cannot open theme file @@@ToBeReplacedByDesktopBase@@@"

I would then be given only the option to press OK, which would dump me back out to the command line. I can get the GUI to start by executing "Startx", which doesn't require sudo to run I might add. The problem is that this command starts gnome. I would like to start X from the command line, but be given a choice of either GNOME or KDE.

Question 1: How do I fix the issue which generates the error message detailed above?
Question 2: How do I set up X to ask me which display manager I would like to use? and
Question 3: Am I correct in assuming that KDM shouldn't require sudo to run? If so, how do I adjust the situation so that it is correctly configured to run like gnome (without requiring root access to run)?

Thank you everyone in advance for your assistance
 
Old 04-21-2011, 02:57 PM   #2
andrewthomas
Senior Member
 
Registered: May 2010
Location: Chicago Metro
Distribution: Arch, Gentoo, Slackware
Posts: 1,690

Rep: Reputation: 307Reputation: 307Reputation: 307Reputation: 307
I am not sure how you change the default desktop environment in Debian, but

try using

Code:
ck-launch-session startkde
to start kde.

You cannot start a display manager from the command-line.
 
Old 04-21-2011, 03:12 PM   #3
EDDY1
Guru
 
Registered: Mar 2010
Location: Oakland,Ca
Distribution: wins7, Debian wheezy
Posts: 5,031

Rep: Reputation: 442Reputation: 442Reputation: 442Reputation: 442Reputation: 442
At login window there's a session selection option
click on user name and look at bottom right of screen
there should be an icon that says desktop environment or default with arrow, click on arrow and select kde.
 
Old 04-21-2011, 03:33 PM   #4
andrewthomas
Senior Member
 
Registered: May 2010
Location: Chicago Metro
Distribution: Arch, Gentoo, Slackware
Posts: 1,690

Rep: Reputation: 307Reputation: 307Reputation: 307Reputation: 307
Quote:
Originally Posted by EDDY1 View Post
At login window there's a session selection option
click on user name and look at bottom right of screen
there should be an icon that says desktop environment or default with arrow, click on arrow and select kde.
Yet, the OP stated that he wanted to start x from the command line, not a DM.
Quote:
Originally Posted by bruceam View Post
I would like to start X from the command line, but be given a choice of either GNOME or KDE.
Using a DM to choose the session is the easiest way, yet it can be done from the command line.
 
Old 04-21-2011, 07:09 PM   #5
widget
Senior Member
 
Registered: Oct 2008
Location: S.E. Montana
Distribution: Debian Testing, Stable, Sid and Manjaro, Mageia 3, LMDE
Posts: 2,169

Rep: Reputation: 355Reputation: 355Reputation: 355Reputation: 355
@bruceam
Log in to Gnome and change the default desktop environment. This should make it so that is what comes up on the startx command.
 
Old 05-04-2011, 03:27 PM   #6
bruceam
Member
 
Registered: Nov 2008
Location: Atlanta, Georiga
Distribution: Debian, Ubuntu
Posts: 63

Original Poster
Rep: Reputation: 15
Problem Solution

Thank you to everyone who has contributed to this problem. I have corrected the issue, though I do not know exactly what the problem was. Removed KDE and started from a clean install. I used the same command line to install as I did before, but this time it works. I am able to select between Gnome and KDE at login/bootup, and both are equally usable.

Thank you again to everyone who helped.


Bruce
 
  


Reply

Tags
kde configuration, squeeze


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Deb Squeeze running from USB-stick Phiebie Debian 2 03-08-2011 04:38 PM
Debian Squeeze - apt-get running by itself in the background austinium Debian 9 11-23-2010 11:33 AM
Anybody got Neatx running on Debian Squeeze? jford_oldman Linux - Software 0 01-14-2010 12:58 AM
Members running Squeeze or Sid; questions... linus72 Debian 9 01-03-2010 06:46 AM
why for ksystraycmd, I should install all KDE in SQUEEZE; it wasnt with Lenny :( frenchn00b Debian 2 10-24-2009 12:24 PM


All times are GMT -5. The time now is 01:02 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration