LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 04-29-2011, 02:53 PM   #1
cccc
Senior Member
 
Registered: Sep 2003
Distribution: Debian Squeeze / Wheezy
Posts: 1,615

Rep: Reputation: 47
remove "Suspend" and "Hibernate" from the "Shut Down" applet


Hi

I have squeeze with Gnome.
Howto remove/disable "Suspend" and "Hibernate" from the "Shut Down" applet, so I have just Restart, Cancel and Shutdown?

Last edited by cccc; 04-29-2011 at 02:55 PM.
 
Old 04-29-2011, 03:16 PM   #2
cccc
Senior Member
 
Registered: Sep 2003
Distribution: Debian Squeeze / Wheezy
Posts: 1,615

Original Poster
Rep: Reputation: 47
I've found a solution.

There are two sections in this file:

/usr/share/polkit-1/actions/org.freedesktop.upower.policy

the first for suspend and the second for hibernate.

Near the end of each section will be a line with:
Code:
<allow_active>yes</allow_active>
It should be changed from “yes” to “no” to disable hibernate/suspend:
Code:
<allow_active>no</allow_active>
 
1 members found this post helpful.
Old 05-02-2011, 10:05 AM   #3
cccc
Senior Member
 
Registered: Sep 2003
Distribution: Debian Squeeze / Wheezy
Posts: 1,615

Original Poster
Rep: Reputation: 47
BTW knows someone howto remove "Restart"?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Cannot get to "sleep" or "hibernate" states succesfully with Slack 13.1 bogzab Slackware 14 06-03-2010 12:35 PM
[SOLVED] Cannot "sleep" or "hibernate" my Thinkpad X61 Tablet SaintDanBert Linux - Laptop and Netbook 1 02-01-2010 10:05 AM
net working eth0 eth1 wlan0 "no connection" "no LAN" "no wi-fi" Cayitano Linux - Newbie 5 12-09-2007 07:11 PM
Standard commands give "-bash: open: command not found" even in "su -" and "su root" mibo12 Linux - General 4 11-11-2007 10:18 PM
LXer: Displaying "MyComputer", "Trash", "Network Servers" Icons On A GNOME Desktop LXer Syndicated Linux News 0 04-02-2007 08:31 AM


All times are GMT -5. The time now is 07:15 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration