LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 05-28-2005, 11:29 AM   #1
linuxcalvin
LQ Newbie
 
Registered: May 2005
Posts: 5

Rep: Reputation: 0
Reading of a FAT32 disk in Linux


Hi

On my harddisk there are a FAT32 partion - can i read this in Linux and how ?
 
Old 05-28-2005, 12:51 PM   #2
ToastedToad
Member
 
Registered: Feb 2005
Location: Sequim,WA
Distribution: Debian_sid/Debian_sarge_amd64
Posts: 157

Rep: Reputation: 30
Yes, you can.

# mkdir /mnt/fat32
# mount /dev/hdx /mnt/fat32 (where x is partition number of FAT32)
# exit
$ cd /mnt/fat32
$ ls
 
Old 05-28-2005, 01:17 PM   #3
Dead Parrot
Senior Member
 
Registered: Mar 2004
Distribution: Debian GNU/kFreeBSD
Posts: 1,597

Rep: Reputation: 46
ToastedToad outlines the general mounting procedure but here's a more detailed account for newbies:

(1) Open a terminal window, "su" to root, and do "fdisk -l" to find out how Debian sees your vfat partition.

(2) Open /etc/fstab with the nano text editor ("nano /etc/fstab") and add a line for the vfat partition, something like this:
Code:
/dev/hda1  /mnt/win  vfat  user,noauto,quiet,umask=0  0  0
(You can use the above line if "fdisk -l" shows that your vfat partition is /dev/hda1.) Exit nano saving changes (Ctrl-x, y, Enter).

(3) Create a mount point for the vfat partition ("mkdir /mnt/win").

(4) Become a normal user by hitting Ctrl-d. Mount the vfat partition with "mount /mnt/win". Now you should be able to use your vfat partition from Debian, and you can unmount it as normal user with "umount /mnt/win". (Dropping the "noauto" switch from fstab should make the vfat partition to be automatically mounted at boot time.)
 
Old 05-31-2005, 12:48 PM   #4
linuxcalvin
LQ Newbie
 
Registered: May 2005
Posts: 5

Original Poster
Rep: Reputation: 0
Thanks but ...

Hi

When I write fdisk -l I got:

fdisk -l

Disk /dev/hda: 16 heads, 63 sectors, 4096 cylinders
Units = cylinders of 1008 * 512 bytes

Device Boot Start End Blocks Id System
/dev/hda1 * 4097 39770 17979696 c Win95 FAT32 (LBA)
/dev/hda2 1421 4096 1348704 f Win95 Ext'd (LBA)
/dev/hda5 1421 1639 110344+ 82 Linux swap
/dev/hda6 1640 4096 1238296+ 83 Linux

and when i then write:

mount /dev/hda1 /mnt/fat32

i got the message:

mount: mount point /mnt/fat32 does not exist

why ?
 
Old 05-31-2005, 01:24 PM   #5
linuxcalvin
LQ Newbie
 
Registered: May 2005
Posts: 5

Original Poster
Rep: Reputation: 0
I was wrong

I have to write /mnt/win insted of /mnt/fat32 - so one problem soulved.

BUT i have done what Dead Parrot said but when reboot
I got the following message:

mount: wrong fs type, bad option, bad superblock on /dev/hda1,
or too many mounted file systems
Please check that the disk is entered correctly.

What have I done wrong ?
 
Old 06-01-2005, 03:20 PM   #6
linuxcalvin
LQ Newbie
 
Registered: May 2005
Posts: 5

Original Poster
Rep: Reputation: 0
Thanks to Dead Parrot

I have figured out the problem. So now it works.

Thanks again.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
About mount fat32 disk in linux lonelyghost317 Linux - Newbie 7 06-29-2005 08:42 AM
reading FAT32 partitions in FC3 Digital Surgeon Fedora - Installation 1 02-08-2005 04:20 PM
Reading FAT32 betamike Linux - General 1 10-27-2004 07:47 PM
Reading Fat32 Hard Drive simplexr Mandriva 7 09-03-2003 12:01 PM
use linux to format a FAT32 Hard Disk ? qwijibow Linux - Newbie 4 08-29-2003 08:38 PM


All times are GMT -5. The time now is 06:01 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration