LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 01-13-2007, 01:37 PM   #1
Quakeboy02
Senior Member
 
Registered: Nov 2006
Distribution: Debian Squeeze 2.6.32.9 SMP AMD64
Posts: 3,245

Rep: Reputation: 121Reputation: 121
Ragged firefox fonts on new etch install


I've tried this several times, and I get the same result. After a fresh install of Etch, Firefox has ragged nasty fonts. On a machine that I upgraded from Sarge the fonts are just fine. If someone has a solution I'd love to hear it. I simply do not understand fonts. My next thing to try, I guess is to check the font directories between the two machines to see what's different. Surely someone knows what's happening?
 
Old 01-13-2007, 02:08 PM   #2
rickh
Senior Member
 
Registered: May 2004
Location: Albuquerque, NM USA
Distribution: Debian-Lenny/Sid 32/64 Desktop: Generic AMD64-EVGA 680i Laptop: Generic Intel SIS-AC97
Posts: 4,250

Rep: Reputation: 60
I don't know specifically what's happening, but following the instructions in Section 3 of this howto has always fixed whatever font problems I had.

http://www.tldp.org/HOWTO/Font-HOWTO/index.html

Another thing: There seem to be some problems in the current Etch installer related to Xorg. I always run "# aptitude install xorg" one final time after the installation is complete.

Last edited by rickh; 01-13-2007 at 02:14 PM.
 
Old 01-13-2007, 03:50 PM   #3
Quakeboy02
Senior Member
 
Registered: Nov 2006
Distribution: Debian Squeeze 2.6.32.9 SMP AMD64
Posts: 3,245

Original Poster
Rep: Reputation: 121Reputation: 121
The problem is that I simply cannot figure out what the difference is between the two machines. I have spent a lot of "quality" time with the synaptic package manager with no joy. The only way I can get them to have the same firefox fonts is if I clone the root drive. The FF configuration panel does not give me the same end result. It's driving me mad.
 
Old 01-13-2007, 04:36 PM   #4
war1025
Member
 
Registered: Jul 2006
Distribution: Debian: Squeeze AMD64
Posts: 318

Rep: Reputation: 31
get the msttcorefonts from apt-get. I think thats what i did to fix it on mine.
 
Old 01-13-2007, 05:37 PM   #5
Quakeboy02
Senior Member
 
Registered: Nov 2006
Distribution: Debian Squeeze 2.6.32.9 SMP AMD64
Posts: 3,245

Original Poster
Rep: Reputation: 121Reputation: 121
"get the msttcorefonts from apt-get. I think thats what i did to fix it on mine."

Well, I can't say that it doesn't look better. But, that's after turning off the ability for the pages to load their own fonts (which I had tried before msttcorefonts). I dunno. I never thought fonts mattered at all, until my eyes got old.
 
Old 01-14-2007, 12:03 AM   #6
war1025
Member
 
Registered: Jul 2006
Distribution: Debian: Squeeze AMD64
Posts: 318

Rep: Reputation: 31
I might have had to restart it or something... I can't really remember, but I'm pretty sure those are the only new fonts I installed and I'm fairly sure the problem is with the default font.
 
Old 01-14-2007, 02:10 AM   #7
Quakeboy02
Senior Member
 
Registered: Nov 2006
Distribution: Debian Squeeze 2.6.32.9 SMP AMD64
Posts: 3,245

Original Poster
Rep: Reputation: 121Reputation: 121
It's a funny thing, my problem turned out to be some kind of borked up FF config of the monospace font. Now that I touched it on the machine I liked, it's gone there, as well, probably never to return. I literally looked at every font available to me, and it ain't none of them. I don't know what happened, but at least your pointer motivated me to start banging on it with a big enough hammer to get some understanding and control of the situation. Thanks!
 
Old 01-14-2007, 04:09 PM   #8
war1025
Member
 
Registered: Jul 2006
Distribution: Debian: Squeeze AMD64
Posts: 318

Rep: Reputation: 31
so did you get it working then?

I'd hafta say that is my favorite thing about linux. Any time you have a problem you learn something new about how the whole thing works. Gives you a sense of accomplishment I suppose.
 
Old 01-14-2007, 11:58 PM   #9
Quakeboy02
Senior Member
 
Registered: Nov 2006
Distribution: Debian Squeeze 2.6.32.9 SMP AMD64
Posts: 3,245

Original Poster
Rep: Reputation: 121Reputation: 121
"so did you get it working then?"

Yeah, well enough, I guess. I was a bit concerned about not being able to figure out exactly what had happened. But, since it's just a font issue, I'm not going to let it worry me too much.
 
Old 01-15-2007, 12:32 AM   #10
oldlucky
LQ Newbie
 
Registered: Jul 2006
Location: Australia
Distribution: Debian Etch
Posts: 15

Rep: Reputation: 0
I have had trouble with fonts in Linux in the past "mostly blurry fonts" , i have played around with them for many months until i stumbled across the settings i use now.

Here is my little recipe i use .

First i install msttcorefonts , gsfonts , gsfonts-other and gsfonts-x11.

Then i setup my fonts as follows

http://img181.imageshack.us/my.php?i...referenpo2.png

and

http://img131.imageshack.us/my.php?i...enderinhi4.png


then in Firefox i set them up like this

http://img405.imageshack.us/my.php?i...oxprefezi0.png

and this

http://img131.imageshack.us/my.php?i...t4fontsna4.png

This fixed my font problem as well as my sore eye's , as you can see from the screen shots the fonts are crystal clear and easy on the eye's.

cheers

edit: updated screenshots to current install of etch .

Last edited by oldlucky; 01-16-2007 at 07:33 PM.
 
Old 01-15-2007, 01:01 PM   #11
Quakeboy02
Senior Member
 
Registered: Nov 2006
Distribution: Debian Squeeze 2.6.32.9 SMP AMD64
Posts: 3,245

Original Poster
Rep: Reputation: 121Reputation: 121
"Here is my little recipe i use ."

Thanks! I'll give it a try.
 
Old 01-16-2007, 05:45 AM   #12
Michael_aust
Member
 
Registered: Aug 2005
Location: Lancashire (United Kingdom)
Distribution: Debian Etch, on 686 machine.
Posts: 509

Rep: Reputation: 30
Hvae you tried reconfiguring your fonts?

As root

dpkg-reconfigure fontconfig

Then it gives you three screens with different settigns you can enable and dissable. Play around with this. I cannot remember what settings I changed to get my fonts to look smooth, but play around anabled and disabling until you find a settings thats right.

I was having a similar problem when using kde and this did the trick.
 
Old 01-16-2007, 06:32 AM   #13
radiodee1
Member
 
Registered: Oct 2006
Location: New York
Distribution: Debian
Posts: 673
Blog Entries: 11

Rep: Reputation: 36
Hey, oldlucky, your recipe worked wonders for me. I was having the 'ragged fonts in Firefox' problem too. Thanks a ton.
 
Old 01-16-2007, 07:53 PM   #14
oldlucky
LQ Newbie
 
Registered: Jul 2006
Location: Australia
Distribution: Debian Etch
Posts: 15

Rep: Reputation: 0
Quote:
Originally Posted by radiodee1
Hey, oldlucky, your recipe worked wonders for me. I was having the 'ragged fonts in Firefox' problem too. Thanks a ton.
Glad it helped , i had a hell of a time getting fonts to display to my liking and most

importantly my eyes , i used to get bad eye strain trying to read blurry fonts in Firefox.

I also use the DVI output of my Nvidia 6200 card instead of the vga port this alone has made a huge

difference to my viewing pleasure.

cheers
 
Old 01-19-2007, 10:40 AM   #15
Steve50
Member
 
Registered: Nov 2004
Location: Coventry, UK
Distribution: Debian Lenny, Ubuntu Feisty
Posts: 121

Rep: Reputation: 15
The bitmap fonts seem to cause fonts to look very jagged in firefox, even after installing microsoft fonts. The solution is to run the following command as root and turn off bitmap fonts when you're given the option:

dpkg-reconfigure fontconfig-config
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Using Mozilla Firefox in Etch kel_en Debian 15 04-26-2007 08:56 AM
Upgrading to Firefox 2 (Etch) carlosinfl Debian 6 11-03-2006 08:15 AM
Etch Xorg 7 and fonts cougyr Debian 13 08-19-2006 09:38 PM
installing ttf fonts in debian(etch).... deepclutch Debian 0 07-24-2006 03:01 PM
Need help fixing fonts in Firefox after new Debian install. buckwheat12 Debian 1 07-21-2006 10:53 PM


All times are GMT -5. The time now is 04:08 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration