LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 03-13-2012, 06:42 PM   #1
navic
LQ Newbie
 
Registered: Apr 2007
Location: NY
Distribution: Mint, Ubuntu, Debian, Voyage, Finnix
Posts: 22

Rep: Reputation: 0
Question Quagga permission issue


I'm running the embedded distro Voyage on an ALIX board. It's a derivative of Debian. I've tried the Voyage mailing list with no luck, so hopefully you guys can help me out.

Installed quagga via apt-get install, went fine. I copied over the example files into /etc/quagga then changed the permissions to quagga.quaggavty and chmod 640 as shown on this page but quagga is still failing:

Code:
root@voyage:/etc/quagga# /etc/init.d/quagga start  
Loading capability module if not yet done.
WARNING: All config files need .conf: /etc/modprobe.d/hostap-utils, it will be ignored in a future release.
WARNING: /etc/modprobe.d/ALIX.conf line 8: ignoring bad line starting with 'options'
WARNING: /etc/modprobe.d/ALIX.conf line 9: ignoring bad line starting with 'options'
Starting Quagga daemons (prio:10): zebravty_read_config: failed to open configuration file /etc/quagga/zebra.conf: Permission denied
can't open configuration file [/etc/quagga/zebra.conf]
The zebra.conf file is there:

Code:
root@voyage:/etc/quagga# ls -l
total 12
-rw-r----- 1 quagga quaggavty 849 Mar 13 22:24 daemons
-rw-r----- 1 quagga quaggavty 471 Oct  2 10:22 debian.conf
-rw-r----- 1 quagga quaggavty 385 Mar 13 22:25 zebra.conf
I've tried changing the /etc/quagga directory and files to root.root, quagga.quagga with no luck. Can anyone point me in the right direction?

Thanks!
 
  


Reply

Tags
debian, quagga, user


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Permission Issue xavinux Linux - Server 10 11-08-2011 07:17 AM
permission's issue bibiki Linux - Desktop 1 05-06-2011 12:10 PM
Permission issue linson_85 Linux - General 3 10-24-2010 10:30 AM
Permission issue??? ThunderStrick Linux - Newbie 4 07-07-2009 12:41 AM
issue with permission santasballz Linux - Newbie 7 02-28-2004 12:25 PM


All times are GMT -5. The time now is 06:12 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration