LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 03-09-2005, 04:42 PM   #1
mattz40
LQ Newbie
 
Registered: Mar 2005
Location: Chalottte NC
Distribution: Debian Squeeze 386
Posts: 18

Rep: Reputation: 0
Q3: Slow network response


Last question for today, I swear. If you can fix this one you deserve the nobel prize in networking.

I'm running Debian Woody, bf24 flavor, latest stable release. For the last 2 weeks I was running compact flavor and had the same problem. Thought maybe bf24 would fix it but apparently not. Here's the problem:
My internet connection and connection to the home network is agonizingly slow when connected through a Linksys router (wired connection). When I bypass the router and connect direct to cable modem it's as fast as I could ask for. I've installed and autoconfigured both while connected through the router and direct to cable modem. Same result. While connected through the router web pages will time out befoer completely loaded. Even when ftp'ing to and from a machine in the same room it will time out. One machine works better but it has a different ftp program, but even that one times out and is incredibly slow. I've turned off ipv6, same result. When I bypass the router, I use the same cable. When the Debian machine is connected to the router, the other 2 machines connect and download fine. It doesn't start out slow and speed up. It starts out slow, stays slow, and times out. Occasionally I'll see a burst of speed for a very short period of time.

Here is everything I can think of that might helpful in identifying the problem:

debian:~# netstat -i
Kernel Interface table
Iface MTU Met RX-OK RX-ERR RX-DRP RX-OVR TX-OK TX-ERR TX-DRP TX-OVR Flg
eth0 1500 0 170364 0 0 0 173198 0 0 0 BMRU
lo 16436 0 124 0 0 0 124 0 0 0 LRU

debian:~# netstat -nr
Kernel IP routing table
Destination Gateway Genmask Flags MSS Window irtt Iface
192.168.1.0 0.0.0.0 255.255.255.0 U 40 0 0 eth0
0.0.0.0 192.168.1.1 0.0.0.0 UG 40 0 0 eth0

debian:~# ifconfig
eth0 Link encap:Ethernet HWaddr 00:40:63:CB:E3:B0
inet addr:192.168.1.101 Bcast:192.168.1.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:170471 errors:0 dropped:0 overruns:0 frame:42254
TX packets:173327 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:100
RX bytes:96455505 (91.9 MiB) TX bytes:22696364 (21.6 MiB)
Interrupt:11 Base address:0xec00

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:124 errors:0 dropped:0 overruns:0 frame:0
TX packets:124 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:8218 (8.0 KiB) TX bytes:8218 (8.0 KiB)

debian:~# netstat -s
Ip:
170421 total packets received
0 forwarded
0 incoming packets discarded
170365 incoming packets delivered
173364 requests sent out
Icmp:
0 ICMP messages received
0 input ICMP message failed.
ICMP input histogram:
0 ICMP messages sent
0 ICMP messages failed
ICMP output histogram:
Tcp:
145 active connections openings
0 passive connection openings
0 failed connection attempts
0 connection resets received
2 connections established
169635 segments received
173286 segments send out
19 segments retransmited
0 bad segments received.
3 resets sent
Udp:
74 packets received
0 packets to unknown port received.
0 packet receive errors
78 packets sent
TcpExt:
ArpFilter: 0
44 TCP sockets finished time wait in fast timer
71 delayed acks sent
Quick ack mode was activated 4541 times
163282 packets directly queued to recvmsg prequeue.
146372 packets directly received from backlog
49925987 packets directly received from prequeue
1135 packets header predicted
69815 packets header predicted and directly queued to user
TCPPureAcks: 2751
TCPHPAcks: 217
TCPRenoRecovery: 0
TCPSackRecovery: 0
TCPSACKReneging: 0
TCPFACKReorder: 0
TCPSACKReorder: 0
TCPRenoReorder: 0
TCPTSReorder: 0
TCPFullUndo: 0
TCPPartialUndo: 0
TCPDSACKUndo: 0
TCPLossUndo: 0
TCPLoss: 0
TCPLostRetransmit: 0
TCPRenoFailures: 0
TCPSackFailures: 2
TCPLossFailures: 0
TCPFastRetrans: 0
TCPForwardRetrans: 0
TCPSlowStartRetrans: 0
TCPTimeouts: 10
TCPRenoRecoveryFail: 0
TCPSackRecoveryFail: 0
TCPSchedulerFailed: 8
TCPRcvCollapsed: 0
TCPDSACKOldSent: 10089
TCPDSACKOfoSent: 2180
TCPDSACKRecv: 0
TCPDSACKOfoRecv: 0
TCPAbortOnSyn: 0
TCPAbortOnData: 1
TCPAbortOnClose: 0
TCPAbortOnMemory: 0
TCPAbortOnTimeout: 1
TCPAbortOnLinger: 0
TCPAbortFailed: 0
TCPMemoryPressures: 0

debian:~# vi /etc/resolv.conf
search carolina.rr.com\000
nameserver 24.93.68.64
nameserver 24.93.68.65
nameserver 24.93.68.63
~
~
/etc/resolv.conf: unmodified: line 1



Thanks in advance for using your valuable time to help out.
Matt
 
Old 03-14-2005, 04:18 AM   #2
pingu
Senior Member
 
Registered: Jul 2004
Location: Skuttunge SWEDEN
Distribution: Debian preferably
Posts: 1,285

Rep: Reputation: 119Reputation: 119
This was crazy...
Normally I'd say this is a typical duplex-mismatch, but no collisions and no dropped frames???
Quote:
debian:~# ifconfig
eth0 Link encap:Ethernet HWaddr 00:40:63:CB:E3:B0
inet addr:192.168.1.101 Bcast:192.168.1.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:170471 errors:0 dropped:0 overruns:0 frame:42254
TX packets:173327 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:100
RX bytes:96455505 (91.9 MiB) TX bytes:22696364 (21.6 MiB)
Interrupt:11 Base address:0xec00
Everything looks fine? How long had it been up - received 91.9 MB, transmitted 21.6 MB, how long did that take?
Anyway, I'd set speed and duplex manually on computer and router-port. (I don't know how to do that, unfortunately.)
You get the IP via DHCP, right? If it's static, add it to /etc/hosts as well as gateway.

Not much help, I'm afraid...
 
Old 03-14-2005, 08:56 AM   #3
mattz40
LQ Newbie
 
Registered: Mar 2005
Location: Chalottte NC
Distribution: Debian Squeeze 386
Posts: 18

Original Poster
Rep: Reputation: 0
It had been up all day. The transmitting seemed to go quick, but in spurts. The receiving took the better part of the day. Yes, I'm using DHCP.
I'll try setting the speed and duplex manually. It's worth a shot if I can figure out how. I'm sure it has something to do with the router since it works fine when I bypass it.

Thanks for the advice.
 
Old 03-16-2005, 01:28 AM   #4
pingu
Senior Member
 
Registered: Jul 2004
Location: Skuttunge SWEDEN
Distribution: Debian preferably
Posts: 1,285

Rep: Reputation: 119Reputation: 119
Have you tried connecting to some other port on the router? Maybe it's just one router port that's malfunctioning?
 
Old 03-17-2005, 09:09 AM   #5
mattz40
LQ Newbie
 
Registered: Mar 2005
Location: Chalottte NC
Distribution: Debian Squeeze 386
Posts: 18

Original Poster
Rep: Reputation: 0
Yes, I tried that and got the same result. Tried shutting down the other 2 machines on the router and that did the same thing. Now I'm in the middle of installing sarge as a last ditch effort and that's doing the same thing. Very frustrating.
 
Old 03-17-2005, 10:36 AM   #6
wrat
Member
 
Registered: May 2004
Posts: 245

Rep: Reputation: 30
your resolv.conf looks funky.....what is the "\000" for?
 
Old 03-17-2005, 01:33 PM   #7
mattz40
LQ Newbie
 
Registered: Mar 2005
Location: Chalottte NC
Distribution: Debian Squeeze 386
Posts: 18

Original Poster
Rep: Reputation: 0
I don't know wrat, it was put in there by the DHCP autoconfig.
After installing sarge the \000 is gone but the resolve.conf is identical otherwise. Everything else from my original post is identical also; no errors no drops, no overruns. Works fine when bypassing the router, however the performance is even worse than before when going through the router. I've done quite a bit of googling and the only other thing to try that I've been able to come up with is turning off full duplex. Someting I read said collisions my not be reported. Not sure if that's a via-rhine idiosyncrasy. But I can't find anything that tells me how to turn it off.
 
Old 03-18-2005, 01:33 AM   #8
pingu
Senior Member
 
Registered: Jul 2004
Location: Skuttunge SWEDEN
Distribution: Debian preferably
Posts: 1,285

Rep: Reputation: 119Reputation: 119
I believe the problem is somewhere in the router, not really in Debian - since it works fine if you bypass router.
You can try setting speed and duplex on Debian with mii-tools, try 10 and 100 combined with HD and FD. There's a small chance it might work, very easy to try if you have mii-tool.
The only other thing I can think of is if the router for some reason has two routes to the same network - it shouldn't happen but...
Can you check the routers routing-table? What router is it, and what IP's do the other computers have?
 
Old 04-04-2005, 06:12 AM   #9
pingu
Senior Member
 
Registered: Jul 2004
Location: Skuttunge SWEDEN
Distribution: Debian preferably
Posts: 1,285

Rep: Reputation: 119Reputation: 119
Any success?
I'm interested, because my computer is now doing the same...
Some days downloading at 3000kbps, other days 3kbps!
And it's only my computer, attached to it's own 100-MB port in router. Doesn't help to switch port either.
 
Old 04-05-2005, 09:07 AM   #10
mattz40
LQ Newbie
 
Registered: Mar 2005
Location: Chalottte NC
Distribution: Debian Squeeze 386
Posts: 18

Original Poster
Rep: Reputation: 0
Yes, just the other day I stumbled on the solution. Just for the heck of it I tried using the cable from another machine and it worked fine. So the problem was the cable. What threw me off was that it worked fine when I bypassed the router and connected directly to the cable modem, so I didn't suspect the cable. I should have known, it's one of those cheap retractable travel cables. I wasted weeks on that problem. But it also explains why my laptop won't connect over ethernet when I travel.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Slow SSH response fr0zen Linux - General 7 11-19-2011 12:50 PM
[SOLVED] Very slow network response; Debian 3.0 mattz40 Linux - Networking 5 03-04-2005 10:07 AM
Slow response when network connection is down Stoic Mandriva 5 10-18-2003 05:36 AM
Slow response as ..... umok Linux - Newbie 4 07-11-2003 12:54 PM
Slow response on Mandrake 8.0 Droopy Linux - Networking 0 09-07-2001 09:16 PM


All times are GMT -5. The time now is 12:50 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration