LinuxAnswers - the LQ Linux tutorial section.
Go Back > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Debian This forum is for the discussion of Debian Linux.


  Search this Thread
Old 01-31-2011, 05:45 AM   #1
LQ Newbie
Registered: Feb 2009
Posts: 4

Rep: Reputation: 0
PXE Boot Menu Background


I have just installed our PXE boot server using PXE which chainloads iPXE iPXE loads a menu.cfg which displays a nice menu which allows our employees to choose what to boot (Ghost, GParted, UBCD etc.).

The menu etc. all works fine. To spice it up a bit i want to add a menu background. I know this is possible but i keep failing. I tried to use the following file as a test:

Here is my menu.cfg:
DEFAULT      vesamenu.c32
PROMPT       0
MENU COLOR BORDER 30;44         #20ffffff #00000000 none
MENU COLOR SCROLLBAR 30;44              #20ffffff #00000000 none
MENU COLOR TITLE 0              #ffffffff #00000000 none
MENU COLOR SEL   30;47          #40000000 #20ffffff
timeout 1200

label local
        menu label Boot local HDD
        localboot 1

label ghost
        menu label Symantec Ghost
        menu default
        kernel memdisk
        append initrd=ghost/ghost.img

label abd
        menu label Active Bootdisk
        kernel memdisk
        append iso raw initrd=ABD.iso

label gparted
        menu label GParted
        kernel gparted/vmlinuz1
        append initrd=gparted/initrd1.img boot=live config union=aufs noswap noprompt vga=788 fetch=

label ubcd
        menu label Ultimate Boot CD
        kernel memdisk
        append iso raw initrd=ubcd/ubcd503.iso

label 2xclient
        menu label 2X ThinClientOS LiveCD
        kernel 2xclient/linux26
        append initrd=2xclient/rootdisk26.img quiet console=tty2 bootm=pxe vga=0x311 BOOT_OPT_START udev nofloppy usb2 BOOT_OPT_END ro  oemedition
Now using a .jpg file i get the following screen:

Notice the crap at the top of the screen. That colored line dissapears when i use an 8 bit PNG but the background stays black. I've tried alot of different "How To's" i found online.

Could someone please assist me in this? I'm quite lost



Last edited by bdegier; 01-31-2011 at 05:46 AM. Reason: spelling
Old 01-31-2011, 05:57 AM   #2
Dutch Master
Senior Member
Registered: Dec 2005
Posts: 1,684

Rep: Reputation: 124Reputation: 124
  • check permissions
  • check filenames+extensions
  • check contents of the /tftpboot directory

The link you provided didn't work, this one does:
Old 01-31-2011, 08:07 AM   #3
LQ Newbie
Registered: Feb 2009
Posts: 4

Original Poster
Rep: Reputation: 0
Permissions we're set to root, i changed the splash.png to nobody and nogroup and chmodded the file to 777.

I am not using the tftpboot directory because i'm using iPXE which boots the menu.cfg described above. All these files reside in my www directory because iPXE allows for booting over HTTP.

I will try and check if this helped later today.
Old 02-07-2011, 06:35 AM   #4
LQ Newbie
Registered: Feb 2009
Posts: 4

Original Poster
Rep: Reputation: 0
Sorry for the late reply but things got a little busy last week :-) I set the permissions to what is stated above but it sadly did not work.

Any suggestions?

[edit] I found a site called today and took a look at their bootscripts. I copied the whole thing and dumped it into my menu.cfg

menu hshift 0
menu width 49
menu margin 8
menu color title * #FFFFFFFF *
menu color border * #00000000 #00000000 none
menu color sel * #ffffffff #999999ff *
menu color hotsel 1;7;37;40 #ffffffff #999999ff *
menu color tabmsg * #ffffffff #00000000 *
menu vshift 8
menu rows 10
menu helpmsgrow 16
menu background
prompt 0
allowoptions 0

menu title boot menu
This seems to work slightly. I can now see a purple banner on top of the screen and a small part of the shoe in the picture.

The rest of the screen stays black

Last edited by bdegier; 02-07-2011 at 07:06 AM.


background, boot, pxe

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
pxe boot "PXE-T01 file not found" ssharma_02 Linux - Networking 16 05-18-2011 03:21 PM
PXE Boot Menu Timeout Not Working SGlassman Linux - Newbie 2 05-31-2010 09:54 AM
GRUB2 - FreeBSD-8.0 does not show up in triple boot menu, dual boot menu it does.. wiliweld *BSD 7 05-03-2010 01:05 PM
TimeOut in PXE Menu doesn't work SGlassman Linux - Newbie 1 08-14-2008 08:25 AM
Gnome - no background, icons, and no right-click menu ColinAnderson Linux - Desktop 1 03-08-2007 11:19 PM

All times are GMT -5. The time now is 03:20 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration