LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 08-15-2005, 04:23 PM   #1
kushalkoolwal
Senior Member
 
Registered: Feb 2004
Location: Middle of nowhere
Distribution: Debian Squeeze
Posts: 1,249

Rep: Reputation: 48
PS/2 mouse error in psmouse.c


I have been trying the Debian Sarge Distribution( Kernel 2.6.8) on two Single Board Computers. One has PS/2 port and the mouse is attached to it. I get no problems getting my Debian system running on these boards.

While the other board does not have any PS/2 port so the mouse is attached to USB port. After my installation is finished, when the Debian boots, I get kernel error message:

psmouse.c: bad data from KBC - time out bad parity.

I know that my Linux boots to the login prompt but the rate at which this message is thrown on my screen is so fast that I can't type anything. Everything loads fine except I get these messages continuously and at a very fast rate. It just freaks out.


I googled about this error message and it seems that there is some kind of bug in the kernel and people have suggested to manually change the kernel source such as in this website:
http://klingon.uab.es/gali/presario.html to stop those error messages.

I am really not comfortable with modifying the kernel source and I have never done this before. Is there any other way by which I can achieve this? Does anyone know a patch for this which I can download and patched to my existing kernel?

Also, does anyone know a kernel parameter which we can give at the boot-time to disable all the PS/2 stuff.

Any help will be greatly appreciated.
 
Old 08-15-2005, 06:27 PM   #2
aikidoist72
Member
 
Registered: Jan 2005
Location: Australia
Distribution: Slackware Archlinux FreeBSD
Posts: 218

Rep: Reputation: 30
By the sounds of it the PS/2 mouse connection is built into the kernel. Here lies the problem. You can not - not load it!! It is part of the kernel. Either you need to load another kernel where the PS/2 is compiled as a module(or not at all), or compile a kernel yourself.

Compiling is not too difficult. Like anything it is just a process you need to follow. Configuring the kernel is harder, because you need to know your hardware.
 
Old 08-15-2005, 07:18 PM   #3
kushalkoolwal
Senior Member
 
Registered: Feb 2004
Location: Middle of nowhere
Distribution: Debian Squeeze
Posts: 1,249

Original Poster
Rep: Reputation: 48
Thanks for the help.

How do I compile PS/2 as a module? Do you mean I should go make menuconfig way? Can anyone give more details?

Thanks
 
Old 08-16-2005, 02:57 PM   #4
kushalkoolwal
Senior Member
 
Registered: Feb 2004
Location: Middle of nowhere
Distribution: Debian Squeeze
Posts: 1,249

Original Poster
Rep: Reputation: 48
Unhappy

Does any one have any idea how can I compile the PS/2 mouse drives as Module or completely disable them.

Please help me.
 
Old 08-16-2005, 05:41 PM   #5
aikidoist72
Member
 
Registered: Jan 2005
Location: Australia
Distribution: Slackware Archlinux FreeBSD
Posts: 218

Rep: Reputation: 30
kushalkoolwal

You need to compile a kernel. Although it is not too complicated to do so, it is not something you can't summarize here very well. Also there are a few Distro specific things you may have to have in your configuration in order to compile a working kernel. The best advice is for you to visit your distro's web site for any info regarding this. Once you have done a little research, then attempt to compile a kernel.

Try this a s a google search just to see how much info is out there
Code:
 Kernel Compilation Guide
 
Old 08-17-2005, 04:20 PM   #6
kushalkoolwal
Senior Member
 
Registered: Feb 2004
Location: Middle of nowhere
Distribution: Debian Squeeze
Posts: 1,249

Original Poster
Rep: Reputation: 48
Oh...I think I didn;t make myself clear. Well I have compiled Debian kernel couple of times (The Debian way and not the usual way). What I was asking is where can I find that option once I run the make menuconfig command.

Thanks.
 
Old 08-17-2005, 05:08 PM   #7
aikidoist72
Member
 
Registered: Jan 2005
Location: Australia
Distribution: Slackware Archlinux FreeBSD
Posts: 218

Rep: Reputation: 30
Ahhh righto,

Under the section

Device drivers -> Input device -> mouse

There you will need to unselect the PS/2 option. Just out of interest, have you tried

Code:
make xconfig
I find this much easier to navigate. With the description panel to help you, it makes compiling so much easier. You need to log into root to do this.
 
Old 08-17-2005, 06:07 PM   #8
kushalkoolwal
Senior Member
 
Registered: Feb 2004
Location: Middle of nowhere
Distribution: Debian Squeeze
Posts: 1,249

Original Poster
Rep: Reputation: 48
Thanks!!!! Excellent!!!

Yes you are right.

make menuconfig does not give enough information. May be I will try xconfig this time as you suggested.

Will let you know how did it go.

Bye

Thanks
 
Old 08-18-2005, 10:46 AM   #9
kushalkoolwal
Senior Member
 
Registered: Feb 2004
Location: Middle of nowhere
Distribution: Debian Squeeze
Posts: 1,249

Original Poster
Rep: Reputation: 48
Smile

Thanks aikidoist72. It worked. I was successfully able to remove that error message. You are simply great!!!!!!
 
Old 08-18-2005, 04:21 PM   #10
aikidoist72
Member
 
Registered: Jan 2005
Location: Australia
Distribution: Slackware Archlinux FreeBSD
Posts: 218

Rep: Reputation: 30
Hey well done!! Did you like the xconfig better?

Glad to be of help.
 
Old 08-19-2005, 02:04 PM   #11
kushalkoolwal
Senior Member
 
Registered: Feb 2004
Location: Middle of nowhere
Distribution: Debian Squeeze
Posts: 1,249

Original Poster
Rep: Reputation: 48
Yes. It is way way better than menuconfig. Only thing is that one has to installed qt libraries which was so easy using apt-get.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Bug in psmouse module? - need some help.. Yalla-One Slackware 4 10-03-2005 06:01 AM
modprobe: can't locate module psmouse linuxhippy Slackware 3 06-03-2005 09:00 AM
Autostart in debian & psmouse VertX Debian 2 02-08-2005 03:24 AM
Kernel 2.6.8.1: psmouse Skazi Slackware 6 09-12-2004 01:04 PM
psmouse and wacom pen in kernel 2.6.6 on /dev/input/mice Moloko Linux - Hardware 0 07-18-2004 12:33 PM


All times are GMT -5. The time now is 05:42 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration