LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 01-19-2013, 05:02 PM   #16
cynwulf
Senior Member
 
Registered: Apr 2005
Distribution: OpenBSD
Posts: 1,103

Rep: Reputation: 333Reputation: 333Reputation: 333Reputation: 333

Did you install the firmware manually as instructed in my previous post? If not, then do so first.

The 'buntuforums thread looks much like the howto for this on the arch wiki page. Just download the wl driver and extract and install the other firmwares:

Code:
$ cd ~
$ wget http://mirror2.openwrt.org/sources/broadcom-wl-4.150.10.5.tar.bz2
$ tar xfvj broadcom-wl-4.150.10.5.tar.bz2
# b43-fwcutter --unsupported -w /lib/firmware broadcom-wl-4.150.10.5/driver/wl_apsta_mimo.o
Then do
Code:
# modprobe -r b43 b43legacy && modprobe b43legacy
Code:
# dmesg | grep firmware
and post the outputs.

Last edited by cynwulf; 01-19-2013 at 05:16 PM.
 
Old 01-20-2013, 06:52 AM   #17
onerous
Member
 
Registered: Jun 2012
Location: Lahndahn innit
Distribution: Toshiba P10 Debian 6 xfce, Scaleo E HTPC and attempting ubuntu and xmbc
Posts: 39

Original Poster
Rep: Reputation: Disabled
Yes did that

Quote:
[ 7.279851] platform radeon_cp.0: firmware: requesting radeon/R200_cp.bin
[ 7.376825] radeon_cp: Failed to load firmware "radeon/R200_cp.bin"
[ 7.376861] [drm:r100_cp_init] *ERROR* Failed to load firmware!
[ 7.380305] platform radeon_cp.0: firmware: requesting radeon/R200_cp.bin
[ 7.383602] radeon_cp: Failed to load firmware "radeon/R200_cp.bin"
[ 7.383638] [drm:r100_cp_init] *ERROR* Failed to load firmware!
[ 24.064125] b43legacy ssb0:0: firmware: requesting b43legacy/ucode4.fw
[ 24.077686] b43legacy-phy0 ERROR: You must go to http://linuxwireless.org/en/users/Dr...devicefirmware and download the correct firmware (version 3).
[ 29.902025] tg3 0000:02:00.0: firmware: requesting tigon/tg3_tso5.bin
[ 29.904587] tg3 0000:02:00.0: eth0: Failed to load firmware "tigon/tg3_tso5.bin"
[ 32.588077] b43legacy ssb0:0: firmware: requesting b43legacy/ucode4.fw
[ 32.593505] b43legacy-phy0 ERROR: You must go to http://linuxwireless.org/en/users/Dr...devicefirmware and download the correct firmware (version 3).
[ 32.912129] b43legacy ssb0:0: firmware: requesting b43legacy/ucode4.fw
[ 32.920876] b43legacy-phy0 ERROR: You must go to http://linuxwireless.org/en/users/Dr...devicefirmware and download the correct firmware (version 3).
[ 33.517432] tg3 0000:02:00.0: firmware: requesting tigon/tg3_tso5.bin
[ 33.522627] tg3 0000:02:00.0: eth0: Failed to load firmware "tigon/tg3_tso5.bin"
[ 34.683262] tg3 0000:02:00.0: firmware: requesting tigon/tg3_tso5.bin
[ 34.685541] tg3 0000:02:00.0: eth0: Failed to load firmware "tigon/tg3_tso5.bin"
[ 58.712254] b43legacy ssb0:0: firmware: requesting b43legacy/ucode4.fw
[ 58.717780] b43legacy-phy0 ERROR: You must go to http://linuxwireless.org/en/users/Dr...devicefirmware and download the correct firmware (version 3).
[ 63.504068] b43legacy ssb0:0: firmware: requesting b43legacy/ucode4.fw
[ 63.510378] b43legacy-phy0 ERROR: You must go to http://linuxwireless.org/en/users/Dr...devicefirmware and download the correct firmware (version 3).
[ 64.896258] b43legacy ssb0:0: firmware: requesting b43legacy/ucode4.fw
[ 64.902309] b43legacy-phy0 ERROR: You must go to http://linuxwireless.org/en/users/Dr...devicefirmware and download the correct firmware (version 3).
[ 66.060152] b43legacy ssb0:0: firmware: requesting b43legacy/ucode4.fw
[ 66.065718] b43legacy-phy0 ERROR: You must go to http://linuxwireless.org/en/users/Dr...devicefirmware and download the correct firmware (version 3).
[47015.684243] b43legacy ssb0:0: firmware: requesting b43legacy/ucode4.fw
[47015.691157] b43legacy-phy0 ERROR: You must go to http://linuxwireless.org/en/users/Dr...devicefirmware and download the correct firmware (version 3).
[47018.596252] b43legacy ssb0:0: firmware: requesting b43legacy/ucode4.fw
[47018.601834] b43legacy-phy0 ERROR: You must go to http://linuxwireless.org/en/users/Dr...devicefirmware and download the correct firmware (version 3).
 
Old 01-20-2013, 07:17 AM   #18
cynwulf
Senior Member
 
Registered: Apr 2005
Distribution: OpenBSD
Posts: 1,103

Rep: Reputation: 333Reputation: 333Reputation: 333Reputation: 333
Well the driver cannot find the firmware... try doing
Code:
# ls /lib/firmware/b43legacy/ucode4.fw
and if there is no output refer to my post #13 on the previous page again.

I just downloaded the wl_apsta-3.130.20.0.o file and extracted the firmware and that file is included and saved in the correct location under /lib/firmware:

Code:
Extracting b43legacy/ucode2.fw
Extracting b43legacy/ucode4.fw
Extracting b43legacy/ucode5.fw
Extracting b43legacy/ucode11.fw
Extracting b43legacy/pcm4.fw
Extracting b43legacy/pcm5.fw
Extracting b43legacy/a0g0bsinitvals2.fw
Extracting b43legacy/b0g0bsinitvals5.fw
Extracting b43legacy/a0g0initvals5.fw
Extracting b43legacy/a0g1bsinitvals5.fw
Extracting b43legacy/a0g0initvals2.fw
Extracting b43legacy/a0g1initvals5.fw
Extracting b43legacy/b0g0bsinitvals2.fw
Extracting b43legacy/b0g0initvals5.fw
Extracting b43legacy/b0g0initvals2.fw
Extracting b43legacy/a0g0bsinitvals5.fw

Last edited by cynwulf; 01-20-2013 at 07:32 AM.
 
Old 01-20-2013, 09:53 AM   #19
onerous
Member
 
Registered: Jun 2012
Location: Lahndahn innit
Distribution: Toshiba P10 Debian 6 xfce, Scaleo E HTPC and attempting ubuntu and xmbc
Posts: 39

Original Poster
Rep: Reputation: Disabled
Hello and thank you as I type this wirelessly.

I rebooted the computer and turned off the network card in the BIOS, then went to post 13. As I had already downloaded the file, I just did the installer

Quote:
b43-fwcutter -w /lib/firmware wl_apsta-3.130.20.0.o
Then the modprobe command

Quote:
modprobe -r b43 b43legacy ssb && modprobe b43legacy
Now it works, as I knew that in WICD the wireless would be wlan0.

So now to turn the NIC card on and see what happens.

Last edited by onerous; 01-20-2013 at 09:58 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Debian 6 on a Dell Latitude D800 can't see the Broadcom BCM4306 WLAN jbruyet Linux - Networking 5 05-19-2011 11:32 PM
Dell Latitude D600 wireless connection issue Risatar22 Linux - Laptop and Netbook 12 01-09-2008 06:25 PM
Can't set up Wireless Internet on Dell Latitude D600 sixsidepentagon Linux - Laptop and Netbook 11 10-02-2007 03:42 PM
driver WIRELESS on dell latitude D600 lark Linux - Laptop and Netbook 6 08-25-2007 11:37 PM
DELL LATITUDE D600 brodcom wireless problem HELP! killer90562 Linux - Laptop and Netbook 25 05-17-2007 02:56 PM


All times are GMT -5. The time now is 07:37 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration