LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Debian (http://www.linuxquestions.org/questions/debian-26/)
-   -   Problems with my screen blinking in and out (http://www.linuxquestions.org/questions/debian-26/problems-with-my-screen-blinking-in-and-out-679183/)

Tribulation 10-26-2008 03:26 PM

Problems with my screen blinking in and out
 
I installed Debian Lenny last night, and unlike Etch (which I had installed previously for a couple days), it detected my video card, or so I think since the default resolution was 1680x1050. However, my screen goes black every few seconds, and flickers, and will do so either for a few seconds or several seconds. I don't have long to do anything before it does it again though. Any ideas what is causing this?

EDIT: I figure it's my video drivers so I downloaded the driver for my video card off on ATI's site. It's on my desktop now and I'm not sure what to do with it now.

pinniped 10-27-2008 06:28 AM

You'll need to install the kernel headers so you can 'link' the ATI drivers and use them:

apt-get install linux-headers-$(uname -r)

Then follow the instructions to run the ATI installer.

Tribulation 10-27-2008 07:23 AM

Thanks, but I figured it out last night. I do have other questions though. Whenever I mount anything to the /mnt directory using the su command I have no problem. However, when I try to access the /mnt directory via the GUI it says I don't have the privileges to do so. I've been trying but I can't find out where or how to give myself those privileges. For the record, I'm using KDE. Also, I remember seeing an icon for my external hard drive on my desktop whenever I plugged it in in Ubuntu. Is there anyway to get it to appear as an icon on my desktop in Debian as well? Also, I remember typing ctrl+alt+F1 (or F2-6) to get into the terminal in Ubuntu, and pressing ctrl+alt+F7 to get back to the GUI. I got into the terminal the same way in Debian but when I try to get out, I can't for some reason.

pinniped 10-27-2008 07:45 AM

To allow a normal user to mount a device, you need to create an entry for the device in /etc/fstab and it should not be automount (noauto) and it should have the "users" option (allow normal users to mount).

Getting the devices to be displayed as an icon on the desktop is a matter of configuring the automounter for whatever GUI you're using (GNOME/KDE/whatever).

When in X, you need to press [ctl][alt][F1]..F[6] to get a virtual console. Within the virtual console you only need to press [alt][F1]..[F7] to switch between virtual consoles and the X console.

Tribulation 10-27-2008 02:12 PM

What would I put for type? Also, what about dump and pass? I made the edits you told me to but everytime I try to save it I get two messages. "Unable to make a backup of the original file" and "Unable to write to file"


All times are GMT -5. The time now is 05:18 AM.