LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 07-30-2005, 08:38 AM   #1
minna
LQ Newbie
 
Registered: Jul 2005
Posts: 3

Rep: Reputation: 0
Problems with installing kdebase-kio-plugins


In the process of upgrading to kde3.4.1. I deinstalled the kdebase-kio-plugins (not a good idea, I know). Now I cannot install them back again. I get the following error msg:

Code:
Unpacking kdebase-kio-plugins (from .../kdebase-kio-plugins_4%3a3.3.2-1_i386.deb) ...
dpkg: error processing /var/cache/apt/archives/kdebase-kio-plugins_4%3a3.3.2-1_i386.deb (--unpack):
 trying to overwrite `/usr/lib/kde3/', which is also in package kdepim-kio-plugins
dpkg-deb: subprocess paste killed by signal (Broken pipe)
Errors were encountered while processing:
 /var/cache/apt/archives/kdebase-kio-plugins_4%3a3.3.2-1_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
apt-get -f install gets the same result.

removing kio_imap4.la doesn't make a difference.

I tried to deinstall the entire kdebase package, but it produces a dependency problem with the kdebase-kio-plugins package. So, now I'm stuck.
 
Old 07-30-2005, 09:35 AM   #2
makuyl
Senior Member
 
Registered: Dec 2004
Location: Helsinki
Distribution: Debian Sid
Posts: 1,107

Rep: Reputation: 53
You need to get it from experimental if the rest of your KDE is 3.4.1-1. The one you tried to install is from unstable. Try with:
apt-get install kdebase-kio-plugins/experimental
 
Old 07-30-2005, 09:57 AM   #3
minna
LQ Newbie
 
Registered: Jul 2005
Posts: 3

Original Poster
Rep: Reputation: 0
Thanks! I did that, and now I got the following dependency problem:

Code:
The following packages have unmet dependencies:
  kdebase-kio-plugins: Depends: dbus-qt-1 (>= 0.23.4) but it is not installable
I haven't been able to install dbus-qt-1 via apt-get
 
Old 07-30-2005, 10:05 AM   #4
makuyl
Senior Member
 
Registered: Dec 2004
Location: Helsinki
Distribution: Debian Sid
Posts: 1,107

Rep: Reputation: 53
That version is in unstable and should install ok. Also there is no newer one in experimental. What error does it give when trying to apt-get it?
 
Old 07-30-2005, 10:17 AM   #5
minna
LQ Newbie
 
Registered: Jul 2005
Posts: 3

Original Poster
Rep: Reputation: 0
It seems like apt-get didn't find the package.

I decided to download it manually, from
here and install it via dpgk -i. Once that was installed, I could install the kdebase-kio-plugins and the rest of kdebase.

thanks a lot, your help was highly appreciated
 
Old 07-30-2005, 10:26 AM   #6
makuyl
Senior Member
 
Registered: Dec 2004
Location: Helsinki
Distribution: Debian Sid
Posts: 1,107

Rep: Reputation: 53
No prob. You might want to check your sources.list though as dbus-qt-1 is installable from unstable.
Code:
 apt-cache policy dbus-qt-1
dbus-qt-1:
  Installed: 0.23.4-3
  Candidate: 0.23.4-3
  Version table:
 *** 0.23.4-3 0
        990 ftp://ftp.fi.debian.org unstable/main Packages
        100 /var/lib/dpkg/status
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Build problems with kdebase-3.3.0 source. craigs1987 Linux - Software 1 09-23-2004 12:40 AM
kio (KDirWatch) warnings about removed directories Lokheed Linux - Software 0 07-28-2004 05:47 PM
Problems compiling kdebase-3.2.2 xonner Linux - Software 0 05-10-2004 04:10 PM
kfile and kio srivas Linux - Newbie 0 11-28-2003 07:25 AM
installing kopete 0.7.1 but have no plugins Moses420ca Linux - Newbie 2 09-04-2003 11:25 AM


All times are GMT -5. The time now is 09:15 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration