LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Debian (http://www.linuxquestions.org/questions/debian-26/)
-   -   Problems with apt-get in etch on embedded arm box (http://www.linuxquestions.org/questions/debian-26/problems-with-apt-get-in-etch-on-embedded-arm-box-733938/)

mvhurlburt 06-18-2009 12:48 PM

Problems with apt-get in etch on embedded arm box
 
Hello all, I seem to be having some problems with my debian etch install on VOX N1 nas. Allow me to backtrack for a moment so I don't negate any potentially critical information. The VOX N1 nas runs the STR8132 which is an arm board. The firmware is stored in NAND flash and is loaded to a ramdisk at boot. The only part of firmware that if modifialble is the last 128k which is where the config file are stored(smb.conf, groups, passwd, and a few others) Anyhow since I'd like to play it safe with this and not brick it (Considering there are no RS232 or JTAG pinouts on the board and I'd like to stay away from soldering) I have installed the debian base system on the attached sata drive and modified the smb.conf file to chroot and start sshd. Now I'd like to install netatalk however I'm having some trouble with apt-get.

I considered using sources of the debian site but it appears I'm going to run into some complicated dependency issues. So now to apt-get, my initial problems were that /etc/apt/sources.list were listing non-us sources, which I fixed. What came next was the apt key, I managed to fix that as well by running the following:
Code:

# gpg --keyserver wwwkeys.eu.pgp.net --recv-keys XXXXXXXXXXXXXXXX
...
# apt-key add /root/.gnupg/pubring.gpg
...
# apt-get update
...

heres where the next snag comes while trying to run 'apt-get install *'
Take GCC for instance(Though this happens with any package)

Code:

The following extra packages will be installed:
  binutils cpp cpp-4.3 gcc-4.3 gcc-4.3-base libc6 libgcc1 libgmp3c2 libgomp1
  libmpfr1ldbl libncurses5 libselinux1 libslang2
Suggested packages:
  binutils-doc cpp-doc gcc-4.3-locales gcc-multilib make manpages-dev autoconf
  automake1.9 libtool flex bison gdb gcc-doc libmudflap0-4.3-dev gcc-4.3-doc
  libgcc1-dbg libgomp1-dbg libmudflap0-dbg glibc-doc
Recommended packages:
  libc6-dev libc-dev libgpm2 libpng12-0
The following packages will be REMOVED:
  tzdata util-linux
The following NEW packages will be installed:
  binutils cpp cpp-4.3 gcc gcc-4.3 gcc-4.3-base libgmp3c2 libgomp1
  libmpfr1ldbl
The following packages will be upgraded:
  libc6 libgcc1 libncurses5 libselinux1 libslang2
WARNING: The following essential packages will be removed.
This should NOT be done unless you know exactly what you are doing!
  util-linux tzdata (due to util-linux)
5 upgraded, 9 newly installed, 2 to remove and 123 not upgraded.
Need to get 12.3MB of archives.
After unpacking 12.0MB of additional disk space will be used.
You are about to do something potentially harmful.
To continue type in the phrase 'Yes, do as I say!'
 ?]

I'm not sure exactly what this risk is here(I wish the error would be a bit more detailed)
but anyway when I respond; 'Yes, do as I say!' the installation proceeds, when it gets to libc6 it attempts to restart some services, the same happens when it gets to some pam lib(I haven't let it go that far yet, not wanting to compromise my install again and have to start from scratch). So when I follow the prompts it usually processes everything but subsequently I loose ssh access so I then need to start from the beginning again. Any ideas on how to fix this or what I'm doing wrong? Is there any way to install older pkgs that are compatible with the dependencies already in etch? Or is there anywhere where I can get a tarred lenny base system with up-to-date dependencies? I don't know how I should proceed at this point but theres gotta be a way to get a working debian base system on this thing with a working apt-get!

Regards,
.:MvH:.

farslayer 06-18-2009 01:38 PM

what does your sources.list look like right now ? could you post it please ?

and no I do not think you want it to remove util-linux

mvhurlburt 06-18-2009 04:27 PM

Here it is:

Code:

# See sources.list(5) for more information, especialy
# Remember that you can only use http, ftp or file URIs
# CDROMs are managed through the apt-cdrom tool.
deb http://http.us.debian.org/debian stable main contrib non-free
#deb http://non-us.debian.org/debian-non-US stable/non-US main contrib non-free
deb http://security.debian.org stable/updates main contrib non-free

# Uncomment if you want the apt-get source function to work
#deb-src http://http.us.debian.org/debian stable main contrib non-free
#deb-src http://non-us.debian.org/debian-non-US stable/non-US main contrib non-free

you'll notice the following line is commented:
Code:

#deb http://non-us.debian.org/debian-non-US stable/non-US main contrib non-free
That I think caused my initial problems.

farslayer 06-19-2009 12:04 AM

Well if you are running etch the problem definitely begins in your sources file, because they are pointing at stable which is Lenny.

You should use the release names in your sources.list file to avoid this issue in the future. etch , lenny, squeeze that way when stable becomes oldstable you will still be tracking the same release..

If you are positive you are running etch I would suggest you edit your sources.list, change all instances of stable to etch, update, and then try to install your files again.

vim /etc/apt/sources.list
fix your sources list to point at etch

apt-get update
apt-get install gcc

mvhurlburt 06-19-2009 07:31 AM

yep that did it. Much thanks! I can't believe I didn't notice that! To bad I had already spent so much time with dpkg and all my needed dependencies! oh well... well thanks again, as earlier stated you prompt reply has been much appreciated!

zerlgi3 02-03-2010 06:24 AM

Quote:

Originally Posted by mvhurlburt (Post 3578549)
modified the smb.conf file to chroot and start sshd.

Please would you share what your smb.conf looks like. did you use "magic script" option to enable sshd/telnetd? was sshd/telnetd already on it or only on the Debian install you added?

Thanks.

Zerlgi


All times are GMT -5. The time now is 04:54 PM.