LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices



Reply
 
Search this Thread
Old 04-14-2005, 09:14 AM   #1
tony yu
Member
 
Registered: Sep 2003
Location: Taiwan
Distribution: mandriva 2006
Posts: 108

Rep: Reputation: 15
problem with Xauth & sound


Hi, I'm new to debian. I compile kde-3.4 from sources and when I login, I see a message, This is an unsecure login, on kdm. What does it mean and how to solve?
In addition, I get no sound, even though I can run alsamixer properly. When I run command such as 'cat /path/to/sound file > dev/dsp' I just get a non-sense noisy sound(I have the right permission to sound). How to rescue my sound? Thanks for your reply.
 
Old 04-16-2005, 10:35 PM   #2
tony yu
Member
 
Registered: Sep 2003
Location: Taiwan
Distribution: mandriva 2006
Posts: 108

Original Poster
Rep: Reputation: 15
Now, I've solved authentification problem of kdm. However my sound is still under sleep, the alsa driver in my system seems not to properly correlate with kernel sound device because when alsa says it can't find my sound card, then 'cat /path/to/sound > dev/dsp' give me pretty sound but when alsa can find my card, that command returns just non-sense noises. I am really confused.

Last edited by tony yu; 04-16-2005 at 10:36 PM.
 
Old 04-17-2005, 01:39 AM   #3
Dead Parrot
Senior Member
 
Registered: Mar 2004
Distribution: Debian GNU/kFreeBSD
Posts: 1,597

Rep: Reputation: 46
Hi, Your problem kind of reminds me of the ALSA troubles I used to have. When I switched to 2.6 kernel and ALSA, I ran alsaconf and tried to play sounds but only got loud scratching noise. It turned out that I needed to tell discover (Debian's hardware-detection utility) to skip loading driver for my soundcard during boot-time. I don't pretend to understand ALSA but I was left with the impression that discover loaded OSS modules for my soundcard and they conflicted with the ALSA modules that alsaconf loaded. Anyway, adding "skip maestro3" (maestro3 being the driver for my soundcard) into /etc/discover.conf solved my problem and I got ALSA playing sounds nicely.

But I thought that this had already been fixed in Debian Testing and Unstable. Maybe you're using Debian Stable with some upgraded components? Or maybe you're using kernel 2.4?

Now when I browse the /etc directory, I can see that there is an /etc/discover.d/alsa-base file that lists drivers for soundcards to be skipped by discover, among them maestro3. And there also appears to be an /etc/hotplug/blacklist.d/alsa-base file that also lists maestro3. So apparently I don't need anymore the "skip maestro3" line in /etc/discover.conf. (But it won't do any harm, so I'll leave it there just in case.)

My suggestion, based on the information I provided above, is that you try adding a line to /etc/discover.conf that tells discover to skip loading the driver for your soundcard. If you're not sure what driver the Linux kernel uses for your sound card, try "lsmod | grep snd" and try to figure it from the output. And, come to think of it, alsaconf probably also mentions the correct driver during configuration.

No guarantees that this will help anything, but I just thought it might be worth a try. Cheers.
 
Old 04-17-2005, 04:07 AM   #4
tony yu
Member
 
Registered: Sep 2003
Location: Taiwan
Distribution: mandriva 2006
Posts: 108

Original Poster
Rep: Reputation: 15
My sound card is on-board of nforce2. I had checked alsa project and it tells me I should use module of snd-intel8x0. I had load this module into kernel, then would I add 'skip snd-intel8x0' to /etc/discover.conf? In fact, I had add 'skip i810_audio' to this file previously, but it failed. BTW, thank you much.
 
Old 04-17-2005, 04:52 AM   #5
Dead Parrot
Senior Member
 
Registered: Mar 2004
Distribution: Debian GNU/kFreeBSD
Posts: 1,597

Rep: Reputation: 46
I'm a very poor adviser on this -- like I said, I know next to nothing about ALSA. My understanding is that the modules beginning with snd- (like snd-intel8x0) are ALSA modules and there is no need to ask discover to skip them. i810_audio, on the other hand, is probably OSS module, so the line 'skip i810_audio' in /etc/discover.conf would be appropriate. I'm sorry to hear that it doesn't do you any good.

Maybe you should run lsmod in terminal window and check if there are any OSS modules currently loaded. In that case asking discover to skip those modules might help. Like I said, as far as I can tell any modules beginning with snd- should be OK. But I'm very ignorant on these matters. Hopefully someone who understands better how ALSA works can give you some more informed advices.

However, I think you might improve your chances in receiving informed advices by telling which version of Debian you are running (stable, testing, or unstable) and also your kernel version, because these things might be important in finding solution to your problem.
 
Old 04-17-2005, 08:39 AM   #6
tony yu
Member
 
Registered: Sep 2003
Location: Taiwan
Distribution: mandriva 2006
Posts: 108

Original Poster
Rep: Reputation: 15
Well, I run debian 3.1 with kernel-2.6.8-k7.
 
Old 04-17-2005, 10:42 AM   #7
Dead Parrot
Senior Member
 
Registered: Mar 2004
Distribution: Debian GNU/kFreeBSD
Posts: 1,597

Rep: Reputation: 46
Hi, again. I used the search engine here at LinuxQuestions.org and found these threads where intel8x0 is mentioned:
http://www.linuxquestions.org/questi...der=descending
I browsed them through and there was actually very little that seemed useful, but someone apparently got ALSA sound working by disabling ARTS sound in KDE's Control Center. I just thought that this might be worth a try.
 
Old 04-19-2005, 07:00 PM   #8
tony yu
Member
 
Registered: Sep 2003
Location: Taiwan
Distribution: mandriva 2006
Posts: 108

Original Poster
Rep: Reputation: 15
xmms and alsaplayer can play music, so alsa should be no problem, but when I override device path to /dev/dsp in kde control center->sound & multimedia->sound system->hardware, kde give me a message, can't open /dev/dsp(no such file or directory), however, the file does be in my /dev!
 
Old 04-19-2005, 09:10 PM   #9
tony yu
Member
 
Registered: Sep 2003
Location: Taiwan
Distribution: mandriva 2006
Posts: 108

Original Poster
Rep: Reputation: 15
I can play sound in amarok with xine engine but can't with arts.
 
Old 04-21-2005, 06:52 AM   #10
Dead Parrot
Senior Member
 
Registered: Mar 2004
Distribution: Debian GNU/kFreeBSD
Posts: 1,597

Rep: Reputation: 46
I don't use KDE, so I cannot offer you much more help in solving your problem. I was hoping that other Debian/KDE users would have given you advices on this issue but it appears that few people here have encountered similar problems.

This is the forum for Debian specific problems but I don't think your problem is actually very Debian specific. So I suggest that you post your question to the general "Linux - Software" forum here at LinuxQuestions.org http://www.linuxquestions.org/questi...p?s=&forumid=2 to reach better support. Give a detailed account of your problem (mention your sound card's manufacturer and model, the suggested ALSA driver, and your kernel version) emphasizing that it appears to be a problem in using ALSA with KDE/aRts.

Don't copy&paste the same question you've asked here (because that's not allowed) but, instead, formulate a new question. You can mention that you've already asked for help at the Debian specific forum and that you'd like to see if you can get any additional help from the general Linux-Software forum.
 
Old 04-21-2005, 08:22 PM   #11
tony yu
Member
 
Registered: Sep 2003
Location: Taiwan
Distribution: mandriva 2006
Posts: 108

Original Poster
Rep: Reputation: 15
After I compile kernel-2.6.10 with a config of previous debian's but unchecking some options in the device driver->ATA/ATAPI/MFM/RLL support for via82cxxx, etc.(because I found some error messages on boot about these drivers), and boot with this kernel, my arts works, though kde system notification is still silent. Any ideas? BTW Thanks, Dead Parrot, you are so zealous.
 
Old 04-22-2005, 05:01 AM   #12
tony yu
Member
 
Registered: Sep 2003
Location: Taiwan
Distribution: mandriva 2006
Posts: 108

Original Poster
Rep: Reputation: 15
Yes, all problems are solved! Removing ~/.kde/share/config/knotifyrc and restarting kde, the system notification can now work.
 
Old 04-22-2005, 05:26 AM   #13
Dead Parrot
Senior Member
 
Registered: Mar 2004
Distribution: Debian GNU/kFreeBSD
Posts: 1,597

Rep: Reputation: 46
I'm glad to hear that you solved the sound problem. Also, very nice of you to post the solution. Way too many people just say "forget about this, I solved the problem", which doesn't actually help much when the next user stumbles into a similar problem.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
disabling xhost & xauth Smokey Slackware 3 06-30-2005 05:02 PM
Problem with my sound card.. can't play video & music files! MESShY Linux - Newbie 5 04-29-2005 09:29 PM
eired sound problem & KDE azi Slackware 1 06-28-2004 12:09 PM
Sound & Video Problem(s) vagabondmuse Fedora 2 11-25-2003 06:02 AM
[Mandrake 9.1] 4 speakers & sound quality problem ilhbutshm Linux - Newbie 1 07-26-2003 07:59 AM


All times are GMT -5. The time now is 09:24 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration