LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 09-03-2005, 01:40 AM   #1
c_olin3404
Member
 
Registered: Jan 2004
Posts: 131

Rep: Reputation: 15
Problem with ATI drivers


I'm using this site to install ATI drivers on my debian box.

The packages installed fine... the compilation of the fglrx module did not fail, but had some warnings:

Code:
bluebox:/usr/src/modules/fglrx# ./make.sh
ATI module generator V 2.0
==========================
initializing...
cleaning...
patching 'highmem.h'...
assuming new VMA API since we do have kernel 2.6.x...
doing Makefile based build for kernel 2.6.x and higher
make -C /usr/src/linux-2.6.12.5 SUBDIRS=/usr/src/modules/fglrx modules
make[1]: Entering directory `/usr/src/linux-2.6.12.5'
  CC [M]  /usr/src/modules/fglrx/agp3.o
  CC [M]  /usr/src/modules/fglrx/nvidia-agp.o
  CC [M]  /usr/src/modules/fglrx/agpgart_be.o
/usr/src/modules/fglrx/agpgart_be.c: In function `__fgl_agp_init':
/usr/src/modules/fglrx/agpgart_be.c:8166: warning: `pm_register' is deprecated (declared at include/linux/pm.h:106)
/usr/src/modules/fglrx/agpgart_be.c: In function `__fgl_agp_cleanup':
/usr/src/modules/fglrx/agpgart_be.c:8176: warning: `pm_unregister_all' is deprecated (declared at include/linux/pm.h:116)
/usr/src/modules/fglrx/agpgart_be.c: At top level:
/usr/src/modules/fglrx/agpgart_be.c:6070: warning: `ati_gart_base' defined but not used
  CC [M]  /usr/src/modules/fglrx/i7505-agp.o
  CC [M]  /usr/src/modules/fglrx/firegl_public.o
/usr/src/modules/fglrx/firegl_public.c: In function `firegl_stub_putminor':
/usr/src/modules/fglrx/firegl_public.c:498: warning: `inter_module_put' is deprecated (declared at include/linux/module.h:5$/usr/src/modules/fglrx/firegl_public.c:500: warning: `inter_module_unregister' is deprecated (declared at include/linux/mod$/usr/src/modules/fglrx/firegl_public.c: In function `firegl_stub_register':
/usr/src/modules/fglrx/firegl_public.c:520: warning: `inter_module_register' is deprecated (declared at include/linux/modul$/usr/src/modules/fglrx/firegl_public.c:551: warning: `inter_module_put' is deprecated (declared at include/linux/module.h:5$/usr/src/modules/fglrx/firegl_public.c: In function `__ke_verify_area':
/usr/src/modules/fglrx/firegl_public.c:1428: warning: `verify_area' is deprecated (declared at include/asm/uaccess.h:105)
  LD [M]  /usr/src/modules/fglrx/fglrx.o
  Building modules, stage 2.
  MODPOST
  CC      /usr/src/modules/fglrx/fglrx.mod.o
  LD [M]  /usr/src/modules/fglrx/fglrx.ko
make[1]: Leaving directory `/usr/src/linux-2.6.12.5'
build succeeded with return value 0
done.
==============================
You must copy fglrx.ko to /lib/modules/2.6.12.5/misc
and then call 'depmod -ae' in order to install the built module.
==============================
There was some weird stuff in dmesg:
Code:
fglrx: module license 'Proprietary. (C) 2002 - ATI Technologies, Starnberg, GERMANY' taints kernel.
[fglrx] Maximum main memory to use for locked dma buffers: 929 MBytes.
ACPI: PCI Interrupt 0000:02:00.0[A] -> Link [APC4] -> GSI 19 (level, high) -> IRQ 19
[fglrx] module loaded - fglrx 8.14.13 [Jun  8 2005] on minor 0
allocation failed: out of vmalloc space - use vmalloc=<size> to increase size.
[fglrx:firegl_unlock] *ERROR* Process 4223 using kernel context 0
allocation failed: out of vmalloc space - use vmalloc=<size> to increase size.
[fglrx:firegl_unlock] *ERROR* Process 4357 using kernel context 0
allocation failed: out of vmalloc space - use vmalloc=<size> to increase size.
[fglrx:firegl_unlock] *ERROR* Process 4654 using kernel context 0
allocation failed: out of vmalloc space - use vmalloc=<size> to increase size.
[fglrx:firegl_unlock] *ERROR* Process 5236 using kernel context 0
ISO 9660 Extensions: Microsoft Joliet Level 1
ISOFS: changing to secondary root
BTW I'm on kernel 2.6.12.5.

Any ideas? (I had the drivers running fine on version fglrx-8.14.13)

Thanks in advanced
 
Old 09-03-2005, 01:52 AM   #2
rtg
Member
 
Registered: Aug 2005
Location: Ukraine
Distribution: Ubuntu 9.04
Posts: 99
Blog Entries: 3

Rep: Reputation: 19
If you continue working with that module, you'll find all 3D apps are failing or your X server won't start.
Go to www.ati.com and get the updated version - they have fixed these issues both with kernel driver and X.
The latest one at the time of writing was dated 08/17/05 and the version is 8.16.20.

They have their package in RPM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
ATI 9600Pro & ATI Proprietary Drivers problem Hyakutake Slackware 6 12-04-2005 11:08 AM
Ati drivers problem :( help please tomazN Linux - Hardware 23 10-27-2005 03:43 AM
ATI drivers problem TheCrizu Mandriva 4 09-28-2005 01:37 PM
Ati drivers problem (slack9.1 k2.6.6) dame Slackware 10 07-14-2004 01:31 AM
Problem installing ati drivers warrant6767 Linux - Hardware 3 07-03-2004 05:14 AM


All times are GMT -5. The time now is 12:27 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration