LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Debian (http://www.linuxquestions.org/questions/debian-26/)
-   -   Problem installing google chrome in Debian Linux (http://www.linuxquestions.org/questions/debian-26/problem-installing-google-chrome-in-debian-linux-777624/)

mdsajjad_001 12-23-2009 02:46 AM

Problem installing google chrome in Debian Linux
 
Hi friends;
Iam new to Debian Linux. Trying to install google chrome on my PC. While trying to install i get the following message :

mdsajjad:~/Desktop# dpkg -i google-chrome-unstable_current_i386.deb
Selecting previously deselected package google-chrome-unstable.
(Reading database ... 127662 files and directories currently installed.)
Unpacking google-chrome-unstable (from google-chrome-unstable_current_i386.deb) ...
dpkg: dependency problems prevent configuration of google-chrome-unstable:
google-chrome-unstable depends on libnss3-1d (>= 3.12.3); however:
Version of libnss3-1d on system is 3.12.0-5.
dpkg: error processing google-chrome-unstable (--install):
dependency problems - leaving unconfigured
Processing triggers for menu ...
Processing triggers for man-db ...
Errors were encountered while processing:
google-chrome-unstable



Unable to know how to upgrade from libnss3-1d to version 3.12.5

baltho 12-23-2009 03:00 AM

Debian "lenny" has the version you need: either:
(best) apt-get update; apt-get upgrade, which will query the repositories and update everything to the latest, or
(worse) update to lenny if you're running sid or etch or an earlier debian, or
(worst) download the sources and compile it yourself, although other packages using libnss3-1d could make that a headache.
You can check out the details - packages which depend on it, on which it depends, etc - at http://packages.debian.org/lenny/libnss3-1d

j1alu 12-23-2009 04:48 AM

check this how-to (from the repository):
http://www.google.com/linuxrepositories/apt.html

about your libnss3-1d problem i don`t know. i have got an up-to date lenny and the same version like you http://packages.debian.org/search?ke...le&section=all
(and it ain`t available from lenny-backports)

airakesh 01-29-2010 12:13 AM

How to Install Google Chrome browser (not Chromium) in Debian (Linux)
 
Solution for installing Google Chrome on Debian (Linux) at AIRAKESH's Weblog (here I can't put the url that's why I have just mentioned the

Enjoy Google Chrome on Debian!!... :)

Rakesh

airakesh 01-29-2010 12:13 AM

Here is soloution for installing Google Chrome on Debian (Linux):

http://airakesh.com/blog/archives/20...-debian-linux/


Rakesh

craigevil 01-29-2010 01:10 AM

dpkg does not resolve depends. Use the Google repo or gdebi.

# Google Chrome http://www.google.com/linuxrepositories/apt.html
#(wget -q -O - https://dl-ssl.google.com/linux/linux_signing_key.pub | sudo apt-key add - )
# or (gpg --keyserver subkeys.pgp.net --recv A040830F7FAC5991 && gpg --export --armor A040830F7FAC5991 | sudo apt-key add - )
# deb http://dl.google.com/linux/deb/ stable main non-free


All times are GMT -5. The time now is 10:34 PM.