LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 04-09-2006, 06:43 AM   #1
vharishankar
Senior Member
 
Registered: Dec 2003
Posts: 3,142
Blog Entries: 4

Rep: Reputation: 121Reputation: 121
Preventing udev from loading kernel modules


I am having a peculiar problem currently. Because udev autodetects my tv tuner card, there is a problem. Because I need to manually set the module option while loading bttv. But unfortunately setting the configuration in /etc/modprobe.d/ doesn't work at all. It doesn't even configure the tv properly.

Whereas if I do a manual modprobe bttv card=52 tuner=1 after manually removing it on boot, it works fine. The problem is, setting these options in the /etc/modprobe.d/ directory does not seem to have the correct effect. Maybe udev conflicts with this.

here's the result of dmesg | grep bttv
Code:
hari@ramhari:~$ dmesg | grep bttv
bttv: driver version 0.9.16 loaded
bttv: using 8 buffers with 2080k (520 pages) each for capture
bttv: Bt8xx card found (0).
bttv0: Bt878 (rev 17) at 0000:01:07.0, irq: 217, latency: 32, mmio: 0xd4000000
bttv0: detected: Pinnacle PCTV [card=39], PCI subsystem ID is 11bd:0012
bttv0: using: Pinnacle PCTV Studio/Rave [card=39,autodetected]
bttv0: gpio: en=00000000, out=00000000 in=00ffffff [init]
bttv0: i2c: checking for MSP34xx @ 0x80... not found
bttv0: pinnacle/mt: id=1 info="PAL / mono" radio=no
bttv0: using tuner=33
bttv0: i2c: checking for MSP34xx @ 0x80... not found
bttv0: i2c: checking for TDA9875 @ 0xb0... not found
bttv0: i2c: checking for TDA7432 @ 0x8a... not found
bttv0: registered device video0
bttv0: registered device vbi0
bttv0: PLL: 28636363 => 35468950 .. ok
bttv0: PLL can sleep, using XTAL (28636363).
bttv0: PLL: 28636363 => 35468950 .. ok
Here's the result of dmesg | grep tuner
Code:
bttv0: using tuner=33
tuner: Unknown parameter `type'
Note: I had added options tuner type=1 in a file in /etc/modprobe.d/, but obviously that option doesn't work.

I tried the blacklist option, but obviously that option is not to prevent the kernel loading the module, but merely to disable aliases.

Last edited by vharishankar; 04-09-2006 at 06:47 AM.
 
Old 04-09-2006, 09:25 AM   #2
Brian1
Guru
 
Registered: Jan 2003
Location: Seymour, Indiana
Distribution: Distribution: RHEL 5 with Pieces of this and that. Kernel 2.6.23.1, KDE 3.5.8 and KDE 4.0 beta, Plu
Posts: 5,700

Rep: Reputation: 61
Add this line to your /etc/rc.local ' modprobe bttv card=52 tuner=1 '. Then remove the line from /etc/modprobe. It may not exist since I do not know the distro you are using since listing many in your ID tag.

Brian1
 
Old 04-09-2006, 10:09 AM   #3
vharishankar
Senior Member
 
Registered: Dec 2003
Posts: 3,142
Blog Entries: 4

Original Poster
Rep: Reputation: 121Reputation: 121
Debian doesn't have the BSD style rc.d scripts It's configuration files are different and also udev autodetects the card and so there's no entry in /etc/modules. This is a Debian specific question so I'm asking here in the Debian forum.

Also passing the module parameters at boot using /etc/modprobe.d/ scripts don't work maybe because it conflicts with the autodetection by udev.

Last edited by vharishankar; 04-09-2006 at 10:11 AM.
 
Old 04-09-2006, 05:46 PM   #4
Brian1
Guru
 
Registered: Jan 2003
Location: Seymour, Indiana
Distribution: Distribution: RHEL 5 with Pieces of this and that. Kernel 2.6.23.1, KDE 3.5.8 and KDE 4.0 beta, Plu
Posts: 5,700

Rep: Reputation: 61
So in a BSD style where does one add small scripts or commands to start after system is mostly booted. Never messed with BSD so I am curious. Thanks for the help.

Brian1
 
Old 04-09-2006, 08:36 PM   #5
vharishankar
Senior Member
 
Registered: Dec 2003
Posts: 3,142
Blog Entries: 4

Original Poster
Rep: Reputation: 121Reputation: 121
Brian, I request you to start a separate thread for this question you have.

Please use this thread to answer the original question.
 
Old 04-27-2006, 01:27 AM   #6
daaku
LQ Newbie
 
Registered: Aug 2003
Posts: 1

Rep: Reputation: 0
Maybe this will work:

in /etc/modprobe.d/bttv:
Code:
options bttv card=52 tuner=1
 
Old 04-27-2006, 01:58 AM   #7
rkelsen
Senior Member
 
Registered: Sep 2004
Distribution: slackware
Posts: 1,748

Rep: Reputation: 159Reputation: 159
Quote:
Originally Posted by Harishankar
But unfortunately setting the configuration in /etc/modprobe.d/ doesn't work at all.
man update-modules
Quote:
Originally Posted by Brian1
So in a BSD style where does one add small scripts or commands to start after system is mostly booted.
/etc/rc.d/rc.local
Quote:
Originally Posted by Harishankar
Please use this thread to answer the original question.
Calm down dude. No need to be so uptight.
 
  


Reply

Tags
bttv, kernel, modules, tuner, tv, udev


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Preventing kernel module (rootkits) from loading shubb Linux - Security 7 12-06-2005 07:48 PM
Loading Kernel Modules superdude_876 Linux - Software 1 10-28-2005 11:46 PM
Loading modules error after loading compiled kernel td0l2 Linux - Newbie 12 07-28-2004 11:10 AM
modules not loading after kernel install epoo Linux - General 1 02-20-2004 01:29 AM
Modules not loading in New kernel palanisaravanan Linux - General 1 11-22-2003 06:31 AM


All times are GMT -5. The time now is 06:19 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration