LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Debian (http://www.linuxquestions.org/questions/debian-26/)
-   -   Preventing udev from loading kernel modules (http://www.linuxquestions.org/questions/debian-26/preventing-udev-from-loading-kernel-modules-433299/)

vharishankar 04-09-2006 06:43 AM

Preventing udev from loading kernel modules
 
I am having a peculiar problem currently. Because udev autodetects my tv tuner card, there is a problem. Because I need to manually set the module option while loading bttv. But unfortunately setting the configuration in /etc/modprobe.d/ doesn't work at all. It doesn't even configure the tv properly.

Whereas if I do a manual modprobe bttv card=52 tuner=1 after manually removing it on boot, it works fine. The problem is, setting these options in the /etc/modprobe.d/ directory does not seem to have the correct effect. Maybe udev conflicts with this.

here's the result of dmesg | grep bttv
Code:

hari@ramhari:~$ dmesg | grep bttv
bttv: driver version 0.9.16 loaded
bttv: using 8 buffers with 2080k (520 pages) each for capture
bttv: Bt8xx card found (0).
bttv0: Bt878 (rev 17) at 0000:01:07.0, irq: 217, latency: 32, mmio: 0xd4000000
bttv0: detected: Pinnacle PCTV [card=39], PCI subsystem ID is 11bd:0012
bttv0: using: Pinnacle PCTV Studio/Rave [card=39,autodetected]
bttv0: gpio: en=00000000, out=00000000 in=00ffffff [init]
bttv0: i2c: checking for MSP34xx @ 0x80... not found
bttv0: pinnacle/mt: id=1 info="PAL / mono" radio=no
bttv0: using tuner=33
bttv0: i2c: checking for MSP34xx @ 0x80... not found
bttv0: i2c: checking for TDA9875 @ 0xb0... not found
bttv0: i2c: checking for TDA7432 @ 0x8a... not found
bttv0: registered device video0
bttv0: registered device vbi0
bttv0: PLL: 28636363 => 35468950 .. ok
bttv0: PLL can sleep, using XTAL (28636363).
bttv0: PLL: 28636363 => 35468950 .. ok

Here's the result of dmesg | grep tuner
Code:

bttv0: using tuner=33
tuner: Unknown parameter `type'

Note: I had added options tuner type=1 in a file in /etc/modprobe.d/, but obviously that option doesn't work.

I tried the blacklist option, but obviously that option is not to prevent the kernel loading the module, but merely to disable aliases.

Brian1 04-09-2006 09:25 AM

Add this line to your /etc/rc.local ' modprobe bttv card=52 tuner=1 '. Then remove the line from /etc/modprobe. It may not exist since I do not know the distro you are using since listing many in your ID tag.

Brian1

vharishankar 04-09-2006 10:09 AM

Debian doesn't have the BSD style rc.d scripts It's configuration files are different and also udev autodetects the card and so there's no entry in /etc/modules. This is a Debian specific question so I'm asking here in the Debian forum.

Also passing the module parameters at boot using /etc/modprobe.d/ scripts don't work maybe because it conflicts with the autodetection by udev.

Brian1 04-09-2006 05:46 PM

So in a BSD style where does one add small scripts or commands to start after system is mostly booted. Never messed with BSD so I am curious. Thanks for the help.

Brian1

vharishankar 04-09-2006 08:36 PM

Brian, I request you to start a separate thread for this question you have.

Please use this thread to answer the original question.

daaku 04-27-2006 01:27 AM

Maybe this will work:

in /etc/modprobe.d/bttv:
Code:

options bttv card=52 tuner=1

rkelsen 04-27-2006 01:58 AM

Quote:

Originally Posted by Harishankar
But unfortunately setting the configuration in /etc/modprobe.d/ doesn't work at all.

man update-modules
Quote:

Originally Posted by Brian1
So in a BSD style where does one add small scripts or commands to start after system is mostly booted.

/etc/rc.d/rc.local
Quote:

Originally Posted by Harishankar
Please use this thread to answer the original question.

Calm down dude. No need to be so uptight. ;)


All times are GMT -5. The time now is 07:58 AM.