LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 04-12-2005, 07:31 AM   #1
reddazz
Guru
 
Registered: Nov 2003
Location: N. E. England
Distribution: Fedora, CentOS, Debian
Posts: 16,298

Rep: Reputation: 73
Preventing Debian from changing time on hardware clock


I recently installed Debian Sarge on a multiboot system. I have noticed that everytime I shutdown Debian and log into Slack, Debian has reset the hardware clock from UTC to local time. How can I prevent this this problem.
 
Old 04-12-2005, 09:39 AM   #2
Dead Parrot
Senior Member
 
Registered: Mar 2004
Distribution: Debian GNU/kFreeBSD
Posts: 1,597

Rep: Reputation: 46
I think you can just rerun the base-config program and change the time settings to your liking.
 
Old 04-12-2005, 09:44 AM   #3
reddazz
Guru
 
Registered: Nov 2003
Location: N. E. England
Distribution: Fedora, CentOS, Debian
Posts: 16,298

Original Poster
Rep: Reputation: 73
Ok, I'll try that.
 
Old 04-12-2005, 02:34 PM   #4
macondo
Senior Member
 
Registered: Jul 2003
Location: Panama
Distribution: Debian Sid
Posts: 1,014

Rep: Reputation: 49
# tzconfig
 
Old 04-12-2005, 06:04 PM   #5
reddazz
Guru
 
Registered: Nov 2003
Location: N. E. England
Distribution: Fedora, CentOS, Debian
Posts: 16,298

Original Poster
Rep: Reputation: 73
Well, I tried tzconfig a while ago but the problem persisted.
 
Old 04-12-2005, 07:28 PM   #6
Dead Parrot
Senior Member
 
Registered: Mar 2004
Distribution: Debian GNU/kFreeBSD
Posts: 1,597

Rep: Reputation: 46
The base-config program has an option to set the timezone and it asks if your computer's clock is set to GMT time. If you answer "yes" to this question, then I'd expect that Debian wouldn't mess with your computer's clock.

Debian probably uses the hwclock tool to change hardware clock settings, so if the problem persists, then checking the man page for hwclock might give you some idea for fixing the problem.
 
Old 04-12-2005, 07:45 PM   #7
reddazz
Guru
 
Registered: Nov 2003
Location: N. E. England
Distribution: Fedora, CentOS, Debian
Posts: 16,298

Original Poster
Rep: Reputation: 73
Running base-config sorted out the problem. The shutdown script still says its saving the time as local time, but its not changing the clock, so problem solved.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
System clock correct, hardware clock wrong karlovac Linux - General 5 01-16-2009 07:19 PM
Various clock issues: Clock shows wrong time only in Knoppmyth, & CMOS time change ? davidbix General 1 04-05-2006 09:58 PM
system clock,hardware clock varunbihani Linux - Newbie 2 07-23-2005 09:04 AM
Hardware and System Clock GruiX Linux - Software 5 02-09-2004 01:28 PM
Hardware Clock... philfighter General 0 08-18-2001 10:26 PM


All times are GMT -5. The time now is 01:54 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration