LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 06-29-2006, 03:43 PM   #1
RestInPieces
Member
 
Registered: Aug 2004
Location: In front of a CRT monitor
Distribution: Slackware-current
Posts: 108

Rep: Reputation: 15
Postfix weird mail sending


I've just installed postfix according to :

http://www.howtoforge.com/perfect_setup_debian_sarge

Now.. the problem is that it only creates the mail folder for root, and stranager... instead of announcing new mail, all mail is redirected to /var/spool/mail/root ..
Running Sarge 3.1 configured by the above tut.
 
Old 06-29-2006, 04:10 PM   #2
billymayday
Guru
 
Registered: Mar 2006
Location: Sydney, Australia
Distribution: Fedora, CentOS, OpenSuse, Slack, Gentoo, Debian, Arch, PCBSD
Posts: 6,678

Rep: Reputation: 122Reputation: 122
RIPs, it would make life easier if you posted your main.cf (not sure where it is in Slackwhere, but in Fedora it's in /etc/postfix).

My initial thought is to question whether or not you followed the lines

postconf -e 'home_mailbox = Maildir/'
postconf -e 'mailbox_command ='

since I'd have expected root's mail to go into /root/Maildir rather than /var/spool/mail/root.

Have a look in main.cf and look for the "home_mailbox" setting for a start.


Rgds

Bill
 
Old 06-30-2006, 07:29 AM   #3
RestInPieces
Member
 
Registered: Aug 2004
Location: In front of a CRT monitor
Distribution: Slackware-current
Posts: 108

Original Poster
Rep: Reputation: 15
Fist of all, thanks for your reply
I have checked the Maildir and all looks ok. Even more, the /new/ folder is full with new mail from tiger. Why won't I receive mail from mutt or mail?

PS: running debian sarge 3.1... this is the debian forum. .right ?

Last edited by RestInPieces; 06-30-2006 at 07:32 AM.
 
Old 07-03-2006, 03:48 PM   #4
farslayer
Guru
 
Registered: Oct 2005
Location: Willoughby, Ohio
Distribution: linuxdebian
Posts: 7,231
Blog Entries: 5

Rep: Reputation: 189Reputation: 189
postconf -n would help so we can see your config settings..




and I think the confusion was your profile says Slackware-current under Distribution and doesn't mention Debian
 
  


Reply

Tags
postfix


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How do you test POSTFIX for sending mail out? LneonGREEN Linux - Software 2 11-20-2008 05:24 PM
Postfix mail transfer agent not sending mail locally or to other servers sketelsen Linux - Software 3 02-09-2006 11:16 AM
Sending mail outside my LAN using Postfix Harlin Linux - Networking 1 07-18-2005 04:16 AM
Postfix not sending mail, exits without error kevlarboxers Linux - Software 0 11-28-2004 02:09 PM
Sending mail to Postfix on LAN JimKyle Linux - Networking 0 02-11-2003 04:12 PM


All times are GMT -5. The time now is 07:05 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration