LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 01-03-2007, 04:32 AM   #16
saman007uk
Member
 
Registered: Dec 2003
Location: ~root
Distribution: Debian
Posts: 363

Rep: Reputation: 32

The command is:
Code:
resolvconf -a eth0 name-server-ip
resolvconf -u
Where eth0 is yout netwrok interface and name-server-ip is the IP of your actual ISP name servers.
 
Old 01-03-2007, 07:50 AM   #17
alexxxis
Member
 
Registered: Jun 2004
Distribution: Debian 3.1
Posts: 33

Original Poster
Rep: Reputation: 15
resolvconf -a eth0 xxx.xxx.xxx.xxx

stucks! and does not return unless i do "Ctrl^c"

does this mean that there is a problem with my nameservers?
by the way the nameservers are already in /etc/resolv.conf

Alex
 
Old 01-03-2007, 09:55 AM   #18
saman007uk
Member
 
Registered: Dec 2003
Location: ~root
Distribution: Debian
Posts: 363

Rep: Reputation: 32
I'm pretty sure that you can just edit /etc/resolv.conf manually, but if you don't like that, the following shoudl also solve your problem.

Add the following to the options{} part of /etc/bind/named.conf:
Code:
forwarders {
    x.x.x.x;
};
forward first;
transfers-in 150;
Where x.x.x.x is the nameserver IP. Then restart the bind daemon.

Then, to speed things up a bit, you can add the following for each of other domains/zones that you are hosting DNS data for:
Code:
forwarders {};
This disables forwariding for that zone/domain.

Last edited by saman007uk; 01-03-2007 at 10:03 AM.
 
Old 01-03-2007, 10:52 AM   #19
alexxxis
Member
 
Registered: Jun 2004
Distribution: Debian 3.1
Posts: 33

Original Poster
Rep: Reputation: 15
Excellent!

I added the forwarders and all works fine..

all i need now is store the digest-md5 passwords in the database
and i should be ready (it already works with plain passwords)

BiG thanks to saman007uk

and a note to newbies trying to use this howto:
http://www.besy.co.uk/projects/debia...rver_howto.htm

At its Second version it is not complete and DOES NOT work..
so do not waste your time with it.. the author said a complete
third version will be soon available

Alex
 
Old 01-05-2007, 03:03 PM   #20
saman007uk
Member
 
Registered: Dec 2003
Location: ~root
Distribution: Debian
Posts: 363

Rep: Reputation: 32
I did a bit of searching, and it turns out that the "resolvconf" utility actually reads the DNS data from /etc/network/interfaces.

For example, if your netwrok interface is called eth0, then you file should have something like this:
Code:
auto eth0
iface eth0 inet static
        address x.x.x.x
        netmask x.x.x.x
        gateway x.x.x.x.x
        dns-nameservers [name-servers here, seprated by a space]
        dns-search [your domain name]
Then, as root:
Code:
resolvconf -u
When changing network options, make sure they are correct - if wrong, you could use access to your server from the net (unless you have soem sort of serial console ...).

Last edited by saman007uk; 01-05-2007 at 03:06 PM.
 
Old 01-06-2007, 02:47 PM   #21
alexxxis
Member
 
Registered: Jun 2004
Distribution: Debian 3.1
Posts: 33

Original Poster
Rep: Reputation: 15
i added:

//recursion no;
allow-recursion { 127.0.0.1; };

and it works perfect
no need to edit resolv.conf

Thanks saman007uk,
Alex
 
  


Reply

Tags
postfix, resolvconf


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Why is PostFix sending mail using the email address of the smtp account? taigon Linux - Server 34 02-09-2007 01:09 AM
Postfix with Sasl for Engarde? natewlew Linux - Software 0 09-05-2006 09:34 PM
sasl/postfix smtp relay problems 5teve-o Red Hat 0 04-02-2005 03:50 PM
sasl and postfix configuration smaida Linux - Software 2 12-15-2004 07:48 PM
SMTP AUTH, SASL and Sendmail not getting along prozach Linux - Software 0 12-02-2003 05:10 PM


All times are GMT -5. The time now is 08:29 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration