LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 01-02-2006, 07:38 AM   #1
juanjavier_xxx
Member
 
Registered: Aug 2004
Location: Madrid, Spain
Distribution: Debian stable.
Posts: 186

Rep: Reputation: 30
ping: unknown host www.google.com


However if I do smthng like
Code:
ping 66.102.9.104
64 bytes from 66.102.9.104 (...) time=53.9 ms
1 packet transmitted, 1 received, 0% packet loss,time 53.9 ms
....ping to the outside world works...

Needless to say apt-get whatever does not work

Does it seem to have something to do with DNS server? (...just guessing...)

In the case it is useful: I am behind a hub that leads to an Efficient Speedstream router.

If I take off the hub, everything works. On bootup sequence -while still attached to the hub- I don't get any DHCPOFFER, so system fails to bring up eth0.

But if I edit /etc/network/interfaces and change the line
Code:
iface eth0 inet dhcp
(which even leads to no ping to the outside at all, since no DHCPOFFER is got and so network will remain unreachable)

to something like

Code:
iface eth0 inet static
and then fill appropiately the required values (gateway, dns, ip address, netmask and so on...) then I succesfully ping to the outside, but no name can be resolved thus no navigation or apt-get is achieved to work....

Any ideas?
 
Old 01-02-2006, 07:41 AM   #2
juanjavier_xxx
Member
 
Registered: Aug 2004
Location: Madrid, Spain
Distribution: Debian stable.
Posts: 186

Original Poster
Rep: Reputation: 30
Forgot to mention: I don't think the hub has got something to do with the issue....since no remote ip would be resolved and no ping would work....so...Sorry! Forget the hub, it has not anything to do with it!!!
 
Old 01-02-2006, 07:56 AM   #3
Guttorm
Senior Member
 
Registered: Dec 2003
Location: Trondheim, Norway
Distribution: Debian and Ubuntu
Posts: 1,156

Rep: Reputation: 247Reputation: 247Reputation: 247
Hi

You edit /etc/resolv.conf too, right?

It should contain something like
nameserver xxx.xxx.xxx.xxx
(ip address of DNS server to use)
 
Old 01-02-2006, 08:38 AM   #4
duffmckagan
Senior Member
 
Registered: Feb 2005
Distribution: Cent OS 6.4
Posts: 1,163

Rep: Reputation: 47
/etc/resolv.conf has the DNS server addresses.


So when you type www.google.com, a query is made to the DNS server and then the appriate IP addresses is used for Browsing. (Google's IP address (66.102.9.104) in this case.

There can be more than one DNS server in resolv.conf

For adding more DNS servers, simply :

nameserver xxx.xxx.xxx.xxx
nameserver xxx.xxx.xxx.xxx
and so on.
 
Old 01-02-2006, 09:58 AM   #5
juanjavier_xxx
Member
 
Registered: Aug 2004
Location: Madrid, Spain
Distribution: Debian stable.
Posts: 186

Original Poster
Rep: Reputation: 30
Quote:
Originally Posted by Guttorm
Hi

You edit /etc/resolv.conf too, right?

It should contain something like
nameserver xxx.xxx.xxx.xxx
(ip address of DNS server to use)

----Yes. Here is my resolv.conf:

Code:
nameserver=172.26.0.1
which is the router ip, but I don't manage it to function. Should I add another one in order to make it work?

Greetings.
 
Old 01-02-2006, 10:55 AM   #6
juanjavier_xxx
Member
 
Registered: Aug 2004
Location: Madrid, Spain
Distribution: Debian stable.
Posts: 186

Original Poster
Rep: Reputation: 30
Quote:
Originally Posted by juanjavier_xxx
----Yes. Here is my resolv.conf:

Code:
nameserver=172.26.0.1
which is the router ip, but I don't manage it to function. Should I add another one in order to make it work?

Greetings.
----Simply typing
Code:
nameserver=<ip.of.my.ISP>
solved the problem.

Thanks to you all. Greetings.
 
Old 01-02-2006, 11:05 AM   #7
duffmckagan
Senior Member
 
Registered: Feb 2005
Distribution: Cent OS 6.4
Posts: 1,163

Rep: Reputation: 47
Have you enabled Port Forwarding?

I think you need to read more docs regarding setting up internet on Debian.

Debian Reference - Network Configuration.

This is what you should reading. It helps in 90% of the cases.
 
Old 01-02-2006, 11:06 AM   #8
duffmckagan
Senior Member
 
Registered: Feb 2005
Distribution: Cent OS 6.4
Posts: 1,163

Rep: Reputation: 47
I was late
 
Old 01-02-2006, 02:47 PM   #9
juanjavier_xxx
Member
 
Registered: Aug 2004
Location: Madrid, Spain
Distribution: Debian stable.
Posts: 186

Original Poster
Rep: Reputation: 30
Quote:
Originally Posted by duffmckagan
I was late
---But you tried to help anyway.....

As for the docs I read....the light inside my head was turned on somewhere on linuxquestions, I think in the Network forum....there is a post deep in there that suggests to put the "nameserver=<ip.of.the.ISP>" thing in resolv.conf....which BTW was one of the things I had not tested....
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
ping: unknown host www.google.com tcma Linux - Networking 7 03-03-2012 12:47 AM
difference between www.google.com/linux and www.google.com dr_zayus69 General 4 01-12-2005 03:45 PM
Still can't ping www.google.com Wyk3d Linux - Networking 1 11-07-2004 02:17 PM
ping: unknown host in local intranet linuxjustin Linux - Networking 3 04-04-2004 03:03 PM
Unknown Host <Linuxmachinename> / Unable to ping by host name nishi_k_79 Linux - Networking 4 11-01-2003 02:24 PM


All times are GMT -5. The time now is 11:29 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration