LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 08-26-2011, 09:50 AM   #1
radiodee1
Member
 
Registered: Oct 2006
Location: New York
Distribution: Debian
Posts: 673
Blog Entries: 11

Rep: Reputation: 36
pet peeve: F1 - F6 letters repeat without warning. wheezy/gnome


I have experienced this on three separate installs. It seems in tty1 - tty6 when I press a key the letter corresponding to that key is duplicated many times on the screen. This doesn't happen on gedit for example, or xterm. I go to F1 and try to log in for example. As I'm typing the letters will occasionally show up on the screen multiple times. This is annoying if you're logging in and you cannot see your password as you type, for instance.

My question is, is there a package I can install that will sure up my typing on those terminals? Maybe there's no package but instead there's a setting. Note: this is not the sort of thing that would get me to stop using linux, but it discourages the use of F1 to F6. Has anyone else had this experience?
 
Old 08-27-2011, 03:37 AM   #2
jdkaye
Senior Member
 
Registered: Dec 2008
Location: Westgate-on-Sea, Kent, UK
Distribution: Debian Testing Amd64
Posts: 4,847

Rep: Reputation: Disabled
What distro and what version are you using? You provide very little information about your system (both hardware and software) so diagnosis is extremely difficult. Maybe you could try being more descriptive about the chain of events leading to your problem. For example, I can't replicate your problem. Keys do not repeat when I switch to a tty. We need to know what is different about your setup (or hardware) from the bulk of users who don't experience this problem.
ciao,
jdk
 
Old 08-27-2011, 05:55 AM   #3
radiodee1
Member
 
Registered: Oct 2006
Location: New York
Distribution: Debian
Posts: 673
Blog Entries: 11

Original Poster
Rep: Reputation: 36
Yeah, it's the debian forum, so it's debian. I say in the title that it's wheezy/gnome. The three machines that I'm referring to are all running wheezy. I do mention that it's three separate machines. One is a desktop and two are laptops. I'm not trying to be confusing, I thought I was pretty clear. To be more precise the desktop is a zt computer, a ZT Element 2161LA. The laptops are Dell 1521 and an old Dell 510. None of them are stellar examples of computing power, but they all share this problem.

I thought maybe it was a common problem and there was some package I could install to fix it.
 
Old 08-27-2011, 10:19 AM   #4
jdkaye
Senior Member
 
Registered: Dec 2008
Location: Westgate-on-Sea, Kent, UK
Distribution: Debian Testing Amd64
Posts: 4,847

Rep: Reputation: Disabled
My mistake about the distro & version. Sorry.
Are you sure this is not a hardware problem? Do any errors show up in your syslog or dmesg to indicate what the problem is?
ciao,
jdk
 
Old 08-27-2011, 11:03 AM   #5
radiodee1
Member
 
Registered: Oct 2006
Location: New York
Distribution: Debian
Posts: 673
Blog Entries: 11

Original Poster
Rep: Reputation: 36
Quote:
Originally Posted by jdkaye View Post
Do any errors show up in your syslog or dmesg to indicate what the problem is?
Here's where I have to ask for help. In dmesg or syslog, what am I looking for? Is there a keyword that I can grep by or something? If I 'dmesg | grep tty' I get:

Code:
[    0.000000] console [tty0] enabled
but this doesn't say anything really. Regarding the hardware, the two laptops have built in keyboards, but the desktop has an old fashioned keyboard (not usb).

EDIT: these results are on one of the laptops.

Last edited by radiodee1; 08-27-2011 at 11:06 AM.
 
Old 08-27-2011, 11:16 AM   #6
jdkaye
Senior Member
 
Registered: Dec 2008
Location: Westgate-on-Sea, Kent, UK
Distribution: Debian Testing Amd64
Posts: 4,847

Rep: Reputation: Disabled
Quote:
Originally Posted by radiodee1 View Post
Here's where I have to ask for help. In dmesg or syslog, what am I looking for? Is there a keyword that I can grep by or something?
Usually there are not too many errors so greping for "error" or "warning" might help. There are other logs as well. I assume the keyboard behaves normally when using the desktop environment. Are the settings for your tty's different from those you use for your x-server?
ciao,
jdk
 
Old 08-27-2011, 11:28 AM   #7
radiodee1
Member
 
Registered: Oct 2006
Location: New York
Distribution: Debian
Posts: 673
Blog Entries: 11

Original Poster
Rep: Reputation: 36
'error' and 'warning' produce nothing in dmesg and syslog. Everything is great from the DE. How would I set things up for the tty's and the x-server? I looked in my xorg.conf file and there's nothing special in the "Generic Keyboard" section that seems to stand out. How do I modify settings for the tty's? How could they be different from the x-server?
 
Old 08-27-2011, 01:54 PM   #8
jdkaye
Senior Member
 
Registered: Dec 2008
Location: Westgate-on-Sea, Kent, UK
Distribution: Debian Testing Amd64
Posts: 4,847

Rep: Reputation: Disabled
Have you checked in /etc/default/keyboard?
jdk
 
Old 08-29-2011, 03:01 PM   #9
radiodee1
Member
 
Registered: Oct 2006
Location: New York
Distribution: Debian
Posts: 673
Blog Entries: 11

Original Poster
Rep: Reputation: 36
Quote:
Originally Posted by jdkaye View Post
Have you checked in /etc/default/keyboard?
I looked at the file. This is it, in part.

Code:
# The following variables describe your keyboard and can have the same
# values as the XkbModel, XkbLayout, XkbVariant and XkbOptions options
# in /etc/X11/xorg.conf.

XKBMODEL="pc105"
XKBLAYOUT="us"
XKBVARIANT=""
XKBOPTIONS=""
I think it's for X11, not for F1 - F6. I googled 'XKBOPTIONS' and found that all the options can be set from the command line using this prog. ('setxkbmap') Then I typed 'setxkbmap -print' as a test. On X11/xterm I get this:

Code:
xkb_keymap {
	xkb_keycodes  { include "evdev+aliases(qwerty)"	};
	xkb_types     { include "complete"	};
	xkb_compat    { include "complete"	};
	xkb_symbols   { include "pc+us+inet(evdev)"	};
	xkb_geometry  { include "pc(pc105)"	};
};
and on F1 I get this:

Code:
Cannot open display "default display"
I'm not really saying anything except that the command only seems to work on X.
 
Old 08-29-2011, 06:43 PM   #10
norobro
Member
 
Registered: Feb 2006
Distribution: Debian Sid
Posts: 248

Rep: Reputation: 50
Never had this problem and I don't know whether this will help in your situation or not but you can increase keyboard delay time. Check out "/etc/kbd/config" and as the file says "man kbdrate".
 
Old 09-02-2011, 03:14 PM   #11
radiodee1
Member
 
Registered: Oct 2006
Location: New York
Distribution: Debian
Posts: 673
Blog Entries: 11

Original Poster
Rep: Reputation: 36
thanks, that works.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Could not connect to wicd's D-Bus interface. wheezy/gnome radiodee1 Debian 0 08-20-2011 09:14 AM
[SOLVED] Cannot type certain letters in gnome Tykku Linux - Newbie 3 02-16-2011 01:08 PM
Fedora 10 with GNOME 2.24.3: Num keypad is inop, can't alter repeat key rate/delay nckeecho Linux - Desktop 0 04-13-2009 08:01 PM
Need backup! Officer Gnome Down...i repeat Officer down :( negociator Slackware 9 02-26-2005 10:08 AM


All times are GMT -5. The time now is 10:29 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration