LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 01-25-2006, 10:20 AM   #1
Darek84CJ
LQ Newbie
 
Registered: Dec 2005
Location: MA, USA
Distribution: Debian 3.1
Posts: 9

Rep: Reputation: 0
"perl: warning: Setting locale failed." System wide problem


Hello there! I am new to this forum, and new to Linux. I recently installed and configured Debian 3.1 I must have spent a week googleling and searching this forum for the many questions I had.
I was successful in almost all of my issues, however one has been plaguing me.

In an attempt to update my Nvidia drivers (after 3 days I successfully did so) I fooled around with the m-a package that one website had a HOW-TO on, and I think I messed something up because I remember them asking me a question about a locale setting

The problem is whenever I run apt-get I get these error messages. Whatever I am installing or removing does so without any issues, however just now I tried to run Cedega and it is giving me similar errors, and not letting me start the application!

I am running Debian 3.1 Sarge (stable) with the 2.6.8-2-386 kernell

Here is my apt-get errors
Code:
debian:/home/spaten# apt-get install acm
Reading Package Lists... Done
Building Dependency Tree... Done
The following NEW packages will be installed:
  acm
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 0B/541kB of archives.
After unpacking 1208kB of additional disk space will be used.
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
        LANGUAGE = "en_US:en_GB:en",
        LC_ALL = (unset),
        LANG = "en_US"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
Selecting previously deselected package acm.
(Reading database ... 108973 files and directories currently installed.)
Unpacking acm (from .../main/a/acm/acm_5.0-19_i386.deb) ...
Setting up acm (5.0-19) ..
.

and here is my Cedega errors



Code:
spaten@debian:~$ cedega
(Point2Play_gui.py:13732): Gtk-WARNING **: Locale not supported by C library.
        Using the fallback 'C' locale.
Traceback (most recent call last):
  File "/usr/lib/transgaming_cedega/Point2Play_gui.py", line 40, in ?
    locale.setlocale(locale.LC_ALL, '')
  File "/usr/lib/transgaming_cedega/lib/python2.3/locale.py", line 381, in setlocale
    return _setlocale(category, locale)
locale.Error: locale setting not supported
spaten@debian:~$
If I attempt to do dpkg-reconfigure locales I get this

Code:
debian:/home/spaten# dpkg-reconfigure locales
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
        LANGUAGE = "en_US:en_GB:en",
        LC_ALL = (unset),
        LANG = "en_US"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
/usr/sbin/dpkg-reconfigure: locales is broken or not fully installed
debian:/home/spaten#

Thank you, this website has been wonderful
Darek


And one last quick question, by accident I overwrote my sources.list file, and I do not know the original, Debian installed sources. I am running from a CD-rom, and currently have a sources.list with only the CD-Rom, no offical Debian security update sources!

Last edited by Darek84CJ; 01-25-2006 at 10:27 AM.
 
Old 01-25-2006, 03:14 PM   #2
mushroomboy
Member
 
Registered: Jan 2006
Distribution: Debian Testing ALWAYS!!!
Posts: 363

Rep: Reputation: 43
It has to do with keyboard settings I think and the layout. I think there's another layout you can enable that works? I've fixed it before but the error won't stop anything from running it just popups as an error for when you install packages. You can run a system fine off it I believe.
 
Old 01-25-2006, 04:30 PM   #3
Darek84CJ
LQ Newbie
 
Registered: Dec 2005
Location: MA, USA
Distribution: Debian 3.1
Posts: 9

Original Poster
Rep: Reputation: 0
I fixed it

It wasn't a keyboard issue

I read on a few threads to install and reconfigure 'locales'
When I tried apt-get install locales, it gave me some dependency issue (glibc-2.3.2.ds1-22). When I googled it, I guess it was a known bug. ???

Anyways, I worked around it and installed localeconf. I had to answer a lot of questions, but kept sticking with en_US ECF 8 or something like that

It worked

Thank you
 
Old 01-25-2006, 05:22 PM   #4
kushalkoolwal
Senior Member
 
Registered: Feb 2004
Location: Middle of nowhere
Distribution: Debian Squeeze
Posts: 1,249

Rep: Reputation: 48
Quote:
Originally Posted by Darek84CJ
I fixed it

It wasn't a keyboard issue

I read on a few threads to install and reconfigure 'locales'
When I tried apt-get install locales, it gave me some dependency issue (glibc-2.3.2.ds1-22). When I googled it, I guess it was a known bug. ???

Anyways, I worked around it and installed localeconf. I had to answer a lot of questions, but kept sticking with en_US ECF 8 or something like that

It worked

Thank you
I had exactly the same problem. I found two solutions for this:

1. I upgraded my glib6c while I was installing some packages

2. I did dpkg-reconfigure localeconf (as mentioned above)

Yes, while doing research, I found out that it is a known bug.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
"fsck failed. Please repair manually and reboot" after chaning non-system partition undeaf Suse/Novell 17 02-07-2014 12:18 PM
perl: warning: Falling back to the standard locale ("C"). walterbyrd Debian 11 05-14-2009 08:50 AM
"locale not supported by Xlib, locale set to C" Irad Linux - Software 3 06-25-2006 03:59 PM
problem "make"ing gtk+ "/usr/bin/env: perl -w" caid Linux - Newbie 8 07-29-2005 04:51 AM
using apt appear warning multiple versions of "openssl" in your system preswang Linux - General 2 10-15-2003 09:28 PM


All times are GMT -5. The time now is 02:41 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration