LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Debian (http://www.linuxquestions.org/questions/debian-26/)
-   -   "perl: warning: Setting locale failed." System wide problem (http://www.linuxquestions.org/questions/debian-26/perl-warning-setting-locale-failed-system-wide-problem-407835/)

Darek84CJ 01-25-2006 10:20 AM

"perl: warning: Setting locale failed." System wide problem
 
Hello there! I am new to this forum, and new to Linux. I recently installed and configured Debian 3.1 I must have spent a week googleling and searching this forum for the many questions I had. :)
I was successful in almost all of my issues, however one has been plaguing me.

In an attempt to update my Nvidia drivers (after 3 days I successfully did so) I fooled around with the m-a package that one website had a HOW-TO on, and I think I messed something up because I remember them asking me a question about a locale setting

The problem is whenever I run apt-get I get these error messages. Whatever I am installing or removing does so without any issues, however just now I tried to run Cedega and it is giving me similar errors, and not letting me start the application!

I am running Debian 3.1 Sarge (stable) with the 2.6.8-2-386 kernell

Here is my apt-get errors
Code:


debian:/home/spaten# apt-get install acm
Reading Package Lists... Done
Building Dependency Tree... Done
The following NEW packages will be installed:
  acm
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 0B/541kB of archives.
After unpacking 1208kB of additional disk space will be used.
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
        LANGUAGE = "en_US:en_GB:en",
        LC_ALL = (unset),
        LANG = "en_US"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
Selecting previously deselected package acm.
(Reading database ... 108973 files and directories currently installed.)
Unpacking acm (from .../main/a/acm/acm_5.0-19_i386.deb) ...
Setting up acm (5.0-19) ..

.

and here is my Cedega errors



Code:

spaten@debian:~$ cedega
(Point2Play_gui.py:13732): Gtk-WARNING **: Locale not supported by C library.
        Using the fallback 'C' locale.
Traceback (most recent call last):
  File "/usr/lib/transgaming_cedega/Point2Play_gui.py", line 40, in ?
    locale.setlocale(locale.LC_ALL, '')
  File "/usr/lib/transgaming_cedega/lib/python2.3/locale.py", line 381, in setlocale
    return _setlocale(category, locale)
locale.Error: locale setting not supported
spaten@debian:~$

If I attempt to do dpkg-reconfigure locales I get this

Code:

debian:/home/spaten# dpkg-reconfigure locales
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
        LANGUAGE = "en_US:en_GB:en",
        LC_ALL = (unset),
        LANG = "en_US"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
/usr/sbin/dpkg-reconfigure: locales is broken or not fully installed
debian:/home/spaten#


Thank you, this website has been wonderful
Darek


And one last quick question, by accident I overwrote my sources.list file, and I do not know the original, Debian installed sources. I am running from a CD-rom, and currently have a sources.list with only the CD-Rom, no offical Debian security update sources!

mushroomboy 01-25-2006 03:14 PM

It has to do with keyboard settings I think and the layout. I think there's another layout you can enable that works? I've fixed it before but the error won't stop anything from running it just popups as an error for when you install packages. You can run a system fine off it I believe.

Darek84CJ 01-25-2006 04:30 PM

I fixed it :)

It wasn't a keyboard issue

I read on a few threads to install and reconfigure 'locales'
When I tried apt-get install locales, it gave me some dependency issue (glibc-2.3.2.ds1-22). When I googled it, I guess it was a known bug. ???

Anyways, I worked around it and installed localeconf. I had to answer a lot of questions, but kept sticking with en_US ECF 8 or something like that

It worked :)

Thank you

kushalkoolwal 01-25-2006 05:22 PM

Quote:

Originally Posted by Darek84CJ
I fixed it :)

It wasn't a keyboard issue

I read on a few threads to install and reconfigure 'locales'
When I tried apt-get install locales, it gave me some dependency issue (glibc-2.3.2.ds1-22). When I googled it, I guess it was a known bug. ???

Anyways, I worked around it and installed localeconf. I had to answer a lot of questions, but kept sticking with en_US ECF 8 or something like that

It worked :)

Thank you

I had exactly the same problem. I found two solutions for this:

1. I upgraded my glib6c while I was installing some packages

2. I did dpkg-reconfigure localeconf (as mentioned above)

Yes, while doing research, I found out that it is a known bug.


All times are GMT -5. The time now is 05:00 AM.