LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 07-23-2004, 09:32 AM   #1
walterbyrd
Member
 
Registered: Apr 2004
Posts: 565

Rep: Reputation: 30
perl: warning: Falling back to the standard locale ("C").


I'm getting a this everytime a do an apt-get install. The installs seem to work, but I'm flooded with error messages.
 
Old 07-23-2004, 04:44 PM   #2
mritch
Member
 
Registered: Nov 2003
Location: austria
Distribution: debian
Posts: 667

Rep: Reputation: 30
that's a problem with the locales setting on your system (harmless;-).
type "env" to see your environment.

try
"export LANGUAGE=your_language"
(do the same for LG_ALL & LANG) where your_language is for example "de_AT@euro" or "en_US" and see if everthing right now.

to make it permanent put those settings in your .bashrc or globally ex. /etc/profile:

LG_ALL=de_AT@euro
export LG_ALL

sl mritch.
 
Old 07-23-2004, 05:29 PM   #3
macondo
Senior Member
 
Registered: Jul 2003
Posts: 1,016

Rep: Reputation: 49
mritch is correct.

you can also do it by:

#dpkg-reconfigure locales

choose your locale(s)

for example i choose all the en_US and the es_ES utf-8

in the next screen choose the one you want for your 'environment'
wait for to generate the locales and voilá
 
Old 07-23-2004, 06:30 PM   #4
Dead Parrot
Senior Member
 
Registered: Mar 2004
Distribution: Debian GNU/kFreeBSD
Posts: 1,597

Rep: Reputation: 46
"env" is a nice command to view environment settings, but it only shows the LANG locale. To get a full view of the current locale environment you can use "locale" command.

There's also a program called "localeconf", which I haven't tried myself, so I don't know if it has any advantage over the usual "dpkg-reconfigure locales" (which works beautifully in my Debian box).
 
Old 07-23-2004, 10:02 PM   #5
walterbyrd
Member
 
Registered: Apr 2004
Posts: 565

Original Poster
Rep: Reputation: 30
Thank for the replies. The dpkg-reconfigure locals didn't really work for me.
-------------------------------------
dpkg-reconfigure locals
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = (unset),
LC_ALL = (unset),
LC_CTYPE = "en_US.UTF-8",
LANG = (unset)
are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
Package `locals' is not installed and no info is available.
Use dpkg --info (= dpkg-deb --info) to examine archive files,
and dpkg --contents (= dpkg-deb --contents) to list their contents.
/usr/sbin/dpkg-reconfigure: locals is not installed
---------------------------------------------
 
Old 09-10-2004, 07:17 AM   #6
cammoblammo
LQ Newbie
 
Registered: Sep 2004
Distribution: Debian
Posts: 3

Rep: Reputation: 0
walterbyrd,

This is probably a bit old now, but I think I can see your problem. You typed

dpkg-reconfigure locals

when you needed to type

dpkg-reconfigure locales

That 'e' seems to be the source of your trouble...!
 
Old 01-25-2006, 04:28 PM   #7
Darek84CJ
LQ Newbie
 
Registered: Dec 2005
Location: MA, USA
Distribution: Debian 3.1
Posts: 9

Rep: Reputation: 0
Here is my experience

I read on a few threads to install and reconfigure 'locales'
When I tried apt-get install locales, it gave me some dependency issue. When I googled it, I guess it was a known bug. ???

Anyways, I worked around it and installed localeconf. I had to answer alot of questions, but kept sticking with en_US ECF 8 or something like that

Last edited by Darek84CJ; 01-25-2006 at 04:29 PM.
 
Old 01-18-2007, 03:03 PM   #8
bluej100
LQ Newbie
 
Registered: Jan 2007
Posts: 2

Rep: Reputation: 0
dpkg-reconfigure worked great for me. Thanks, everyone.
 
Old 02-22-2007, 04:52 AM   #9
atul_mehrotra
LQ Newbie
 
Registered: Sep 2004
Posts: 28

Rep: Reputation: 15
I also faced same problems...

But it finally got solved using thsi command.

sudo aptitude install locales

-cheers
 
Old 10-02-2007, 06:38 AM   #10
satimis
Senior Member
 
Registered: Apr 2003
Posts: 3,426

Rep: Reputation: 53
Hi folks,


Ubuntu 7.04 server amd64 Host OS
vmware-mui-distrib-1.0.4-56528
vmware-server-distrib-1.0.4-56528


I have been suffering on similar problem, having googling around for 2 days without a solution.


1)
1st problem - on ssh

On an Ubuntu 7.04 desktop running

$ ssh -Y user@server_router_ip rox
password:
Code:
(process:5576): Gdk-WARNING **: locale not supported by C library

(rox:5576): Gtk-WARNING **: Locale not supported by C library.
        Using the fallback 'C' locale.
Remark: rox - a light-weight file manager


$ ssh user@server_router_ip
$ ls
displaying files and directories of the server which indicates server connnected.


On the other way:

On server
$ ssh -Y user@desktop_router_ip rox
it connected with the rox displayed locally.



2)
2nd problem - on VMWare

$ sudo /etc/init.d/httpd.vmware start
Code:
Starting httpd.vmware:
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
        LANGUAGE = (unset),
        LC_ALL = (unset),
        LANG = "en_HK.UTF-8"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").

Please advise how to fix the problem. TIA.


Remark:
Previously I also suffered on locale problem on this box. I tried to fix it with a new installation of locale resulting in the server crashed. This is a fresh installation, NOT completed yet.


Edit:

$ locale
Code:
LANG=en_HK.UTF-8
LC_CTYPE="en_HK.UTF-8"
LC_NUMERIC="en_HK.UTF-8"
LC_TIME="en_HK.UTF-8"
LC_COLLATE="en_HK.UTF-8"
LC_MONETARY="en_HK.UTF-8"
LC_MESSAGES="en_HK.UTF-8"
LC_PAPER="en_HK.UTF-8"
LC_NAME="en_HK.UTF-8"
LC_ADDRESS="en_HK.UTF-8"
LC_TELEPHONE="en_HK.UTF-8"
LC_MEASUREMENT="en_HK.UTF-8"
LC_IDENTIFICATION="en_HK.UTF-8"
LC_ALL=
$ locale -a
Code:
C
en_AU.utf8
en_BW.utf8
en_CA.utf8
en_DK.utf8
en_GB.utf8
en_HK.utf8
en_IE.utf8
en_IN
en_NZ.utf8
en_PH.utf8
en_SG.utf8
en_US.utf8
en_ZA.utf8
en_ZW.utf8
POSIX
$ apt-cache policy language-pack-en
Code:
language-pack-en:
  Installed: 1:7.04+20070601
  Candidate: 1:7.04+20070601
  Version table:
 *** 1:7.04+20070601 0
        500 http://us.archive.ubuntu.com feisty-updates/main Packages
        100 /var/lib/dpkg/status
     1:7.04+20070412 0
        500 http://us.archive.ubuntu.com feisty/main Packages
B.R.
satimis

Last edited by satimis; 10-02-2007 at 07:26 AM.
 
Old 05-14-2009, 08:44 AM   #11
jamie.krug
LQ Newbie
 
Registered: May 2009
Location: Rochester, NY - US
Distribution: Ubuntu
Posts: 3

Rep: Reputation: 0
Ubuntu VM on Xen FIX

I had a similar problem and the solution that worked for me does not appear to be in this thread, so here you go...

I've had my hosting company setup a couple VPS servers for me, running Ubuntu 8.04 Server 64-bit. Each time I noticed these errors whenever I ran apt-get upgrade:

Code:
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
	LANGUAGE = (unset),
	LC_ALL = (unset),
	LANG = "en_US.UTF-8"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
...and here is the output from the locale command:

Code:
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
LANG=en_US.UTF-8
LC_CTYPE="en_US.UTF-8"
LC_NUMERIC="en_US.UTF-8"
LC_TIME="en_US.UTF-8"
LC_COLLATE="en_US.UTF-8"
LC_MONETARY="en_US.UTF-8"
LC_MESSAGES="en_US.UTF-8"
LC_PAPER="en_US.UTF-8"
LC_NAME="en_US.UTF-8"
LC_ADDRESS="en_US.UTF-8"
LC_TELEPHONE="en_US.UTF-8"
LC_MEASUREMENT="en_US.UTF-8"
LC_IDENTIFICATION="en_US.UTF-8"
LC_ALL=
I know they're running my VMs on Xen, so I found my solution on the Ubuntu Community page for Xen (https://help.ubuntu.com/community/Xen). The doc states that:

Quote:
Debootstrap does not create locales. When you run the virtual machine, if you get errors like the following, run the command below.
...
To fix this, run this, replace en_US.UTF-8 with your own locale.
Code:
sudo locale-gen en_US.UTF-8
That one command did the trick for me. My output from the locale command is then:

Code:
LANG=en_US.UTF-8
LC_CTYPE="en_US.UTF-8"
LC_NUMERIC="en_US.UTF-8"
LC_TIME="en_US.UTF-8"
LC_COLLATE="en_US.UTF-8"
LC_MONETARY="en_US.UTF-8"
LC_MESSAGES="en_US.UTF-8"
LC_PAPER="en_US.UTF-8"
LC_NAME="en_US.UTF-8"
LC_ADDRESS="en_US.UTF-8"
LC_TELEPHONE="en_US.UTF-8"
LC_MEASUREMENT="en_US.UTF-8"
LC_IDENTIFICATION="en_US.UTF-8"
LC_ALL=
Hope that helps someone else!

Best,
Jamie
 
Old 05-14-2009, 08:50 AM   #12
AlucardZero
Senior Member
 
Registered: May 2006
Location: USA
Distribution: Debian
Posts: 4,644

Rep: Reputation: 523Reputation: 523Reputation: 523Reputation: 523Reputation: 523Reputation: 523
I would guess that dpkg-reconfigure locales would do that if you selected en_US.utf8, but that way is good to know too.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
"locale not supported by Xlib, locale set to C" Irad Linux - Software 3 06-25-2006 03:59 PM
problem "make"ing gtk+ "/usr/bin/env: perl -w" caid Linux - Newbie 8 07-29-2005 04:51 AM
perl: warning: Please check that your locale settings: Daredevil Linux - Software 1 05-12-2005 10:47 AM
Howto disable "Graphical Login" or "Standard Login?" the_gripmaster Red Hat 1 07-08-2004 02:55 PM
LFS 4.1: Stalled at Perl, "missing seperator" error from "make" SparceMatrix Linux From Scratch 1 06-07-2003 03:31 PM


All times are GMT -5. The time now is 11:18 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration