LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Debian (http://www.linuxquestions.org/questions/debian-26/)
-   -   paraport_pc module loaded with wrong options, st not loaded (http://www.linuxquestions.org/questions/debian-26/paraport_pc-module-loaded-with-wrong-options-st-not-loaded-267428/)

adrianmariano 12-17-2004 11:13 AM

paraport_pc module loaded with wrong options, st not loaded
 
I'm using SimplyMepis 2004.04 with the 2.6.7 kernel. I have been confused about module loading. I thought that the system would look in /etc/modules.conf and load things that appeared there.

I discovered that my parallel port printer didn't work. I managed to fix it by executing the following:

Code:

# rmmod lp
# rmmod parport
# modprobe parport_pc io=0x378 irq=none
# modprobe lp

But I can't seem to convince the system to do this automatically. I tried specifying these options in /etc/modules.conf. But that had no effect. I also noticed that this file had no entry for "lp" in it, which made me wonder how lp was being loaded at all. I hunted around some more and found /etc/modprobe.d/ which seems like a duplicate in function of /etc/modules.conf. Which one is used??? These files had references to paraport and lp. I added my options in /etc/modprobe.d/arch-aliases as shown below, but this still had no effect.

Code:

alias char-major-6 lp
alias parport_lowlevel parport_pc
options parport_pc io=0x378 irq=none,none

A possibly related problem is that my scsi tape module (st) doesn't load automatically, even though the "alias char-major-9 st " line appears in these config files. I guess I can put it in /etc/modules (assuming this file is actually used). Is that really the solution?

basileus 12-18-2004 11:31 AM

In Debian I have given parameters to my modules like this:

1) Create a new file in /etc/modutils/newfilename
2) Add entries there, for example here's my cdwriter file:

above hid usbcore
options ide-cd ignore=hdc
alias scd0 sr_mod
pre-install sg modprobe ide-scsi # load ide-scsi before sg
pre-install sr_mod modprobe ide-scsi # load ide-scsi before sr_mod
pre-install ide-scsi modprobe ide-cd # load ide-cd before ide-scsi

3) Run command "update-modules"

This is how it is cleanly done in Debian at least... maybe also in Ubuntu.

If it seems that nothing else works, try adding the script you wrote to a startup file. For example, create a new text file in /etc/init.d:

#! /bin/bash

case "$1" in
start)
#actions here
;;
stop)
#actions here, if needed
;;
reload)
#actions here, if needed
;;
force-reload|restart)
#actions here, if needed
;;
*)
echo "Usage: /etc/init.d/yourservice {start|stop|restart|force-reload|reload}"
exit 1
;;
esac

and then change permissions:

chmod 755 yourservice

and then add links to it into init dirs:

update-rc.d yourservice defaults

or check "man update-rc.d" if you want to fiddle with update-rc.d's settings.

Hope some of this helps.

adrianmariano 12-18-2004 09:37 PM

When I looked at modules.conf it says

Quote:

### This file is automatically generated by update-modules"
#
# Please do not edit this file directly. If you want to change or add
# anything please take a look at the files in /etc/modutils and read
# the manpage for update-modules.
So then I followed the directions and I found:

Quote:

NAME
update-modules - obsolete command
Hmmm. This is what made me suspicious that the /etc/modules.conf is ignored. That and the fact that a whole separate /etc/modprobe.d directory full of files that serve (apparently) the same function exists.


All times are GMT -5. The time now is 02:39 PM.