LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 02-16-2005, 07:08 AM   #16
vharishankar
Senior Member
 
Registered: Dec 2003
Posts: 3,142
Blog Entries: 4

Rep: Reputation: 121Reputation: 121

Well to install ALSA kernel modules, you must go to Synaptic and search for "ALSA".

There will be many packages with names like:

Code:
alsa-modules-2.4.27-2-i386
and so on.

Choose the correct module for your kernel architecture (whichever kernel you've installed) and install it and all other ALSA related tools.

Don't load the OSS module at startup but run the ALSA configuration tool.

Install also the alsa-oss module to provide a wrapper for OSS compatible programs in ALSA.

Again to use ALSA, you must install the kernel modules in 2.4 kernel. In 2.6 ALSA is the default and you don't need it.

Last edited by vharishankar; 02-16-2005 at 07:09 AM.
 
Old 02-16-2005, 08:31 AM   #17
GSX
Member
 
Registered: Feb 2005
Location: Germany
Distribution: Debian Etch, kernel 2.6.18
Posts: 103

Original Poster
Rep: Reputation: 15
My kernel-version is 2.6.6-1.

So you mean I donīt need to install the alsa-kernel module?
 
Old 02-16-2005, 08:46 AM   #18
vharishankar
Senior Member
 
Registered: Dec 2003
Posts: 3,142
Blog Entries: 4

Rep: Reputation: 121Reputation: 121
So you're using 2.6!

All right. Try running alsaconf as root. It should autodetect your sound devices if any.
 
Old 02-16-2005, 09:02 AM   #19
GSX
Member
 
Registered: Feb 2005
Location: Germany
Distribution: Debian Etch, kernel 2.6.18
Posts: 103

Original Poster
Rep: Reputation: 15
Ok Iīll do and post you the reply.
 
Old 02-21-2005, 12:11 AM   #20
GSX
Member
 
Registered: Feb 2005
Location: Germany
Distribution: Debian Etch, kernel 2.6.18
Posts: 103

Original Poster
Rep: Reputation: 15
Hi...

I got a soundcard from a friend..
I run alsaconf and everthing worked


Thanks a lot for your help..
Greetz
 
Old 03-01-2005, 12:52 AM   #21
goeko
LQ Newbie
 
Registered: Mar 2005
Location: A cold place
Distribution: Debian Mostly
Posts: 4

Rep: Reputation: 0
Sound with i810

You should of been able to get your sound working by loading the package
alsa-base

I don't believe there is anything wrong with your sound card. The problem is the linux startup is being brain dead, and loading two drivers for the sound card, you can see that by the two modules in the module list your posted,
snd_intel8x0 34952 0
snd_ac97_codec 65188 1 snd_intel8x0
snd_pcm 98148 1 snd_intel8x0
snd_timer 25380 1 snd_pcm
snd_page_alloc 11460 2 snd_intel8x0,snd_pcm
gameport 4704 1 snd_intel8x0
snd_mpu401_uart 7968 1 snd_intel8x0
snd_rawmidi 24704 1 snd_mpu401_uart
snd_seq_device 8200 1 snd_rawmidi
snd 54692 7 snd_intel8x0,snd_ac97_codec,snd_pcm,snd_timer,snd_mpu401_uart,snd_rawmidi,snd_seq_device
i810_audio 33844 0
ac97_codec 18956 1 i810_audio
soundcore 10336 2 snd,i810_audio

the "snd_intel8x0" is the *NEW* module for ALSA sound drivers. And the "i810_audio" is the *OLD* OSS sound drivers (ARG!!) Until you load the alsa-base linux will load both drivers, so your sound wouldn't work.

Good luck with that, it worked really well for me. I was impressed that the sound on a 566mhz system sounded that good with onboard sound!

==>brian.
 
Old 03-02-2005, 11:49 PM   #22
GSX
Member
 
Registered: Feb 2005
Location: Germany
Distribution: Debian Etch, kernel 2.6.18
Posts: 103

Original Poster
Rep: Reputation: 15
How can I stop to load the "alsa-base" module at the start up?
 
Old 03-03-2005, 12:48 AM   #23
goeko
LQ Newbie
 
Registered: Mar 2005
Location: A cold place
Distribution: Debian Mostly
Posts: 4

Rep: Reputation: 0
Okay, now I am confused.

Why do you want to do that, the alsa-base is supposed to fix your sound problem ?

There are a few ways to make it not run alsa at boot. You can just purge the package (this is kinda extreme, it will delete all files with the package, but that way you will be sure it will not run at boot)

dpkg --purge alsa-base

or you could, the "quick & dirty way" edit the script in /etc/init.d/alsa, and add the exit command at the begining of the script. That will leave the script there, but every time it is run, it will just exit (as long as you put the exit before any other commands) before it does anything. That is kinda a temp/simple way to disable it.

You can also user update-rc.d, you will have to look at the man page on how that works, and have it not run on run at any run levels.

If I know why you don't want it to run, I can give a better answer.

==>brian.
 
Old 03-03-2005, 01:39 AM   #24
GSX
Member
 
Registered: Feb 2005
Location: Germany
Distribution: Debian Etch, kernel 2.6.18
Posts: 103

Original Poster
Rep: Reputation: 15
Sorry, I misunderstood you :-)

I thought I have to stop load the alsa-base package...


Please tell me the better answer



Greetz
 
Old 03-04-2005, 11:57 PM   #25
goeko
LQ Newbie
 
Registered: Mar 2005
Location: A cold place
Distribution: Debian Mostly
Posts: 4

Rep: Reputation: 0
To get the sound working with the Intel i810 chip set with debian, you need to load the package alsa-base. You can load that with this command

apt-get install alsa-base

and then reboot (there are other ways to do that but that is the easiest) and your sound should work.

You should be able to

cat /proc/asound/cards

and you should see your sound card in there.

You should also load the alsa-utils package, that has some nice utils for working with the alsa sound system.

Does that help ?

==>brian.
 
Old 03-07-2005, 02:17 AM   #26
GSX
Member
 
Registered: Feb 2005
Location: Germany
Distribution: Debian Etch, kernel 2.6.18
Posts: 103

Original Poster
Rep: Reputation: 15
@ gueko

Iīll try and post the results :-)
 
Old 03-08-2005, 04:24 AM   #27
GSX
Member
 
Registered: Feb 2005
Location: Germany
Distribution: Debian Etch, kernel 2.6.18
Posts: 103

Original Poster
Rep: Reputation: 15
Hi all,

thanks a lot for your great help.....I did like gueko said (load the alsa-module) and now my
onboard sound work perfectly......

Thx all


Greetz
GSX
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to chown -R don.lab * for don.users Hans Zilles Linux - Newbie 3 11-15-2005 07:53 AM
Laptop keyboard donīt work under 2005 LE guckusko Mandriva 2 10-11-2005 11:04 AM
Suse dontīt boot X; donīt ask for root passwd, YAST donīt work... carrie Linux - Newbie 4 10-08-2004 07:46 AM
quota don`t work vytenis Slackware 0 02-13-2004 04:25 AM
altgr don' t work intrip Linux - Hardware 0 12-14-2003 01:41 PM


All times are GMT -5. The time now is 07:21 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration