LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 02-14-2005, 02:22 AM   #1
GSX
Member
 
Registered: Feb 2005
Location: Germany
Distribution: Debian Etch, kernel 2.6.18
Posts: 103

Rep: Reputation: 15
Unhappy Onborad sound donīt work!!! HELP


Hi,

my sound donīt work
In KDE I I selected ALSA but I get the error "Cannot load sound module..."


I run Debian Sarge with kernel 2.6.6-1.

My motherboard is an

ASUS P4P8X with onboardsound:

--- Audio ADI AD1985 SoundMAX 6-channel CODEC -----

When I boot-up debian Linux load the sound module ACī97 successfully, but itīs the wrong module.

Is there a SoundMax-driver available for Debian?
Or have somebody the same problems?


Please help..
Greetz
GSX
 
Old 02-14-2005, 02:56 AM   #2
vharishankar
Senior Member
 
Registered: Dec 2003
Posts: 3,142
Blog Entries: 4

Rep: Reputation: 121Reputation: 121
You must manually load the module i810_audio.

Become root then type in a terminal.

Code:
modprobe i810_audio
To load the module every time you boot you need to run some command which I forget now. I'll try to find it out for you. Meanwhile you can load the module by hand.
 
Old 02-14-2005, 03:06 AM   #3
vharishankar
Senior Member
 
Registered: Dec 2003
Posts: 3,142
Blog Entries: 4

Rep: Reputation: 121Reputation: 121
Ah found the command.

Issue
Code:
update-modules
as root to automatically configure to load the modules at startup.
 
Old 02-14-2005, 03:18 AM   #4
GSX
Member
 
Registered: Feb 2005
Location: Germany
Distribution: Debian Etch, kernel 2.6.18
Posts: 103

Original Poster
Rep: Reputation: 15
First thanks a lot for your fast reply :-)

Iīm not 100% sure but I think my debian system also loads the i810_audio module at startup.
But Linux said something about ID=0 ???
But I donīt know what that means...

Maybe the problem that Linux loads both audio modules???
In case Linux loads the i810 module correctly, what can be the reason that my sound donīt work?
Where can I check it out?
 
Old 02-14-2005, 03:37 AM   #5
vharishankar
Senior Member
 
Registered: Dec 2003
Posts: 3,142
Blog Entries: 4

Rep: Reputation: 121Reputation: 121
Go as root and type
Code:
lsmod
and paste the results here.

Also open KDE Control Center -> Sound and Multimedia -> Sound System.

Tell us the options selected and whether the sound system is enabled or not.
 
Old 02-14-2005, 03:55 AM   #6
GSX
Member
 
Registered: Feb 2005
Location: Germany
Distribution: Debian Etch, kernel 2.6.18
Posts: 103

Original Poster
Rep: Reputation: 15
Ok,

I paste the results here for you...

But I can only post it tommorrow because I donīt have internet at home, ok?


Thanks in advance
Greetz
GSX
 
Old 02-14-2005, 06:42 AM   #7
HalfDiminished
Member
 
Registered: Jan 2005
Location: Santa Barbara, CA
Distribution: Ubuntu Hoary/Debian 3.1/RHEL-WS3/DSL 1.1
Posts: 66

Rep: Reputation: 15
Quick note - KDE by default uses the arts sound server. This needs to be turned off to free up the sound services for alsa. In the configuration gui (control center?) on the KDE menu, there is a 'sound' section. Look in there to find how to disable arts.
 
Old 02-14-2005, 08:29 AM   #8
GSX
Member
 
Registered: Feb 2005
Location: Germany
Distribution: Debian Etch, kernel 2.6.18
Posts: 103

Original Poster
Rep: Reputation: 15
Hi, I was at home and hereīs my lsmod :

Module Size Used by
ds 18500 0
yenta_socket 21376 0
pcmcia_core 67620 2 ds,yenta_socket
snd_intel8x0 34952 0
snd_ac97_codec 65188 1 snd_intel8x0
snd_pcm 98148 1 snd_intel8x0
snd_timer 25380 1 snd_pcm
snd_page_alloc 11460 2 snd_intel8x0,snd_pcm
gameport 4704 1 snd_intel8x0
snd_mpu401_uart 7968 1 snd_intel8x0
snd_rawmidi 24704 1 snd_mpu401_uart
snd_seq_device 8200 1 snd_rawmidi
snd 54692 7 snd_intel8x0,snd_ac97_codec,snd_pcm,snd_timer,snd_mpu401_uart,snd_rawmidi,snd_seq_device
i810_audio 33844 0
ac97_codec 18956 1 i810_audio
soundcore 10336 2 snd,i810_audio
i8xx_tco 6964 0
hw_random 5460 0
ehci_hcd 29988 0
uhci_hcd 31632 0
usbcore 108060 4 ehci_hcd,uhci_hcd
shpchp 102220 0
pciehp 102412 0
pci_hotplug 36400 2 shpchp,pciehp
intel_agp 18556 1
intel_mch_agp 10576 0
agpgart 34152 2 intel_agp,intel_mch_agp
evdev 9536 0
capability 4100 0
commoncap 7200 1 capability
ide_cd 43268 0
cdrom 40384 1 ide_cd
rtc 12760 0
xfs 622232 0
reiserfs 236656 0
vfat 14656 0
fat 46624 1 vfat
isofs 35416 0
ext2 72456 0
ext3 126184 1
jbd 62008 1 ext3
mbcache 9348 2 ext2,ext3
ide_disk 19872 3
ide_generic 1408 0
piix 13696 1
ide_core 149696 4 ide_cd,ide_disk,ide_generic,piix
unix 28560 6
font 8320 0
cfbcopyarea 3840 0
cfbimgblt 3040 0
cfbfillrect 3776 0


In KDE my sound is activated, but when I select ALSA, I get the error that the sound module cannot be loaded!!!


Greetz
GSX
 
Old 02-14-2005, 09:37 AM   #9
vharishankar
Senior Member
 
Registered: Dec 2003
Posts: 3,142
Blog Entries: 4

Rep: Reputation: 121Reputation: 121
Try the Open Sound System option in KDE Sound System audio device option in the Hardware tab.

Last edited by vharishankar; 02-14-2005 at 09:38 AM.
 
Old 02-14-2005, 09:45 AM   #10
GSX
Member
 
Registered: Feb 2005
Location: Germany
Distribution: Debian Etch, kernel 2.6.18
Posts: 103

Original Poster
Rep: Reputation: 15
OK I try but whatīs about the

ACī97 and i810_audio modules?

I donīt need both modules, donīt I?
 
Old 02-15-2005, 02:04 AM   #11
GSX
Member
 
Registered: Feb 2005
Location: Germany
Distribution: Debian Etch, kernel 2.6.18
Posts: 103

Original Poster
Rep: Reputation: 15
Hi,

when I select OSS instead of ALSA I get the same error
<Cannot load sound module>.

When I run "update-modules", is it also possible to remove modules from the automatically start-up?
 
Old 02-16-2005, 01:40 AM   #12
f1dave
Member
 
Registered: Jan 2005
Location: Kinross, Western Australia
Distribution: Kubuntu 5.04 (Hoary)
Posts: 114

Rep: Reputation: 15
Damn this problem comes up all the time.

From memory, i used to have the same problem until a more recent copy of sarge detected everything nicely. (I've got an ASUS board too- ANK8E or something [hell i'm at work and it's got a random abbreviated name i can't remember]) But i remember messing around with AC97, i810 etc... and i also remember finding the answer at that wonderful repository of complaining linux users that is google :P

So yeah, go there and search your onboard sound with "no sound" or something in a google linux search and i'm sure you'll find something. Hell, i'm sure you'll get some results doing a similar search here.

Dave.
 
Old 02-16-2005, 02:11 AM   #13
GSX
Member
 
Registered: Feb 2005
Location: Germany
Distribution: Debian Etch, kernel 2.6.18
Posts: 103

Original Poster
Rep: Reputation: 15
Hi,

Yesterday I read my kern.log...

Code:
Feb 15 16:09:06 lowrider kernel: Intel 810 + AC97 Audio, version 0.24, 15:59:45 May 12 2004
Feb 15 16:09:06 lowrider kernel: PCI: Setting latency timer of device 0000:00:1f.5 to 64
Feb 15 16:09:06 lowrider kernel: i810: Intel ICH5 found at IO 0xee80 and 0xe800, MEM 0xfebff800 and 0xfebff400, IRQ 17
Feb 15 16:09:06 lowrider kernel: i810: Intel ICH5 mmio at 0xf894c800 and 0xf89e3400
Feb 15 16:09:06 lowrider kernel: i810_audio: Primary codec has ID 0
Feb 15 16:09:06 lowrider kernel: i810_audio: Audio Controller supports 6 channels.
Feb 15 16:09:06 lowrider kernel: i810_audio: Defaulting to base 2 channel mode.
Feb 15 16:09:06 lowrider kernel: i810_audio: Resetting connection 0
Feb 15 16:09:06 lowrider kernel: i810_audio: Connection 0 with codec id 0
Feb 15 16:09:06 lowrider kernel: ac97_codec: AC97 Audio codec, id: ADS117 (Unknown)
Feb 15 16:09:06 lowrider kernel: i810_audio: AC'97 codec 0 supports AMAP, total channels = 6

When I select the ALSA-driver:

Code:
Error-message: "Error while initializing the sound driver:
device: default canīt be openend for playback (No such file or directory)
The sound server will continue, using the null output device

I deactivated aRts... but no sound

When I select the OSS-driver:
No error but also no sound.



What can I do?
Greetz
 
Old 02-16-2005, 03:21 AM   #14
vharishankar
Senior Member
 
Registered: Dec 2003
Posts: 3,142
Blog Entries: 4

Rep: Reputation: 121Reputation: 121
If you selected your OSS driver and you get no error message, did you run the volume control (kmix) to set the volume correctly?

Also if you want ALSA, make sure the ALSA kernel modules are installed (not installed by default I think in kernel 2.4). Just go to synaptic and search for ALSA and install the relevant ALSA kernel module.
 
Old 02-16-2005, 05:31 AM   #15
GSX
Member
 
Registered: Feb 2005
Location: Germany
Distribution: Debian Etch, kernel 2.6.18
Posts: 103

Original Poster
Rep: Reputation: 15
I configured kmix, I think itīs correctly set-up.

There is something weird:

The first time I selected OSS I got an error:
"Cannot find /dev/dsp*"

Then I selected ALSA: I wrote the error above.

Then I selected OSS again and I didnīt get an error (And I didnīt click to : DO NOT SHOW AGAIN THIS MESSAGE)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to chown -R don.lab * for don.users Hans Zilles Linux - Newbie 3 11-15-2005 07:53 AM
Laptop keyboard donīt work under 2005 LE guckusko Mandriva 2 10-11-2005 11:04 AM
Suse dontīt boot X; donīt ask for root passwd, YAST donīt work... carrie Linux - Newbie 4 10-08-2004 07:46 AM
quota don`t work vytenis Slackware 0 02-13-2004 04:25 AM
altgr don' t work intrip Linux - Hardware 0 12-14-2003 01:41 PM


All times are GMT -5. The time now is 05:26 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration