LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices



Reply
 
Search this Thread
Old 09-08-2005, 08:41 AM   #1
zuessh
Member
 
Registered: Jun 2002
Location: USA
Distribution: Suse 8.0
Posts: 247

Rep: Reputation: 30
Odd xlib error after kernel upgrade


I upgraded my kernel to 2.6.12 and am now receiving the following message after viewing or use vi on a file

view /etc/hosts
Xlib: connection to ":0.0" refused by server
Xlib: No protocol specified

Xlib: connection to ":0.0" refused by server
Xlib: No protocol specified

Xlib: connection to ":0.0" refused by server
Xlib: No protocol specified

this error only happens after i exit the file. The other oddity is that is only happens when i am the root user. If i vi or view a file as a standard user i do not receive the message. I did some googleing and everything seem to point to the lo interface not being up, mine is up. Also maybe a problem with /etc/hosts but mine looks correct. If i try xhost + i receive the exact same message. Any thoughts? Thanks
 
Old 09-08-2005, 08:52 AM   #2
zuessh
Member
 
Registered: Jun 2002
Location: USA
Distribution: Suse 8.0
Posts: 247

Original Poster
Rep: Reputation: 30
Okay, somewhat by accident i was able to get around this issue. intead of issuing the xhost + command as root, i issued it as my normal user. It works. This leads me to believe that for some reason root did not have access to my x server? how can this be resolved? i don't like the idea of using xhost + at all times. Thanks
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Kernel Audit Support Unavaible error when booting after kernel upgrade abefroman Red Hat 2 03-21-2013 09:32 AM
Kernel Install Odd Error inescapeableus Linux - Software 13 10-22-2005 07:11 PM
Odd kernel message error Seventh Linux - Software 3 07-05-2005 03:30 PM
odd mouse action on kernel upgrade rosslaird Debian 2 07-26-2004 01:27 PM
Kernel upgrade error..... tinaa Linux - Software 3 07-21-2003 02:14 PM


All times are GMT -5. The time now is 11:52 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration