LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 12-07-2006, 04:11 PM   #1
farpoint
Member
 
Registered: Sep 2004
Location: France
Distribution: Debian Sarge, Etch. FC1,2,3,4,5. Slackware 10.0. Gentoo. Kubuntu.
Posts: 193

Rep: Reputation: 30
Odd IP address 169.254.187.86 in ifconfig (Etch)


I have gkrellm installed for most of my distros, and use the plugin gkrellmip, which displays the IP address of the machine, (I use static addresses). I've just set the plugin up on Etch, and the IPaddress is showing as 169.254.187.86, but the machine address is 192.168.0.8. I verified this by FTP'ing from the other machine to 192.168.0.8, and get a connection with no problem. /etc/network/interfaces shows the network setup I made when installing Woody, then upgraded to Sarge, while still in testing, and now it's still in the testing repo, but as Etch. 192.168.0.8 is showing as the IP address, and 192.168.0.1 as the gateway, which is correct.

I'm posting this from FC2. And the same IP 169.254.0.0 shows up in FC2's routing table, but not in ifconfig. See below.
[root@localhost djmons]# /sbin/ifconfig
eth0 Link encap:Ethernet HWaddr 00:50A:B5:38:49
inet addr:192.168.0.230 Bcast:192.168.0.255 Mask:255.255.255.0
inet6 addr: fe80::250:daff:feb5:3849/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:193075 errors:0 dropped:0 overruns:0 frame:0
TX packets:85038 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:75071601 (71.5 Mb) TX bytes:7964896 (7.5 Mb)
Interrupt:10 Base address:0x1000

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:346 errors:0 dropped:0 overruns:0 frame:0
TX packets:346 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:27328 (26.6 Kb) TX bytes:27328 (26.6 Kb)

[root@localhost djmons]# /sbin/route
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
192.168.0.0 * 255.255.255.0 U 0 0 0 eth0
169.254.0.0 * 255.255.0.0 U 0 0 0 eth0
default 192.168.0.1 0.0.0.0 UG 0 0 0 eth0

I've got Sarge booted up on the other machine at the moment, so will post the output for ifconfig, and route for that, and gkrellm displays the correct IP address. See output below.

Last login: Thu Dec 7 20:38:44 2006
djmons@debian:~$ su
Password:
debian:/home/djmons# ifconfig
eth0 Link encap:Ethernet HWaddr 00:40:F4:93:28:F5
inet addr:192.168.0.7 Bcast:192.168.0.255 Mask:255.255.255.0
inet6 addr: fe80::240:f4ff:fe93:28f5/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:221 errors:0 dropped:0 overruns:0 frame:0
TX packets:251 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:31529 (30.7 KiB) TX bytes:19170 (18.7 KiB)
Interrupt:11 Base address:0xe000

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:129 errors:0 dropped:0 overruns:0 frame:0
TX packets:129 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:10429 (10.1 KiB) TX bytes:10429 (10.1 KiB)

debian:/home/djmons# route
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
localnet * 255.255.255.0 U 0 0 0 eth0
default 192.168.0.1 0.0.0.0 UG 0 0 0 eth0

Now back to Etch having rebooted into it. I can FTP into it using IP 192.168.0.8 (the correct address), but trying to ssh into it with the same address fails. so I try ssh 169.254.187.86, and it asks if I want to continue, so Yes, and I have a connection. I have tried changing the IP address with ifconfig, but when I reboot it reverts to this 169.254. ....... address. Anyway the output from ifconfig, and route is below, while being ssh'd into Etch with what really is the wrong IP address.

Last login: Thu Dec 7 22:40:47 2006
djmons@debian:~$ su
Password:
debian:/home/djmons# ifconfig
eth0 Link encap:Ethernet HWaddr 00:40:F4:93:28:F5
inet addr:169.254.187.86 Bcast:169.254.255.255 Mask:255.255.0.0
inet6 addr: fe80::240:f4ff:fe93:28f5/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:153 errors:0 dropped:0 overruns:0 frame:0
TX packets:306 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:17509 (17.0 KiB) TX bytes:22579 (22.0 KiB)
Interrupt:11 Base address:0xe000

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:236 errors:0 dropped:0 overruns:0 frame:0
TX packets:236 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:19460 (19.0 KiB) TX bytes:19460 (19.0 KiB)

debian:/home/djmons# route
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
localnet * 255.255.255.0 U 0 0 0 eth0
169.254.0.0 * 255.255.0.0 U 0 0 0 eth0
default 192.168.0.1 0.0.0.0 UG 0 0 0 eth0


Any suggestions for a fix for this Etch network problem?

the gateway address is correct in "route" , but the 192.168.0.0 network address is missing.

Ifconfig has the wrong IP address for the machine. It's showing as 169.254.187.86, but should be 192.168.0.8

All a bit confusing.

Nigel. aka farpoint.
 
Old 12-07-2006, 04:18 PM   #2
pljvaldez
Guru
 
Registered: Dec 2005
Location: Somewhere on the String
Distribution: Debian Squeeze (x86)
Posts: 6,092

Rep: Reputation: 269Reputation: 269Reputation: 269
You know, I've had a similar problem with Etch (I also have gkrellm). Whenever I reboot the machine (which isn't very often), it comes up with that same address. All I have to do is do ifdown and ifup again since I have static DHCP setup on the router (i.e. it resends the IP request and always gets assigned the same IP address).
 
Old 12-07-2006, 05:09 PM   #3
Brian1
Guru
 
Registered: Jan 2003
Location: Seymour, Indiana
Distribution: Distribution: RHEL 5 with Pieces of this and that. Kernel 2.6.23.1, KDE 3.5.8 and KDE 4.0 beta, Plu
Posts: 5,700

Rep: Reputation: 61
Might read this link on the odd IP you mention. http://www.redhat.com/archives/fedor.../msg03565.html

I think it arises when the module is loaded but no networking has been started so it gets a temporary IP.

Brian
 
Old 12-07-2006, 05:12 PM   #4
farpoint
Member
 
Registered: Sep 2004
Location: France
Distribution: Debian Sarge, Etch. FC1,2,3,4,5. Slackware 10.0. Gentoo. Kubuntu.
Posts: 193

Original Poster
Rep: Reputation: 30
OK. I ifdown eth0, then I get.
Stopping ClamAV virus database updater: freshclam.
Now I ifup eth0.
debian:/home/djmons# ifup eth0
SCIOCSIFADDR: File exists
Failed to bring up eth0.

That may be so but gkrellm is now showing the correct IP address 192.168.0.8, but Konqueror cannot access the Internet.

So I run ifup eth0 again.

debian:/home/djmons# ifup eth0
Starting ClamAV virus database updater: freshclam.

Getting weirder, and weirder. Now I can access the Internet, and gkrellm still shows the correct IP address, but I betya, if I reboot the Etch install it will revert to gkrellm displaying the 169.254.187.86 address.

Yup. Thats confirmed. After a reboot gkrellm is showing eth0 169.254.187.86, and Internet access is available.

I'm losing the plot at the moment, but if anyone has some sort of fix to get rid of this unwanted IP address.

Nigel. aka.farpoint

,
 
Old 12-07-2006, 09:42 PM   #5
farslayer
Guru
 
Registered: Oct 2005
Location: Willoughby, Ohio
Distribution: linuxdebian
Posts: 7,231
Blog Entries: 5

Rep: Reputation: 189Reputation: 189
You probably need to look at when your network card module is being loaded in relation to when the networking services are started.. I have a feeling somethig is either out of order or overlapping.
 
Old 12-08-2006, 03:05 PM   #6
farpoint
Member
 
Registered: Sep 2004
Location: France
Distribution: Debian Sarge, Etch. FC1,2,3,4,5. Slackware 10.0. Gentoo. Kubuntu.
Posts: 193

Original Poster
Rep: Reputation: 30
As far as dmesg says, 8139too is loading early in the boot sequence, and eth0 ifup is sometime later on.

I googled for IP 169.254.0.0 which took me to IANA. The FAQ there says this address is used as a stand-in when a static address can't be found, but I did set a static address when I installed this OS, and during bootup 192.168.0.8, along with 169.254.187.86 show up, but only the 169.254.187.86 address shows up in ifconfig.

I have installed all my 3 Debian installs from Woody 3.0r2 CDROMS. They were all upgraded to Sarge when Sarge was still in testing. 2 of them are still at Sarge, now in the stable repo, but the other I continued in the testing repo, which is my Etch install. Etch is a bit experimental in a way, but apart from this small problem with the IP address is going just fine, but loads of updates.

What I need to do is get 192.168.0.8 into the ifconfig file permanantly.

Is there something I can run similar to the network setup when installing the OS? FC2 has /etc/sysconfig/network/ifconfig as a file that I can directly edit, but Debian has no such file. Is it possible to directly edit ifconfig as a file in Debian Etch?

I'm getting a bit desperate here, but it's only a small problem. I'm just trying to get the correct machine address showing on Gkrellm, and it's not 169.254.187.86, which is some sort of pseudo address.

This ain't too serious folks, just a puzzle I'm trying to solve.

Nigel. aka farpoint.
 
Old 12-08-2006, 08:43 PM   #7
farslayer
Guru
 
Registered: Oct 2005
Location: Willoughby, Ohio
Distribution: linuxdebian
Posts: 7,231
Blog Entries: 5

Rep: Reputation: 189Reputation: 189
Other bizarre things I have seen are IEEE 1394 Ports (Firewire) that come up claiming they are eth0, pushing my network card back to eth1.. is there a firewire port on the motherboard ?

Just trying to think of other things that could muck up a perfectly good network config..
 
Old 12-09-2006, 12:26 PM   #8
Brian1
Guru
 
Registered: Jan 2003
Location: Seymour, Indiana
Distribution: Distribution: RHEL 5 with Pieces of this and that. Kernel 2.6.23.1, KDE 3.5.8 and KDE 4.0 beta, Plu
Posts: 5,700

Rep: Reputation: 61
You can run a network over a ieee1394 interface. It isw loaded using the module eth1394. http://www.linux1394.org/

Not a Debian user but the file for editing is /etc/network/interfaces.
http://www.debian.org/doc/manuals/re...ateway.en.html

Brian
 
Old 12-11-2006, 11:10 AM   #9
farpoint
Member
 
Registered: Sep 2004
Location: France
Distribution: Debian Sarge, Etch. FC1,2,3,4,5. Slackware 10.0. Gentoo. Kubuntu.
Posts: 193

Original Poster
Rep: Reputation: 30
Bingo! Problem solved after a posting to Debian users list. zeroconf is the fly in the ointment.

Apparently this is a regular query, but unless you know that zeroconf is the culprit, you don't know what you're looking for in the archives.

Anyway the fix, at least for me was.

apt-get --purge remove zeroconf

And miraculously after that Gkrellm switched IP addresses to the correct static address for the distro.

I'm still left with a little problem, no doubt due to all my messing with network settings.

I can't access the Internet with Konqueror. It's not a DNS problem, because I can't access the Smoothwalls webserver using the gateway address either. KDE's Konsole works ok, using apt-get for updates, and both Opera, and Firefox can access the Internet ok. I've just checked, and there's no problem with Kmail downloading the mail either. It seems to be confined to Konqueror if anyone has any ideas.

Otherwise it's a trip to the KDE list, in case there's some magic incantation that will fix it.

Thanks for all the suggestions folks.

Nigel. aka farpoint.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Removing DHCP (169.254.0.0) From static routes Alistair Linux - Networking 2 09-02-2011 09:49 AM
Odd Software Update Error- Etch hitest Debian 8 08-29-2006 02:13 PM
ifconfig reports wrong mac address and wireless doesn't work blackdragonblood Linux - Wireless Networking 7 04-15-2006 12:08 PM
169.254.0.0 in Kernal IP routing table aikempshall Linux - Networking 13 03-10-2004 11:30 PM
extracting IP address from ifconfig nowonmai Programming 2 11-24-2003 03:28 AM


All times are GMT -5. The time now is 08:45 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration