LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Debian (http://www.linuxquestions.org/questions/debian-26/)
-   -   NVidia driver install fails on Debian 6 (http://www.linuxquestions.org/questions/debian-26/nvidia-driver-install-fails-on-debian-6-a-890810/)

Arcane 07-09-2011 12:36 PM

NVidia driver install fails on Debian 6
 
Before you shout "OMG RTFM!" let me say i did. I followed all the steps(enabled non-free and contrib, executed given commands replacing &{VERSION} with -legacy173xx since i have FX 5200 and received no error messages during those commands in terminal) mentioned in this wiki about installation but at the end where comes config and launch part something is not working. First i had no existing xorg.conf after going through process and second when i execute nvidia-xconfig and make that file after restart it just doesn't launch xserver anymore. So i need rm xorg.conf to restart it without that file in /etc/X11. Also if i install with nvidia homepage .run file after it creates nouveau disable file then i can't set any normal resolution - it shows 0Hz refresh rate and shows some colored lines like rainbow. And if i combine this with another xorg.conf i get same message and it doesn't start at all. Either i'm missing some important detail or that wiki is bit outdated. Any ideas would be nice.

EDDY1 07-09-2011 01:24 PM

In order to get mine working I had to do it from console. For some reason I couldn't do it from a terminal.
Alos I follwowed the directions for setting up Compiz.

This is the 1 I used. It shows that you have to use both commands under link.
http://www.howtoforge.com/enabling-c...a-geforce-8200
X -configure
nvidia-xconfig

Arcane 07-10-2011 12:30 PM

Unfortunately even that guide didn't help. When i do startx after done making xorg.conf there is some large portion of info text which stays same. Most of it is about x server and linux and some it's content versions and paths. However it mentions some failure lines like:
- Error inserting nvidia (/lib path to nvidia.ko) No such device
- Failed to load NVidia kernel module
- Screens found but none have usable configuration
- Fatal server error
no screens found
- xinit: no such file or directory (errno 2) unable to connect to x server
xinit: no such process (errno 3) Server error
Another interesting thing is working xorg file path is /usr/share/X11/xorg.conf.d Hope this helps more. Once more - i did every step correctly written in above mentioned guides(i only skipped build custom kernel step in debian wiki since i use vanilla squeeze) and received no error messages and got confirmation everything downloaded and installed correctly. Problem is in xorg file setup untill then i can't even use nvidia-settings to save to file because it says i'm not using nvidia x driver and should enable doing nvidia-xconfig as root then restarting x server which is what i did already before without success.

widget 07-10-2011 01:26 PM

You may want to run, from the command prompt as root;
Code:

apt-get install --reinstall xinit
I am not sure how you installed but that package may be missing or corrupted. That command should fix either situation as far as startx goes. That is assuming the rest of the "x" stuff is installed.

gradinaruvasile 07-10-2011 02:09 PM

Quote:

Originally Posted by widget (Post 4410814)
You may want to run, from the command prompt as root;
Code:

apt-get install --reinstall xinit
I am not sure how you installed but that package may be missing or corrupted. That command should fix either situation as far as startx goes. That is assuming the rest of the "x" stuff is installed.

I dont think that it has to do with anything else but the nvidia driver and its installation procedure.

To the OP:

Please specify every single step you did (exactly your commands) for the installation.

About the nvidia .run driver from the nvidia site:
It works perfectly well (i used it on many coputers, Ubuntu and Debian and never had any problems with it) - but there are a few things that must be kept in mind:
1. The nouveau driver MUST be blacklisted.
2. Before installing, every nvidia-related package MUST be purged from the system to avoid conflicts.
3. The X server MUST be shut down during the installation - so this has to be done from a VT (virtual terminal).
4. The default gcc compiler MUST match the one used to compile the running kernel - otherwise the compiled nvidia.ko might be refused by the kernel at load time.
5. The driver MUST be reinstalled after every major kernel or any x server upgrade - because on major kernel upgrade the kernel module (nvidia.ko) has to be recompiled to match the new kernel and the x server has some components that are replaced by the nvidia driver and if the xserver packages are upgraded these will be rewritten and you will lose opengl.

Other than these above, the installation is very simple:
1. Switch to a VT and log in
2. stop the x server:

sudo service gdm3 stop

(if you use another display manager, use accordingly - ex. xdm or kdm)

3. Install the driver:

sudo /path/nvidiadriver.run

(change the names accordingly)

4. Start the display manager:

service gdm3 start

Arcane 07-10-2011 02:25 PM

Quote:

Originally Posted by widget (Post 4410814)
{...}I am not sure how you installed but that package may be missing or corrupted.{...}

Still nothing changes. I did Debian net-install base install. Then i installed Fluxbox and this time LXDE but i did same commands from base without DE or WM either and same result. If i need post some file content then let me know which one you need. Seems like another sign i should read about xorg and how it works since one more distro(PC-BSD) didn't work because of this file.
Quote:

Originally Posted by gradinaruvasile (Post 4410863)
{...}Please specify every single step you did (exactly your commands) for the installation.{...}

Same steps and commands mentioned in wiki page as i said. Really i have to copy&paste commands from there? If yes then i will in next post.

widget 07-10-2011 04:03 PM

I have had trouble booting with netinstalls because I did not have all the "x" stuff that is needed. This is the base of all your video out put.

I think if you try installing the packages "xorg" and "xserver-common" and they comes back as current that x is probably not your problem.

gradinaruvasile 07-11-2011 05:36 AM

Quote:

Originally Posted by Arcane (Post 4410886)
Still nothing changes. I did Debian net-install base install. Then i installed Fluxbox and this time LXDE but i did same commands from base without DE or WM either and same result. If i need post some file content then let me know which one you need. Seems like another sign i should read about xorg and how it works since one more distro(PC-BSD) didn't work because of this file.
Same steps and commands mentioned in wiki page as i said. Really i have to copy&paste commands from there? If yes then i will in next post.

You installed a Debian base system.
Do you have the necessary build packages installed? (the linux headers, gcc, build-essential). Because you need those for the installation process (namely the compile of the nvidia module).

Also, please paste here the /var/log/Xorg.0.log files content.

Arcane 07-11-2011 01:15 PM

Quote:

Originally Posted by gradinaruvasile (Post 4411430)
{...}Do you have the necessary build packages installed? (the linux headers, gcc, build-essential).{...}

Yes. Already installed and latest version it says in terminal and it also says Virtual packages can't be removed aswell.
Quote:

Also, please paste here the /var/log/Xorg.0.log files content.
Here you go. I also can show xorg.0.old.log if interested.

the trooper 07-11-2011 01:41 PM

From the log file it shows you are using Nouveau,this needs to be disabled before trying to install the Nvidia driver as pointed out earlier.
If you are having problems I'd recommend using Smxi which will automate the process for you,including dealing with Nouveau.
Here's a link to their site:

http://smxi.org/

Arcane 07-11-2011 01:46 PM

Quote:

Originally Posted by the trooper (Post 4411856)
From the log file it shows you are using Nouveau,this needs to be disabled before trying to install the Nvidia driver as pointed out earlier.{...}

Don't worry i did disable and afterwards installed driver and yes i'm using other driver because otherwise i can't use Debian at all with GUI(I'm not that much noob as you may think from this issue). Anyway ill go check that website.

the trooper 07-11-2011 01:47 PM

So you have the driver installed now?.

Arcane 07-11-2011 02:00 PM

Quote:

Originally Posted by the trooper (Post 4411861)
So you have the driver installed now?.

I dunno if it is completed(maybe some command could check if all needed stuff are installed?) but i did go through all step-by-step guide mentioned in wiki. I'm using Nouveau driver because this works without that file like before. I just want to know what should i edit in that xorg config file or additionally install so that it will work.

the trooper 07-11-2011 02:16 PM

You can install as many packages as you like,but until you stop Nouveau loading you will not be able to install the Nvidia driver.
If it was me I would ctrl-alt-f1 to a tty,remove anything Nvidia related via apt-get/aptitude,then install smxi with:

Code:

# as root, run the following command
cd /usr/local/bin && wget -Nc smxi.org/smxi.zip && unzip smxi.zip && smxi

Just answer the questions when prompted, and continue to graphics driver install.

Simples.

Arcane 07-11-2011 03:21 PM

Ok. I did try that but no success.. I followed instruction - downloaded files, from tty executed it, then disabled nouveau with that file that creates in /etc/modprobe.d location, restarted PC, run again from shell that sgfxi and installed everything but still nothing. Here is files after that process: xorg.conf Xorg.0.log Xorg.0.old.log and Nouveau
Code:

# generated by nvidia-installer
blacklist nouveau
options nouveau modeset=0

disable file content. Hope something will be more clear now. I'm just wondering 2 things: Shall i reinstall Debian 6 with full DE this time from net install? Is that wiki page outdated for Squeeze?


All times are GMT -5. The time now is 06:57 AM.