LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 06-24-2007, 04:08 AM   #1
rangalo
Member
 
Registered: Jan 2005
Posts: 189

Rep: Reputation: 30
Nothing on display after suspend/resume


Hi,

I am using sidux (based on sid).

I changed my /boot/grub/menu.lst to configure suspend/resume like this ...

The UUID provided belongs to my swap partition which is almost 1GB.

Code:
# kopt=root=UUID=353cc61f-ede4-46c1-8d7f-b678de74678a ro quiet vga=791
resume=UUID=25184dd8-abc9-41c8-ae89-7c7ef875fed4  # in case the kernel is changed

......
......
title       Debian GNU/Linux, kernel 2.6.21.3-slh-up-4 Default
root        (hd0,4)
kernel      /boot/vmlinuz root=UUID=353cc61f-ede4-46c1-8d7f-b678de74678a ro quiet vga=791  resume=UUID=25184dd8-abc9-41c8-ae89-7c7ef875fed4 #for normal resume
initrd      /boot/initrd.img
After that, I can suspend my computer using powersave -u command, but while resuming, I get only a black screen, I see a lot of activity of my hard-disk and I can hear the fans running, so I think that resume is working, but there is something with the display.

Any, ideas ?

thanks & regards,
Hardik

Last edited by rangalo; 06-24-2007 at 08:23 AM.
 
Old 06-25-2007, 07:23 AM   #2
angryfirelord
Member
 
Registered: Dec 2005
Posts: 498

Rep: Reputation: 59
It's an ACPI issue that still is being fixed. I have the same problem, and not too many people can get suspend/hibernate working.

Here's some troubleshooting about it: http://fchabaud.free.fr/English/Tric...suspend-4.html
 
Old 06-26-2007, 04:19 AM   #3
rangalo
Member
 
Registered: Jan 2005
Posts: 189

Original Poster
Rep: Reputation: 30
Hi,

Thanks, angryfirelord.

I think that the first one given in you link is causing problem for me, but I cannot use the solution because I have an ATI card, not n-vidia.

So, is it not possible to have suspend/resume working on Dell -Inspiron ?

regards,
Hardik
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
F7 fails to resume from suspend spiffytech Fedora 4 06-07-2007 02:35 PM
Suspend Fails to Resume dengel Linux - Laptop and Netbook 0 11-27-2005 08:58 AM
No resume from suspend mehlkelm Debian 3 11-22-2005 10:48 AM
laptop suspend/resume zchoyt Fedora 0 10-24-2005 10:21 PM
Can't resume from ACPI S3 suspend cdhgee Fedora 3 08-18-2005 02:39 AM


All times are GMT -5. The time now is 03:26 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration