LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Debian (http://www.linuxquestions.org/questions/debian-26/)
-   -   not working: debian xen anmd64 + ati fglrx kernel module (http://www.linuxquestions.org/questions/debian-26/not-working-debian-xen-anmd64-ati-fglrx-kernel-module-667956/)

mad4linux 09-06-2008 09:19 AM

not working: debian xen amd64 + ati fglrx kernel module
 
I'm unable to run the ati kernel-module with the official debian xen kernel for amd64.

I'm using this kernel:
vmlinuz-2.6.18-6-xen-amd64

and trying to load this fglrx-module:
fglrx-kernel-2.6.18-6-xen-amd64 (8.28.8-4+2.6.18.dfsg.1-22etch2)

Code:

mesg | grep fglrx
gives this output:

Code:

fglrx: module license 'Proprietary. (C) 2002 - ATI Technologies, Starnberg, GERMANY' taints kernel.
fglrx: Unknown symbol flush_tlb_page
fglrx: Unknown symbol flush_tlb_page

Does anybody know anything helpful on how to fix this?

I also tried to apply the patch from debian bugs #368802. But it seems, that it is already done. Patch gives me the following output:

Code:

patching file firegl_public.c
Reversed (or previously applied) patch detected!  Assume -R? [n] n
Apply anyway? [n] n
Skipping patch.
patch: **** malformed patch at line 18:


mad4linux 12-01-2008 02:40 PM

Problem is solved. I've just upgraded to lenny. With the xen-kernel and ati-drivers from lenny, everything works!


All times are GMT -5. The time now is 10:33 PM.