Download your favorite Linux distribution at LQ ISO.
Go Back > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Debian This forum is for the discussion of Debian Linux.


  Search this Thread
Old 04-17-2005, 06:45 AM   #1
LQ Newbie
Registered: Apr 2004
Location: Australia
Distribution: Debian
Posts: 19

Rep: Reputation: 0
normal user Kppp permissions damn you sarge!

i know debian is really built for server implementation but i'm trying to take advice and not use root account for day to day operation where possible. I have setup a normal user account but cannot auth with ISP. kppp success with root only.
i know this is a common prob but i've not found a definitiv answer after many hours of trawling through documentation and usergroups.
here are the details of PPP log:

Apr 9 02:59:22 eugenio pppd[3131]: pppd 2.4.2 started by kev, uid 1000
Apr 9 02:59:22 eugenio pppd[3131]: Using interface ppp0
Apr 9 02:59:22 eugenio pppd[3131]: Connect: ppp0 <--> /dev/ttyS0
Apr 9 02:59:22 eugenio pppd[3131]: Warning - secret file /etc/ppp/pap-secrets has world and/or group access
Apr 9 02:59:22 eugenio pppd[3131]: Warning - secret file /etc/ppp/pap-secrets has world and/or group access
Apr 9 02:59:23 eugenio pppd[3131]: PAP authentication failed
Apr 9 02:59:23 eugenio pppd[3131]: Connection terminated.
Apr 9 02:59:23 eugenio pppd[3131]: Exit

normal user is member of dip and admin groups.
i defo have correct login details and I have no auth option set
getting close to changing back to slack - deb is just not happenning for me.
and now i seem to have screwed up su! cannot su root from normal user - get SETGID error. operation is not allowed.
any help for this problem much appreciated. tks baird.
Old 04-17-2005, 12:52 PM   #2
Registered: Jun 2004
Posts: 37

Rep: Reputation: 15

Open this file /etc/ppp/peers/kppp-options and delete "#" infront of noauth.

This file has only one line : #noauth

groups for a mine user : audio cdrom dialout dip floppy plugdev video

Proud of using Debian !!!!!!!!!!!!!!!!!!!
Old 04-18-2005, 10:16 PM   #3
LQ Newbie
Registered: Apr 2004
Location: Australia
Distribution: Debian
Posts: 19

Original Poster
Rep: Reputation: 0
no such file at location -

here is sample of my options file for PPP in /etc/ppp/

# /etc/ppp/options
# Originally created by Jim Knoble <>
# Modified for Debian by alvar Bray <>
# Modified for PPP Server setup by Christoph Lameter <>
# To quickly see what options are active in this file, use this command:
# egrep -v '#|^ *$' /etc/ppp/options

# Specify which DNS Servers the incoming Win95 or WinNT Connection should use
# Two Servers can be remotely configured
# ms-dns
# ms-dns

# Specify which WINS Servers the incoming connection Win95 or WinNT should use
# ms-wins
# ms-wins

# Run the executable or shell command specified after pppd has
# terminated the link. This script could, for example, issue commands
# to the modem to cause it to hang up if hardware modem control signals
# were not available.
#disconnect "chat -- \d+++\d\c OK ath0 OK"

# async character map -- 32-bit hex; each bit is a character
# that needs to be escaped for pppd to receive it. 0x00000001
# represents '\x01', and 0x80000000 represents '\x1f'.
asyncmap 0

# Require the peer to authenticate itself before allowing network
# packets to be sent or received.
# Please do not disable this setting. It is expected to be standard in
# future releases of pppd. Use the call option (see manpage) to disable
# authentication for specific peers.

thanks for your response


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
X hangs at startup, permissions for normal user messed up. elgatofilo Slackware 5 12-20-2004 08:48 PM
How to establish ppp with nolock option using RxTx with normal user permissions deepalalla Linux - Networking 0 12-06-2004 04:58 AM
Using kppp with a normal user... titogo Slackware 2 08-12-2004 09:33 PM
sometime kppp locked my keyboard on normal user demmylls Linux - General 2 12-26-2003 01:17 AM
How to use Kppp as a normal user mrogerf Debian 7 08-28-2003 08:06 PM

All times are GMT -5. The time now is 07:06 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration