LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Debian (http://www.linuxquestions.org/questions/debian-26/)
-   -   normal user Kppp permissions damn you sarge! (http://www.linuxquestions.org/questions/debian-26/normal-user-kppp-permissions-damn-you-sarge-314104/)

baird 04-17-2005 06:45 AM

normal user Kppp permissions damn you sarge!
 
i know debian is really built for server implementation but i'm trying to take advice and not use root account for day to day operation where possible. I have setup a normal user account but cannot auth with ISP. kppp success with root only.
i know this is a common prob but i've not found a definitiv answer after many hours of trawling through documentation and usergroups.
here are the details of PPP log:

Apr 9 02:59:22 eugenio pppd[3131]: pppd 2.4.2 started by kev, uid 1000
Apr 9 02:59:22 eugenio pppd[3131]: Using interface ppp0
Apr 9 02:59:22 eugenio pppd[3131]: Connect: ppp0 <--> /dev/ttyS0
Apr 9 02:59:22 eugenio pppd[3131]: Warning - secret file /etc/ppp/pap-secrets has world and/or group access
Apr 9 02:59:22 eugenio pppd[3131]: Warning - secret file /etc/ppp/pap-secrets has world and/or group access
Apr 9 02:59:23 eugenio pppd[3131]: PAP authentication failed
Apr 9 02:59:23 eugenio pppd[3131]: Connection terminated.
Apr 9 02:59:23 eugenio pppd[3131]: Exit


normal user is member of dip and admin groups.
i defo have correct login details and I have no auth option set
getting close to changing back to slack - deb is just not happenning for me.
and now i seem to have screwed up su! cannot su root from normal user - get SETGID error. operation is not allowed.
any help for this problem much appreciated. tks baird.

tompravi 04-17-2005 12:52 PM

/etc/ppp/peers/kppp-options
 
Open this file /etc/ppp/peers/kppp-options and delete "#" infront of noauth.

This file has only one line : #noauth


groups for a mine user : audio cdrom dialout dip floppy plugdev video

Proud of using Debian !!!!!!!!!!!!!!!!!!!

baird 04-18-2005 10:16 PM

no such file at location -

here is sample of my options file for PPP in /etc/ppp/

# /etc/ppp/options
#
# Originally created by Jim Knoble <jmknoble@mercury.interpath.net>
# Modified for Debian by alvar Bray <alvar@meiko.co.uk>
# Modified for PPP Server setup by Christoph Lameter <clameter@debian.org>
#
# To quickly see what options are active in this file, use this command:
# egrep -v '#|^ *$' /etc/ppp/options

# Specify which DNS Servers the incoming Win95 or WinNT Connection should use
# Two Servers can be remotely configured
# ms-dns 192.168.1.1
# ms-dns 192.168.1.2

# Specify which WINS Servers the incoming connection Win95 or WinNT should use
# ms-wins 192.168.1.50
# ms-wins 192.168.1.51

# Run the executable or shell command specified after pppd has
# terminated the link. This script could, for example, issue commands
# to the modem to cause it to hang up if hardware modem control signals
# were not available.
#disconnect "chat -- \d+++\d\c OK ath0 OK"

# async character map -- 32-bit hex; each bit is a character
# that needs to be escaped for pppd to receive it. 0x00000001
# represents '\x01', and 0x80000000 represents '\x1f'.
asyncmap 0

# Require the peer to authenticate itself before allowing network
# packets to be sent or received.
# Please do not disable this setting. It is expected to be standard in
# future releases of pppd. Use the call option (see manpage) to disable
# authentication for specific peers.
noauth

thanks for your response


All times are GMT -5. The time now is 10:12 PM.