LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 08-12-2007, 03:07 PM   #1
blueobsession
LQ Newbie
 
Registered: Aug 2006
Location: USA
Distribution: SymphonyOS, Kanotix, Sidux
Posts: 27

Rep: Reputation: 15
No video for nVidia Geforce FX 5500 after Etch install


Hey everyone. I've searched these forums and google'd, and I still can't find a solution. I installed Debian Etch XFCE version earlier today and all went well until the system tried to go into X (gdm). All I get is a blank screen. I also hear a single beep after about 10 seconds or so.

Pressing ctrl-Alt-F1 drops me to command line and I can log in and access my system from there. So I know it has to be some weird problem with X. I can see no errors with X once I drop to command line.

My system has worked with other Debian-based distros such as Kanotix/Sidux and Dreamlinux... I do remember having a similar problem with Kubuntu though. I'm sure that my motherboard and graphics card are supported by Linux because I've been distro hopping before I decided to go to pure Debian, and almost all of them installed. I'm not sure why Debian doesn't want to load the xserver. Does anybody have any suggestions that might fix my problem? I really want to make the switch to Debian 4.0. Thanks in advance for your help and time.

Last edited by blueobsession; 08-12-2007 at 03:08 PM.
 
Old 08-12-2007, 03:20 PM   #2
war1025
Member
 
Registered: Jul 2006
Distribution: Debian: Squeeze AMD64
Posts: 318

Rep: Reputation: 31
editing your /etc/X11/xorg.conf file would probably be a good start, post the contents to it for more help...
 
Old 08-12-2007, 05:20 PM   #3
blueobsession
LQ Newbie
 
Registered: Aug 2006
Location: USA
Distribution: SymphonyOS, Kanotix, Sidux
Posts: 27

Original Poster
Rep: Reputation: 15
Here's my xorg.conf file (starting with the "Module" section... the other part is about the fonts):

Code:
Section "Module"
          Load "i2c"
          Load "bitmap"
          Load "ddc"
          Load "dri"
          Load "extmod"
          Load "freetype"
          Load "glx"
          Load "int10"
          Load "vbe"
       End Section

Section "InputDevice"
          Identifier "Generic Keyboard"
          Driver "kbd"
          Option "CoreKeyboard"
          Option "XKbRules" "xorg"
          Option "XKbModel" "PC104"
          Option "XKbLayout" "us"
       End Section

Section "InputDevice"
          Identifier "Configured Mouse"
          Driver "mouse"
          Option "CorePointer"
          Option "Device" "/dev/input/mice"
          Option "Protocol" "ImPS/2"
          Option "Emulate3Buttons" "true"
       End Section

Section "Device"
          Identifier "nVidia Corporation NV34 [GeForce FX 5500]"
          Driver "nv"
          BusID "PCI:1:0:0
       End Section

Section "Monitor"
          Identifier "eView 17f3"
          Option "DPMS"

Section "Screen"
          Identifier "Default Screen"
          Device "nVidia Corporation NV34 [GeForce FX 5500]"
          Monitor "eView17f3"
          DefaultDepth 24
          Subsection "Display"
             Depth 1
             Modes "1024x768" "800x600" "720x400" "640x480"
            EndSection
          Subsection "Display"
             Depth 4
             Modes "1024x768" "800x600" "720x400" "640x480"
            EndSection
          Subsection "Display"
             Depth 8
             Modes "1024x768" "800x600" "720x400" "640x480"
            EndSection
          Subsection "Display"
             Depth 15
             Modes "1024x768" "800x600" "720x400" "640x480"
            EndSection
          Subsection "Display"
             Depth 16
             Modes "1024x768" "800x600" "720x400" "640x480"
            EndSection
          Subsection "Display"
             Depth 24
             Modes "1024x768" "800x600" "720x400" "640x480"
            EndSection

Section "ServerLayout"
          Identifier "Default Layout"
          Screen "Default Screen"
          InputDevice "Generic Keyboard"
          InputDevice "Configured Mouse"
        End Section

Section "DRI"
          Mode 0666
        End Section
Any ideas guys? Thanks again for your help.
 
Old 08-12-2007, 05:20 PM   #4
craigevil
Senior Member
 
Registered: Apr 2005
Location: OZ
Distribution: Debian Sid
Posts: 4,733
Blog Entries: 12

Rep: Reputation: 456Reputation: 456Reputation: 456Reputation: 456Reputation: 456
doing dpkg-reconfigure xserver-xorg would probably be a good place to start. Along with installing the nVidia driver properly.

NvidiaGraphicsDrivers - Debian Wiki
http://wiki.debian.org/NvidiaGraphicsDrivers

The 5500 fx card works just fine in Debian once you install the drivers properly.

$ infobash -v3
Host/Kernel/OS "craigevil" running Linux 2.6.22.2-slh-smp-1 i686 [ sidux-20070111-d:5 ]
CPU Info AMD Duron 64 KB cache flags( sse ) clocked at [ 1800.096 MHz ]
Videocard nVidia NV34 [GeForce FX 5500] X.Org 1.3.0 [ 1280x1024 @50hz ]
Network cards Silicon Integrated Systems [SiS] SiS900 PCI Fast Ethernet, at port: e400
Processes 92 | Uptime 4:06 | Memory 239.7/2027.4MB | HDD ATA WDC WD800JB-00JJ Size 80GB (42%used) | GLX Renderer GeForce FX 5500/AGP/SSE/3DNOW! | GLX Version 2.1.1 NVIDIA 100.14.11 | Client Shell | Infobash v2.67
 
Old 08-12-2007, 05:47 PM   #5
war1025
Member
 
Registered: Jul 2006
Distribution: Debian: Squeeze AMD64
Posts: 318

Rep: Reputation: 31
Section "Monitor"
Identifier "eView 17f3"
Option "DPMS"

Section "Screen"
Identifier "Default Screen"
Device "nVidia Corporation NV34 [GeForce FX 5500]"
Monitor "eView17f3"
DefaultDepth 24


That might be a problem. Make sure both of the monitors have the same title.
 
Old 08-12-2007, 05:53 PM   #6
blueobsession
LQ Newbie
 
Registered: Aug 2006
Location: USA
Distribution: SymphonyOS, Kanotix, Sidux
Posts: 27

Original Poster
Rep: Reputation: 15
Thanks everyone... I'm trying to install the closed source nVidia drivers now (the Debian way).

@ War:

I only have one monitor. Is it calling for two? Sorry if I misunderstood, I'm pretty sure that's what you were saying.
 
Old 08-12-2007, 07:02 PM   #7
blueobsession
LQ Newbie
 
Registered: Aug 2006
Location: USA
Distribution: SymphonyOS, Kanotix, Sidux
Posts: 27

Original Poster
Rep: Reputation: 15
O.K., I got the nVidia driver installed without errors, but I still can't get into X. I ran the command 'startx' from command line and nothing came up. When I did ctrl-alt-F1... I got a couple of errors.

The first one (which may not be a big deal) was the first line on the screen and said,

Code:
X: warning; process set to priotrity -1 instead of requested priority 0.
The next one said,

Code:
(WW) NVIDIA: No matching Device section for instance (BusID PCI:2:6:0) found
What should I do now?
 
Old 08-12-2007, 07:42 PM   #8
JackieBrown
Member
 
Registered: Dec 2004
Location: San Antonio, TX
Distribution: Debian-AMD64 Sid
Posts: 481

Rep: Reputation: 31
Not to offend, but of the people I know, the most common missed step is apt-get install nvdia-glx

Assuming you did that, did you modprode it?

Did you run dpkg-reconfigure xserver-xorg? That would fix the error that War mentioned and any other in your xorg.

Lastly, do you also have an onboard video card?

edit

You can also try commenting out the bus id

Last edited by JackieBrown; 08-12-2007 at 07:48 PM.
 
Old 08-12-2007, 09:41 PM   #9
noxious
Member
 
Registered: May 2004
Location: Ohio, USA
Distribution: LinuxMint Gloria, Ubuntu 9.10
Posts: 299

Rep: Reputation: 30
I use Ubuntu on this desktop, but I use Debian Etch on my laptop. This desktop uses the FX5500 card - here's my xorg.conf:

# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf(5) manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
FontPath "/usr/share/fonts/X11/misc"
FontPath "/usr/share/fonts/X11/cyrillic"
FontPath "/usr/share/fonts/X11/100dpi/:unscaled"
FontPath "/usr/share/fonts/X11/75dpi/:unscaled"
FontPath "/usr/share/fonts/X11/Type1"
FontPath "/usr/share/fonts/X11/100dpi"
FontPath "/usr/share/fonts/X11/75dpi"
# path to defoma fonts
FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
Load "bitmap"
Load "ddc"
Load "dri"
Load "extmod"
Load "freetype"
Load "glx"
Load "int10"
Load "vbe"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "true"
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "stylus"
Option "Device" "/dev/input/wacom"
Option "Type" "stylus"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "eraser"
Option "Device" "/dev/input/wacom"
Option "Type" "eraser"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "cursor"
Option "Device" "/dev/input/wacom"
Option "Type" "cursor"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "Device"
Identifier "Nvidia FX-5500"
Driver "nvidia"
BusID "PCI:1:0:0"
EndSection

Section "Monitor"
Identifier "Generic Monitor"
Option "DPMS"
HorizSync 30-65
VertRefresh 50-75
EndSection

Section "Screen"
Identifier "Default Screen"
Device "Nvidia FX-5500"
Monitor "Generic Monitor"
DefaultDepth 16
SubSection "Display"
Depth 1
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 4
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 8
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 15
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 16
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
SubSection "Display"
Depth 24
Modes "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"
InputDevice "stylus" "SendCoreEvents"
InputDevice "cursor" "SendCoreEvents"
InputDevice "eraser" "SendCoreEvents"
EndSection

Section "DRI"
Mode 0666
EndSection


Notice the driver says "nvidia" instead of "nv"
 
Old 08-12-2007, 09:54 PM   #10
JackieBrown
Member
 
Registered: Dec 2004
Location: San Antonio, TX
Distribution: Debian-AMD64 Sid
Posts: 481

Rep: Reputation: 31
On your desktop change your BusID to PCI:2:6:0

The nv will be fixed after running dpkg-reconfigure xserver-xorg and choosing nvidia instead of nv (or type over nv with nvidia)

Last edited by JackieBrown; 08-12-2007 at 09:56 PM.
 
Old 08-12-2007, 10:00 PM   #11
blueobsession
LQ Newbie
 
Registered: Aug 2006
Location: USA
Distribution: SymphonyOS, Kanotix, Sidux
Posts: 27

Original Poster
Rep: Reputation: 15
Hey there. I finally got it working! After tweaking the xorg.conf (thanks noxious) file a little more, I ended up commenting out the BusID line like Jackie suggested and it worked finally. I appreciate everyone's help!

Now I just have to go write down what I did so I don't forget.

Thanks again.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Debian etch doesn't recognize GeForce FX 5500 ninjabob7 Linux - Hardware 1 04-08-2007 10:53 PM
Nvidia/E-VGA e-geforce 5500 PCI installtion issues anubis26 Linux - Hardware 0 03-29-2007 09:46 PM
NVIDIA geforce 5500- direct rendering slow cjae Linux - Hardware 2 09-04-2006 04:02 PM
No Picture, onboard video and geforce fx 5500 vid card on system, using geforce?? dragoncorp.org Linux - Newbie 1 04-17-2006 01:56 PM
Nvidia Geforce 5500 set up as VESA in Suse 9.1 puke Linux - Hardware 1 12-26-2004 07:02 PM


All times are GMT -5. The time now is 11:41 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration