LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 08-26-2004, 07:12 PM   #1
t2701
LQ Newbie
 
Registered: Jul 2004
Posts: 18

Rep: Reputation: 0
No spell check in Openoffice


I'm running Debian Sid. I just installed Openoffice but the spell check doesn't work. I have installed myspell-en-us (or whatever the package name is) but it still doesn't work. I installed a few other packages, but it still doesn't work. When I go to Language Aids under the Options, the list is blank.

Just curious if I'm the only one who is having this problem.
 
Old 08-26-2004, 11:57 PM   #2
halo14
Senior Member
 
Registered: Apr 2004
Location: Surprise, AZ
Distribution: Debian | CentOS | Arch
Posts: 1,103

Rep: Reputation: 45
i'm running Sarge so i don't know if it's the same issue.. but try pressing F7 to autorun spellcheck... it works for me... and i just finished writting a 12 page final essay for my Win2000Server MCSA class.... (how do you spell irony?? lol)
 
Old 08-27-2004, 02:54 PM   #3
t2701
LQ Newbie
 
Registered: Jul 2004
Posts: 18

Original Poster
Rep: Reputation: 0
Yeah, I know how to spellcheck my documents...it just doesn't work. There's no error message either. It says "Spellcheck complete" and I know it's lying because I have obvious misspelled words in the document.
 
Old 08-28-2004, 05:51 PM   #4
duress
LQ Newbie
 
Registered: Aug 2004
Posts: 1

Rep: Reputation: 0
Open /usr/share/myspell/dicts/DicOOo.sxw with Writer and follow the instructions in the document to enable your spell checker.
 
Old 08-28-2004, 06:17 PM   #5
macondo
Senior Member
 
Registered: Jul 2003
Location: Panama
Distribution: Debian Sid
Posts: 1,014

Rep: Reputation: 49
Thanks!, i didn't know that either.
 
Old 08-29-2004, 01:17 PM   #6
t2701
LQ Newbie
 
Registered: Jul 2004
Posts: 18

Original Poster
Rep: Reputation: 0
Thanks!

But why the heck did they make it so difficult? In all other distros I've used (and I've used plenty) OOo spellcheck works fine by default as it should and there is no excuse for this.

T
 
Old 08-30-2004, 09:29 AM   #7
halo14
Senior Member
 
Registered: Apr 2004
Location: Surprise, AZ
Distribution: Debian | CentOS | Arch
Posts: 1,103

Rep: Reputation: 45
It should have worked fine by default... Maybe there was just a misplaced setting on installation?? I installed OOo with Sarge and my spellcheck works fine...
 
Old 08-30-2004, 11:56 AM   #8
R00ts
Member
 
Registered: Mar 2004
Location: Austin TX, USA
Distribution: Ubuntu 11.10, Fedora 16
Posts: 545

Rep: Reputation: 30
I just checked and my spellcheck also works fine (haven't touched OO since my initial install of sarge).
 
Old 08-30-2004, 11:21 PM   #9
shodekiagari
Member
 
Registered: Nov 2003
Posts: 47

Rep: Reputation: 15
I had this problem.

I had this problem and spent about two hours trying to figure out how to get the dictionaries to work (I'm slow okay?!)

I was browsing through the openoffice forums and I found a link to this dictionary auto-installer. It's pretty nifty and it can download everylanguage pack. Even I managed to get it working w/o that many problems (okay, okay I did end up putting it in spanish on accident )

http://lingucomponent.openoffice.org/dictpack.html

The very top link, links to the dictionary installer.

Harrison
 
Old 02-14-2007, 02:32 PM   #10
bandwidthjunkie
LQ Newbie
 
Registered: Jan 2007
Location: london
Distribution: Gentoo(amd64) - 2.16.20
Posts: 26

Rep: Reputation: 15
UPDATED INFO:

I had the same problem with gentoo - I emerged the binary with a linguas option selected, but there was no spell check.

Go to http://wiki.services.openoffice.org/wiki/Dictionaries (the link shodekiagari gives is out dated, but points to this page).

There is a link on this page to the wizard file DicOOo (http://ftp.services.openoffice.org/p...ooo/DicOOo.sxw)
get this file. You don't need to put it in any special directory, just open it in writer and follow the instructions, then restart OO.
 
1 members found this post helpful.
Old 02-22-2007, 05:58 PM   #11
danthehat
LQ Newbie
 
Registered: Oct 2004
Location: Ontario, Canada
Distribution: Gentoo, all the way
Posts: 11

Rep: Reputation: 0
On gentoo,
Code:
emerge app-dicts/myspell-en
LINGUAS="en" emerge openoffice-bin
 
Old 05-17-2011, 04:26 AM   #12
amorphous
LQ Newbie
 
Registered: Jun 2008
Distribution: etch & ubuntu
Posts: 2

Rep: Reputation: 0
squeeze & oo3

sudo apt-get install myspell-en-gb openoffice.org-l10n-en-gb

not sure if the l10n one is necessary & I had to REBOOT to get it to take effect
 
Old 07-02-2011, 12:14 PM   #13
westburian
LQ Newbie
 
Registered: Jul 2011
Posts: 11

Rep: Reputation: Disabled
Easy SOLUTION for Open Office spell check not working

I was kind of stumped when spell check did not work on my slackware 13.1 machine (KDE 4.4.x) so I jumped onto my slackware 12.2 machine (KDE 3.5.10) and oo spell check did not work there either!! Yet I could use aspell -c [filename] at the command line to check .txt files, and Kword, Kate spell check, worked fine, so why not open office?

After researching (okay googling) and thinking I was about to go through several hours of pulling my hair out trying to fix this, I stumbled upon a post that said all that was needed was to get the dictionary 'extension' for your language. They can be found here:

http://extensions.services.openoffic...n/dictionaries

If you can't get directly to that page, you may have to start from openoffice.org and go to the downloads and navigate your way there. In my case, the file I needed was something like en_US.oxt and I simply downloaded that, about 256K, then opened up open office, went to tools, then the extension manager, then 'add extension', navigated to the dir where I had the en_us.oxt downloaded, clicked on that, and voila, all done !!! Same process I'm sure to add other dictionaries.

This process is for versions of Open Office 3.0 and greater, a different procedure is used for older versions. This worked in less than 5 minutes for both my slackware 12.2 and 13.1 boxes, no problem.

I hope this help someone who may have the similar problem. What is was doing, since there was no dictionary installed, for whatever reason, it would give the message 'spell check complete', and when you would click OK the whole thing would close.

A bit of FYI, my Open Office is version 3.0 and I downloaded the .tgz package from linux packages.org and up until this incident, I've never had any issues with oo 3.0 as I use it extensively for mostly .xls spreadsheets and occasionally to view .pps file that people send me.

As it happened, I was using my SW 13.1 machine to help a friend with a resume, I usually use Kword on my sw 12.2 box with KDE 3.5.10 but I simply do not like all the widgety little floating and docking boxes that Kword in sw 13.1 / KDE 4.4 has, so, I did her resume in OO 3.0 and discovered the spell check problem.

This was a quick and easy fix and I would think be applicable to any distro. My guess is that the install script simply did not put the dictionary in the right place, or at all.

It's interesting to note the different types of spellcheckers in use, aspell, ispell, and I think 'enchant' is one of the newer ones.
 
Old 07-03-2011, 04:30 AM   #14
Valdis Grinbergs
Member
 
Registered: Dec 2005
Distribution: Debian
Posts: 30

Rep: Reputation: 25
Debian has made LibreOffice available in unstable, testing, and recently stable too, through backporting. See http://www.debian.org/News/2011/20110623.en.html

I run stable and replaced OpenOffice with LibreOffice using the instructions in the link above. Spell checking works fine.
 
Old 07-03-2011, 08:08 AM   #15
hitest
Senior Member
 
Registered: Mar 2004
Location: Prince Rupert, B.C., Canada
Distribution: Slackware, OpenBSD
Posts: 4,141

Rep: Reputation: 523Reputation: 523Reputation: 523Reputation: 523Reputation: 523Reputation: 523
Quote:
Originally Posted by Valdis Grinbergs View Post
Debian has made LibreOffice available in unstable, testing, and recently stable too, through backporting. See http://www.debian.org/News/2011/20110623.en.html

I run stable and replaced OpenOffice with LibreOffice using the instructions in the link above. Spell checking works fine.
I've also replaced OOo with Libreoffice and it works very well on Debian 6.0. I downloaded the source directly from the Libreoffice website and extracted the .deb source code then installed the the package as per the instruction on the readme.

Code:
tar -xvf nameoftarball
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
OpenOffice 1.1.0 Spell Check rsmereka Linux - Software 0 12-30-2004 05:49 PM
Javascript spell check slightcrazed Programming 3 10-02-2003 04:08 PM
spell check under opera??? bigjohn LQ Suggestions & Feedback 2 02-02-2003 12:51 AM
OpenOffice spell checker problems JHuizingh Linux - General 6 04-16-2002 10:25 PM
vi spell-check? jeri Linux - General 2 09-01-2001 03:41 PM


All times are GMT -5. The time now is 06:24 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration