LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices

Reply
 
Search this Thread
Old 10-19-2008, 05:57 PM   #1
McDale
LQ Newbie
 
Registered: Oct 2008
Posts: 5

Rep: Reputation: 0
No Sound Debian Lenny AMD64 Gigabyte GA-MA78GM-S2H AMD 780G


Hey there,

I just performed a fresh install of Debian, Lenny. Its on an AMD64. I have been unable to get sound working at all. (trying to use the optical ouput of Gigabyte GA-MA78GM-S2H AMD 780G motherboard)

After doing a fresh install, updating, upgrading etc... I am using a CD to test sound with the default player (Sound Jucer). Nothing. Opened the volume control (Applications -> Sound & Video -> Volume Control) Unmuted any playback items, and turned up all volumes. Under "Switches" checked the checkboxes for "IEC958" and "IE958 Default PCM". Still nothing.

So, I opened up a root terminal, and ran alsaconf.
In there, selected the first item (hda-intel ATI Technologies Inc SBx00 Azalia) The only other option was probe legacy...
Chose yes to edit modprobe.d
(noticed one strange thing: after this there is a line saying:
amixer: Mixer attach default error: No such file or directory
)

It says "Now ALSA is ready to use" tho. Closed root terminal and opened regular terminal. Ran alsamixer. Made sure the IEC958 ones are all unmuted... everything looks OK.

No sound still! Rebooted, no sound still. :P

If anyone can help me out I would surely appreciate it. I'm a bit of a linux noob, but I did get a previous AMD system up and running with Debian / MythTV before, so I do have a little experience.

Thanks,
McD

Last edited by McDale; 10-19-2008 at 06:01 PM.
 
Old 10-19-2008, 06:02 PM   #2
sparker
Member
 
Registered: Aug 2007
Location: Canada
Distribution: OpenBSD 4.6, Debian Lenny
Posts: 64

Rep: Reputation: 16
I had similar issues but I was able to fix it with
Code:
apt-get install libesd-alsa0
 
Old 10-19-2008, 06:09 PM   #3
McDale
LQ Newbie
 
Registered: Oct 2008
Posts: 5

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by sparker View Post
I had similar issues but I was able to fix it with
Code:
apt-get install libesd-alsa0
OK, I installed the package, rebooted, ran alsaconf again. No "amixer" errors this time. ran alsamixer, everything still looks OK. Tried the CD again and still nada.
 
Old 10-19-2008, 06:15 PM   #4
McDale
LQ Newbie
 
Registered: Oct 2008
Posts: 5

Original Poster
Rep: Reputation: 0
I also went into System --> Preferences --> Sound.

all the playback ones are all set to "Autodetect".

So, I tried changing all the playback ones to "AL882 Digital", tried it, nothing. Went back in again and changed them to "ALSA - Advanced Linux Sound Architecture". Tried it again nothing.

Is there maybe some library or switch somewhere I'm missing?
 
Old 10-19-2008, 07:47 PM   #5
McDale
LQ Newbie
 
Registered: Oct 2008
Posts: 5

Original Poster
Rep: Reputation: 0
Hmm, Its now working...

Under Sound Preferences, I had to change everything to use "ALC882 Digital" for playback. Changed the Default mixer device to "Realtek ALC882 (OSS Mixer)". Started the CD Player again and now its working! Maybe I didn't close and re-open the player when I switched it to this device last time? Oh well, its working anyways. I hope this thread helps someone else.

Summary:
-Installed the package: libesd-alsa0
-Changed everything in sound preferences to "ALC882 Digital"
-Default Mixer device to Realtek ALC882

Next step, MythTV. Does anyone know if Myth with work with OSS instead of ALSA?
 
Old 10-19-2008, 09:34 PM   #6
sparker
Member
 
Registered: Aug 2007
Location: Canada
Distribution: OpenBSD 4.6, Debian Lenny
Posts: 64

Rep: Reputation: 16
You can always use the alsa oss wrapper.
Code:
apt-get install alsa-oss
 
Old 10-21-2008, 11:48 PM   #7
McDale
LQ Newbie
 
Registered: Oct 2008
Posts: 5

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by sparker View Post
You can always use the alsa oss wrapper.
Code:
apt-get install alsa-oss
Well it worked, I have sound. That package was already installed. Thanks.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Debian Lenny AMD64 Intel IWL4965 WiFi WolfCub Linux - Wireless Networking 9 02-25-2009 07:03 AM
K3b 1.0.5 Lame parameter Debian Lenny amd64 the trooper Linux - Newbie 3 10-06-2008 08:30 AM
Xinerama, AMD 780G, Slack 12.1 Geist3 Slackware 3 08-15-2008 04:27 PM
Debian Lenny AMD64 netinstall not detecting ethernet correctly the trooper Debian 6 07-28-2008 01:13 PM
Running Opera in Debian Lenny on AMD-64 jlinkels Linux - Software 1 05-07-2008 06:00 AM


All times are GMT -5. The time now is 03:15 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration