LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices



Reply
 
Search this Thread
Old 04-21-2004, 04:55 PM   #1
drumaholik
LQ Newbie
 
Registered: Sep 2003
Posts: 18

Rep: Reputation: 0
no internet after dist-upgrade


Im running sarge and everything worked fine until i did a dist-upgrade. It looked like it was mainly upgrading libs but after i restarted it couldnt connect to the internet.

some info:
netconfig gives me a "command not found"

~# ifconfig
lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:52 errors:0 dropped:0 overruns:0 frame:0
TX packets:52 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:3428 (3.3 KiB) TX bytes:3428 (3.3 KiB)

~# lspci
pcilib: Cannot open /sys/bus/pci/devices
0000:00:00.0 Host bridge: VIA Technologies, Inc. VT8366/A/7 [Apollo KT266/A/333]
0000:00:01.0 PCI bridge: VIA Technologies, Inc. VT8366/A/7 [Apollo KT266/A/333 AGP]
0000:00:08.0 Multimedia audio controller: Ensoniq 5880 AudioPCI (rev 04)
0000:00:11.0 ISA bridge: VIA Technologies, Inc. VT8233A ISA Bridge
0000:00:11.1 IDE interface: VIA

Technologies, Inc. VT82C586A/B/VT82C686/A/B/VT823x/A/C/VT8235 PIPC Bus Master IDE (rev 06)
0000:00:13.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)
0000:00:14.0 USB Controller: VIA Technologies, Inc. VT6202 [USB 2.0 controller] (rev 50)
0000:00:14.1 USB Controller: VIA Technologies, Inc. VT6202 [USB 2.0 controller] (rev 50)
0000:00:14.2 USB Controller: VIA Technologies, Inc. USB 2.0 (rev 51)
0000:01:00.0 VGA compatible controller: ATI Technologies Inc Radeon RV200 QW [Radeon 7500]

/etc/network/interfaces
auto lo
iface lo inet loopback
# This entry was created during the Debian installation
auto eth0
iface eth0 inet dhcp
 
Old 04-21-2004, 05:36 PM   #2
Muzzy
Member
 
Registered: Mar 2004
Location: Denmark
Distribution: Gentoo, Slackware
Posts: 333

Rep: Reputation: 30
Some suggestions:

If you do 'ifconfig -a' does your card show up (lists all cards even if they are not configured)?
Can you post the output to /sbin/lsmod ?
Did you upgrade to kernel 2.6.x? (uname -a)
Have you tried running /sbin/dhcpcd manually as root?

Mark.
 
Old 04-21-2004, 06:02 PM   #3
drumaholik
LQ Newbie
 
Registered: Sep 2003
Posts: 18

Original Poster
Rep: Reputation: 0
ifconig -a gives me the same output as before. and i dont see my network device listed in there.

my network device is listed in lspci:
0000:00:13.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)

~# lsmod
Module Size Used by Not tainted
input 3040 0 (autoclean)
radeon 89376 0
pcmcia_core 38784 0
af_packet 11624 0 (autoclean)
ehci-hcd 14988 0 (unused)
usb-uhci 19696 0 (unused)
usbcore 53068 1 [ehci-hcd usb-uhci]
es1371 24044 0
ac97_codec 11444 0 [es1371]
soundcore 3268 4 [es1371]
gameport 1388 0 [es1371]
ide-scsi 8464 0
scsi_mod 85408 1 [ide-scsi]
parport_pc 19400 1 (autoclean)
lp 5952 1 (autoclean)
parport 21800 1 (autoclean) [parport_pc lp]
nls_cp437 4284 4 (autoclean)
ide-cd 27968 0
cdrom 25088 0 [ide-cd]
rtc 6344 0 (autoclean)
reiserfs 155600 1 (autoclean)
vfat 8940 2 (autoclean)
fat 28088 0 (autoclean) [vfat]
isofs 23092 0 (autoclean)
ext3 66696 0 (autoclean)
jbd 35076 0 (autoclean) [ext3]
ide-detect 288 0 (autoclean) (unused)
via82cxxx 9448 1 (autoclean)
ide-disk 12512 4 (autoclean)
ide-core 94300 4 (autoclean) [ide-scsi ide-cd ide-detect via82cxxx ide-disk]
unix 13260 118 (autoclean)

~# uname -a
Linux debian 2.4.25-1-386 #1 Tue Feb 24 08:11:13 EST 2004 i686 GNU/Linux
which is the original kernel i installed

and if i type dhcpcd in a terminal is says command not found
 
Old 04-21-2004, 06:32 PM   #4
Muzzy
Member
 
Registered: Mar 2004
Location: Denmark
Distribution: Gentoo, Slackware
Posts: 333

Rep: Reputation: 30
Try modprobing the module for your network card:

modprobe 8139too

then if this works try ifconfig -a again and see if your card has appeared.

then /sbin/dhcpcd as root. You said that dhcpcd didn't work before? Did you run it as root? Is sbin in your path?

I'm going to bed now, I hope this works for you, if not then posts any errors you get and I'll check back tomorrow evening. You can also try searching LQ for other ppl with similar problems (this sort of question gets posted a lot so you should be able to find something).

Good luck,
Mark.
 
Old 05-03-2004, 06:49 PM   #5
gsharpe
LQ Newbie
 
Registered: May 2004
Posts: 4

Rep: Reputation: 0
Question

I''m having the same problem. Were you finally able to connect to the internet? How?
 
Old 05-04-2004, 12:42 PM   #6
drumaholik
LQ Newbie
 
Registered: Sep 2003
Posts: 18

Original Poster
Rep: Reputation: 0
yeah i fixed it by adding

alias eth0 8139too

to my modules.conf so it would load at startup

Last edited by drumaholik; 05-04-2004 at 12:44 PM.
 
Old 05-04-2004, 01:38 PM   #7
Dead Parrot
Senior Member
 
Registered: Mar 2004
Distribution: Debian GNU/kFreeBSD
Posts: 1,597

Rep: Reputation: 46
I don't think you should edit /etc/modules.conf with text editor, because Debian maintains this file automatically and your settings will be overwritten. The proper way is to add module aliases into /etc/modutils/aliases and then run "update-modules", which will update /etc/modules.conf.

For 2.6.x kernels the equivalent files are /lib/modules/modprobe.conf and /etc/modprobe.d/aliases but the procedure is similar.
 
Old 05-04-2004, 03:00 PM   #8
gsharpe
LQ Newbie
 
Registered: May 2004
Posts: 4

Rep: Reputation: 0
how would I add an Intell 82557/8/9 into /etc/modutils/aliases? Then how do I run "update-modules"?
 
Old 05-04-2004, 03:38 PM   #9
Dead Parrot
Senior Member
 
Registered: Mar 2004
Distribution: Debian GNU/kFreeBSD
Posts: 1,597

Rep: Reputation: 46
Quote:
how would I add an Intell 82557/8/9 into /etc/modutils/aliases? Then how do I run "update-modules"?
In Linux you can edit most files with text editor. To edit /etc/modutils/aliases with text editor called "nano", first get root privileges by writing "su" command in command line. Then write "nano /etc/modutils/aliases". Now you can write desired changes and save them when you exit nano. The line you need to add is:

alias eth0 eepro100

Similarly, you can run the command "update-modules" by writing it in command line (in console or terminal). Also running this command requires root privileges, so use "su" command first and write the root user's password when asked.

You can also use any GUI text editor (like Kedit in KDE or Gedit in Gnome) but, because you need root user's privileges to edit most system files, I recommend that you use nano from command line. There's also a very cool text editor in Midnight Commander.

Hope this helps.

Last edited by Dead Parrot; 05-04-2004 at 03:42 PM.
 
Old 05-04-2004, 03:56 PM   #10
edwardOG
LQ Newbie
 
Registered: May 2004
Posts: 12

Rep: Reputation: 0
I had a similar problem.

I believe that Debian likes to use modconf to do this kind of stuff.

Try using modconf and load the module like that. Then restart your networking stuff by:
/etc/init.d/networking restart

This worked for me.

Confirm that the module you want is being listed by lsmod.
 
Old 05-04-2004, 04:15 PM   #11
Dead Parrot
Senior Member
 
Registered: Mar 2004
Distribution: Debian GNU/kFreeBSD
Posts: 1,597

Rep: Reputation: 46
Quote:
I believe that Debian likes to use modconf to do this kind of stuff.
Try using modconf and load the module like that. Then restart your networking stuff by:
/etc/init.d/networking restart
I agree. modconf is a great easy-to-use utility. If modconf fails, you can try the update-modules method.
 
Old 05-04-2004, 04:54 PM   #12
gsharpe
LQ Newbie
 
Registered: May 2004
Posts: 4

Rep: Reputation: 0
I've added eepro100 using the update-modules approach described above. Still no connection. Any help, greatly appreciated.
 
Old 05-04-2004, 05:07 PM   #13
Dead Parrot
Senior Member
 
Registered: Mar 2004
Distribution: Debian GNU/kFreeBSD
Posts: 1,597

Rep: Reputation: 46
Quote:
I've added eepro100 using the update-modules approach described above. Still no connection. Any help, greatly appreciated.
Did you reboot (or restart networking with the "/etc/init.d/networking restart" command)?

If that doesn't seem to work, "su" to root and try "modconf" command. modconf offers you a graphical way to load the eepro100 module. Then restart networking as already suggested.
 
Old 05-04-2004, 07:06 PM   #14
CBlue
Member
 
Registered: Mar 2004
Location: South Carolina, USA
Distribution: Mepis
Posts: 287

Rep: Reputation: 30
Just add your ethernet with the alias eth0 yourethernetmodulename to your /etc/modutils/aliases file and then reboot. That's what I did when I lost my ethernet module after upgrading recently.
 
Old 05-04-2004, 08:14 PM   #15
edwardOG
LQ Newbie
 
Registered: May 2004
Posts: 12

Rep: Reputation: 0
Try using epro100 or e100 instead of eepro100.

I believe the eepro100 driver was the open source reverse enginering effort to figure out Intel's drivers. Since then, Intel has released Linux drivers in the form of epro100 (and I seemed to have fixed my connection by installing the e100 driver using modconf on debian).
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
apt-get question: dist-upgrade vs upgrade Arodef Fedora 9 06-15-2012 02:33 PM
safe to dist-upgrade yet? jnev Ubuntu 32 10-24-2005 06:48 AM
apt-get dist-upgrade bosewicht Debian 5 10-24-2003 02:08 PM
Error trying to dist-upgrade or upgrade KDE prophet621 Linux - Newbie 0 09-10-2003 05:17 PM
dist-upgrade slinkyredfoot Debian 1 08-03-2003 08:25 PM


All times are GMT -5. The time now is 10:55 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration